Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-20-2012, 04:58 AM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
BT Audio

Quick question, when I use my Android phone for bluetooth audio streaming, no song info on the I Drive, if I were to use a USB cable, would I see this info, also would I able to
control via the I drive instead of the phone, seems that Android phone are the bastard stepchild of BMW.
__________________
Reply With Quote
Ads by Google
  #2  
Old 11-20-2012, 08:55 AM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Streaming:

Depends. What phone are you using? Another thing is what app you're using. If its the built-in song player, then the audio's meta data will be shown on the iDrive. However, if you are using streaming audio apps, such as Pandora/MOG/Spotify, etc, no, you won't get any meta data, but you can use the steering wheel controls to skip songs.

Plugged in:

Also a little iffy. My newer Galaxy S3 is quite finicky and sometimes doesn't get recognized when I plug it into the USB, but you also have to make sure what "USB mode" its in. If you have music on the internal storage and you plug it in (and it mounts correctly), theoretically, it should work fine. All meta data info plus album art. But you won't be able to use Pandora/etc over USB because BMW doesn't support that yet.


Yes, BMW seems to hate Android
Reply With Quote
  #3  
Old 11-20-2012, 09:20 AM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
Quote:
Originally Posted by AutoUnion View Post
Streaming:

Depends. What phone are you using? Another thing is what app you're using. If its the built-in song player, then the audio's meta data will be shown on the iDrive. However, if you are using streaming audio apps, such as Pandora/MOG/Spotify, etc, no, you won't get any meta data, but you can use the steering wheel controls to skip songs.

Plugged in:

Also a little iffy. My newer Galaxy S3 is quite finicky and sometimes doesn't get recognized when I plug it into the USB, but you also have to make sure what "USB mode" its in. If you have music on the internal storage and you plug it in (and it mounts correctly), theoretically, it should work fine. All meta data info plus album art. But you won't be able to use Pandora/etc over USB because BMW doesn't support that yet.


Yes, BMW seems to hate Android
Thanks for the info, I am using a Motorola Atrix 2, BT streaming works with the apps, steering wheel controls do not work to skip songs though at least on my particular phone.
__________________
Reply With Quote
  #4  
Old 11-21-2012, 10:46 AM
RPsX5d RPsX5d is offline
Officially Welcomed to the 'Fest
Location: Bay Area California
 
Join Date: Nov 2010
Posts: 606
Mein Auto: X5 Diesel xDrive35d
These comments are for an iPhone 5 . . . may or may not match OP's Android case. Writing this post in case folks with iPhones are reading this thread.

I have the BMW supplied Y-cable - MY 2011, June 2010 build.

When iPhone is connected to the Y-cable, everything works - playlists are displayed on iDrive, iDrive controls and steering switches all work.

When iPhone is connected via a BT audio (I use Blackberry Music Gateway plugged into the audio jack) only audio part works - i.e. you can hear the song/podcast but nothing else. All you control from the steering wheel is volume.

By mistake I left the USB end of the Y-cable plugged in (with iPod attached to the Y-cable) and plugged the BB Music Gateway to the audio jack. In this case I saw the *iPod* (not iPhone 5) playlist on the iDrive but the audio was from my iPhone 5.
Reply With Quote
  #5  
Old 11-21-2012, 06:59 PM
macming macming is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Sep 2012
Posts: 112
Mein Auto: E46 M3, 2011 X5 35i
What does the Y cable get you that a regular iphone USB cable doesn't?


Quote:
Originally Posted by RPsX5d View Post
These comments are for an iPhone 5 . . . may or may not match OP's Android case. Writing this post in case folks with iPhones are reading this thread.

I have the BMW supplied Y-cable - MY 2011, June 2010 build.

When iPhone is connected to the Y-cable, everything works - playlists are displayed on iDrive, iDrive controls and steering switches all work.

When iPhone is connected via a BT audio (I use Blackberry Music Gateway plugged into the audio jack) only audio part works - i.e. you can hear the song/podcast but nothing else. All you control from the steering wheel is volume.

By mistake I left the USB end of the Y-cable plugged in (with iPod attached to the Y-cable) and plugged the BB Music Gateway to the audio jack. In this case I saw the *iPod* (not iPhone 5) playlist on the iDrive but the audio was from my iPhone 5.
Reply With Quote
  #6  
Old 11-21-2012, 07:01 PM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Quote:
Originally Posted by macming View Post
What does the Y cable get you that a regular iphone USB cable doesn't?
Basically nothing. As long you have the COMBOX (post 10/10 production), you don't need to use the Y cable. You can use the regular white sync cable
Reply With Quote
  #7  
Old 11-21-2012, 07:04 PM
macming macming is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Sep 2012
Posts: 112
Mein Auto: E46 M3, 2011 X5 35i
Quote:
Originally Posted by AutoUnion View Post
Basically nothing. As long you have the COMBOX (post 10/10 production), you don't need to use the Y cable. You can use the regular white sync cable
Oh, mine is Aug 10. I guess there might be some benefit?
Reply With Quote
  #8  
Old 11-21-2012, 07:05 PM
RPsX5d RPsX5d is offline
Officially Welcomed to the 'Fest
Location: Bay Area California
 
Join Date: Nov 2010
Posts: 606
Mein Auto: X5 Diesel xDrive35d
Nothing . . . mine is simply the older model (BMW audio engineer simply didn't get around to doing the obvious!) . . . missed the regular white cable by a few months . . . more cable mess but fortunately it is out of sight!

Last edited by RPsX5d; 11-21-2012 at 07:06 PM.
Reply With Quote
  #9  
Old 11-22-2012, 08:05 AM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
My wife's Infiniti, I tried using the BT Audio today with Pandora and guess what, the steering wheel controls change the station, where in my X5, no go, again BMW hates Android
__________________
Reply With Quote
  #10  
Old 11-22-2012, 10:50 AM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Quote:
Originally Posted by ductman View Post
My wife's Infiniti, I tried using the BT Audio today with Pandora and guess what, the steering wheel controls change the station, where in my X5, no go, again BMW hates Android
I just went out and tried it again. Pandora and Spotify worked perfectly on my Galaxy S3. Try again?
Reply With Quote
  #11  
Old 11-22-2012, 03:58 PM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
Quote:
Originally Posted by AutoUnion View Post
I just went out and tried it again. Pandora and Spotify worked perfectly on my Galaxy S3. Try again?
Tried again, also tried the USB ports also, BT audio streams, only way I can change songs is thru the phone itself, only the volume button works on the steering wheel.
__________________
Reply With Quote
  #12  
Old 11-22-2012, 04:12 PM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Quote:
Originally Posted by ductman View Post
Tried again, also tried the USB ports also, BT audio streams, only way I can change songs is thru the phone itself, only the volume button works on the steering wheel.
What software version are you on?
Reply With Quote
  #13  
Old 11-23-2012, 06:37 AM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
Quote:
Originally Posted by AutoUnion View Post
What software version are you on?
Multimedia Version MX-003.004.031
__________________
Reply With Quote
  #14  
Old 11-23-2012, 11:59 AM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Quote:
Originally Posted by ductman View Post
Multimedia Version MX-003.004.031
Oops, I meant what version of Android are you running?
Reply With Quote
  #15  
Old 11-23-2012, 04:07 PM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
Quote:
Originally Posted by AutoUnion View Post
Oops, I meant what version of Android are you running?
I just updated to 4.0 Gingerbread today, that also did not do the trick, thanks for your help.
__________________
Reply With Quote
  #16  
Old 11-23-2012, 04:57 PM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
Quote:
Originally Posted by ductman View Post
I just updated to 4.0 Gingerbread today, that also did not do the trick, thanks for your help.
4.0 is ICS, not Gingerbread

Maybe you need to update your bluetooth update for the iDrive?

(from www.bmw.com/bluetooth , enter your VIN and put the firmware bin file on a USB stick and upload the file into your iDrive via the BMW Firmware Update section.)


If that doesn't work, then it has to be something with Motorola's software. All my old Sammy and HTC Android phones work fine with the iDrive's A2DP controls.


This whole situation is weird because both the Atrix and iDrive support A2DP (streaming BT audio) and AVRCP (BT controls), yet they don't seem to like each other
Reply With Quote
  #17  
Old 11-23-2012, 04:59 PM
AutoUnion's Avatar
AutoUnion AutoUnion is offline
Officially Welcomed to the 'Fest
Location: New England
 
Join Date: Apr 2005
Posts: 5,140
Mein Auto: German
UPDATE: just looked at BMW's website and it specifically outlines that "fast forward/reverse" isn't supported, but does say that it can be operated "via control display"

Reply With Quote
  #18  
Old 11-23-2012, 05:45 PM
ductman's Avatar
ductman ductman is offline
Officially Welcomed to the 'Fest
Location: Eastern Pa
 
Join Date: Dec 2011
Posts: 776
Mein Auto: 2011 X5 35D /2011 M37X
Quote:
Originally Posted by AutoUnion View Post
UPDATE: just looked at BMW's website and it specifically outlines that "fast forward/reverse" isn't supported, but does say that it can be operated "via control display"

Just got it to work finally, it will only work thru the I Drive controller ( Pushing down ) on the
" fast forward/reverse " that supposedly is not supported but it will still not work thru the steering wheel controls, again thanks for your time.
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms