Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-08-2012, 04:33 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
Radio Aux input question

Hey guys I just purchased a 2007 335I Hard top convertable, I have a question on the audios aux input in the console, I turn the radio to AUX, and use a cable from my iphone into the Aux port but I get no music. I would asume that if my itunes is playing and i use the headphone output jack on my iphone into the AUX, and AUX is selected on my radio I would get music but NO GO, I have not tried my Ipod yet, any suggestion?

I dont have an Idrive thing, just a regular type radio

Hondo
Reply With Quote
Ads by Google
  #2  
Old 11-08-2012, 05:54 AM
bmwrocks's Avatar
bmwrocks bmwrocks is offline
Officially Welcomed to the 'Fest
Location: Winter Park, FL
 
Join Date: Oct 2003
Posts: 257
Mein Auto: 2011 328i Convertible
It could be the cable. Each one of the bands on the miniplug represents a channel. If the plug doesn't make proper contact with the bands within your phone, or the bands within the aux port, you will get no sound. Try pulling the plug out a bit from your phone while the music is playing to see if it makes contact and you hear something. Worth a try.
__________________
2011 328i Convertible : Mineral White; Oyster/Black Dakota Leather; Premium, Sport, Value; Sport Wheel w/paddles; Heated Front Seats; Satellite radio; HK Sound
2012 528i Sedan : Titanium Silver; Oyster/Black Dakota Leather; Anthracite Wood; Comfort Access; Side & Top View Cameras; Cold Weather, Premium; Technology;
2004 330ci : Titanium Silver; Gray Leather; Premium, Sport; Fold Down Rear Seats; Xenon Headlights; Navigation System; HK Sound
2001 X5, 2009 528i (retired)
Reply With Quote
  #3  
Old 11-08-2012, 11:05 AM
Towelie Towelie is offline
Registered User
Location: Midwest
 
Join Date: Dec 2007
Posts: 36
Mein Auto: E90 335xi 6MT
Make sure the volume is turned way up on your iPhone / iPod. There is also a separate input level control for the aux input that can be found under the options on the radio head unit (sorry, can't recall exactly how to get to this, but pretty sure you need to have aux selected before going into the menu).
Reply With Quote
  #4  
Old 11-08-2012, 02:33 PM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
well I have selected Aux, I have adjusted the volume on the head unit, I have checked the audio cable on another tuner inside my house, and I also tried my Ipod and I phone,
everything else on the car works, so either I am not doing something right or the aux port is not working, maybe a trip to the BMW place
I also have a USB port, is that for charging only? because if I hook the USB cable to my Iphone it charges but no music

Hondo
Reply With Quote
  #5  
Old 11-08-2012, 05:10 PM
Nordic_Kat's Avatar
Nordic_Kat Nordic_Kat is offline
Omnia in modum
Location: Texas
 
Join Date: Aug 2009
Posts: 7,226
Mein Auto: Certified Garage Princess
Quote:
Originally Posted by hondo402000 View Post
well I have selected Aux, I have adjusted the volume on the head unit, I have checked the audio cable on another tuner inside my house, and I also tried my Ipod and I phone,
everything else on the car works, so either I am not doing something right or the aux port is not working, maybe a trip to the BMW place
I also have a USB port, is that for charging only? because if I hook the USB cable to my Iphone it charges but no music

Hondo
You will have to do a search to get the actual name of the cable (its something like FL6-Y) but for 2007-2009 E93s you needed this Y-Cable to hook an iphone or ipod up and get it controlled through the radio. The cable has one aux jack, one usb connector and one Apple (13 pin?) connector. If you want to go the short and easy route and have the USB connector inside the armrest, just download all your music onto a USB flash (thumb) drive, plug it into the usb port, then choose usb from the input source on your radio. It will take a while to parse the list, but eventually you can sort by album, song title etc via the display panel on your radio. You can even import playlists as long as they are in *.m3u format. There were a lot of posts about this so do a search and you will find a ton of information.

Good Luck.
__________________
If your sport doesn't put blood, dirt or grease under your fingernails,
then it's just a game.

Euro Modded|Split Armrest|Rear Foglight Mod|BMW Performance Exhaust|CDV Delete|Shark Fin Antenna Delete|Front Reflector Delete|LUX H8 Angel Eyes|328i|3 Pedals|Das Fahren im Freien| BMWCCA#445793
Reply With Quote
  #6  
Old 11-09-2012, 02:12 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
I will do a search and see what I can find out, however, my head unit doesnt give me the option of USB, only tuner, CD or AUX, I would most likely find out faster at the BMW Palace

thanks
Hondo
Reply With Quote
  #7  
Old 11-09-2012, 04:45 AM
jmsent jmsent is offline
Officially Welcomed to the 'Fest
Location: Chicago
 
Join Date: Sep 2006
Posts: 779
Mein Auto: 07 335i Coupe
Quote:
Originally Posted by hondo402000 View Post
I will do a search and see what I can find out, however, my head unit doesnt give me the option of USB, only tuner, CD or AUX, I would most likely find out faster at the BMW Palace

thanks
Hondo
It should work as you describe. You should still try another cable, because the jacks tend to be touchy. Also make sure the plug is all the way in. Often when you hit the first detent with the plug you are fooled into thinking it's plugged all the way in. Just give it one more push.
__________________
07 335i COUPE-SPACE GRAY-STEP-SPORT-PREMIUM-COLD-SIRIUS-RFT DELETE
Reply With Quote
  #8  
Old 11-09-2012, 05:21 AM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by hondo402000 View Post
well I have selected Aux, I have adjusted the volume on the head unit, I have checked the audio cable on another tuner inside my house, and I also tried my Ipod and I phone,
everything else on the car works, so either I am not doing something right or the aux port is not working, maybe a trip to the BMW place
I also have a USB port, is that for charging only? because if I hook the USB cable to my Iphone it charges but no music

Hondo
Quote:
Originally Posted by hondo402000 View Post
I will do a search and see what I can find out, however, my head unit doesnt give me the option of USB, only tuner, CD or AUX, I would most likely find out faster at the BMW Palace

thanks
Hondo
Somehow the MULF unit in your car is defective or simply removed by whoever sold you that car. It is not that unusual for that to happen with used BMWs.

MULF = USB + AUX

That's the reason this is not working at all.
Reply With Quote
  #9  
Old 11-09-2012, 05:58 AM
gpburdell gpburdell is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Sep 2012
Posts: 404
Mein Auto: 2010 335i Cabrio
hondo402000: Where is the USB port you mention? Glovebox or next to the AUX jack? If nothing next to the AUX jack, then the USB won't work with an ipod/iphone.


Quote:
Originally Posted by Nordic_Kat View Post
for 2007-2009 E93s you needed this Y-Cable to hook an iphone or ipod up and get it controlled through the radio. The cable has one aux jack, one usb connector and one Apple (13 pin?) connector.
Search "BMW iDrive Cable" on Amazon.com and choose one of the ~$20 cables. I have the neXplug iPod Adapter one and it works great. (BTW 2010's also need the Y cable, the new combox didn't come out until early 2011MY)
Reply With Quote
  #10  
Old 11-09-2012, 08:24 AM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by gpburdell View Post
hondo402000: Where is the USB port you mention? Glovebox or next to the AUX jack? If nothing next to the AUX jack, then the USB won't work with an ipod/iphone.

Search "BMW iDrive Cable" on Amazon.com and choose one of the ~$20 cables. I have the neXplug iPod Adapter one and it works great. (BTW 2010's also need the Y cable, the new combox didn't come out until early 2011MY)
The OP already stated 4 facts:

- the AUX have no sound
- MY2007
- USB port (meaning, center console location as this is a MY2007)
- USB not showing in the Professional Radio Audio menu

Before the OP goes and spend $20 in a cable that may be connected to nothing, let the OP check if in fact there is a MULF unit in his car.
Reply With Quote
  #11  
Old 11-09-2012, 11:11 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
I went to the BMW dealer today, seems the Aux port is not working. the tech told me in my 2007 car, the AUX port will only operate an Ipod thru the headphone jack, he checked the USB port which is adjacent to the AUX port, the USB only charges the ipod and its working, so he said it could be just the actual AUX port itself thats not working or it could be the head unit AUX is not working. but I did find out! Now to deterimine If I want to spend the money to fix it

thanks
Hondo
Reply With Quote
  #12  
Old 11-09-2012, 11:30 AM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by hondo402000 View Post
I went to the BMW dealer today, seems the Aux port is not working. the tech told me in my 2007 car, the AUX port will only operate an Ipod thru the headphone jack, he checked the USB port which is adjacent to the AUX port, the USB only charges the ipod and its working, so he said it could be just the actual AUX port itself thats not working or it could be the head unit AUX is not working. but I did find out! Now to deterimine If I want to spend the money to fix it

thanks
Hondo
The AUX works via the MULF, not the radio.

Can you see the USB selection at the radio Audio menu now?

Last edited by Technic; 11-09-2012 at 11:33 AM.
Reply With Quote
  #13  
Old 11-09-2012, 11:47 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
no there is no USB function on the radio menu, when I press the audio button only Tuner, CD, AUX show up
what is the MULF?

if the radio head unit shows AUX, what is it for if not associated with the AUX port?

I can only go by what the BMW guys told me and that is if the AUX button is pressed and I plug my Ipod headphone out to the AUX in, I should get music but I have to select songs thru the IPod menu.

Hondo
Reply With Quote
  #14  
Old 11-09-2012, 12:15 PM
gpburdell gpburdell is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Sep 2012
Posts: 404
Mein Auto: 2010 335i Cabrio
Quote:
Originally Posted by Technic View Post
Before the OP goes and spend $20 in a cable that may be connected to nothing, let the OP check if in fact there is a MULF unit in his car.
Where did I suggest he NOT check for a MULF unit before buying a cable?

I didn't think it necessary to explicitly direct the OP to perform the free look-for-the-MULF step *before* the $20 order-a-cable-and-wait-for-days step. Perhaps I'm overly optimistic, but I assumed the OP was smart enough to do the no-cost step first. (and strictly speaking, my cable mention was merely offering an alternative source and not a recommendation that the cable would solve the OP's issues)

Last edited by gpburdell; 11-09-2012 at 12:18 PM.
Reply With Quote
  #15  
Old 11-09-2012, 01:18 PM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by hondo402000 View Post
no there is no USB function on the radio menu, when I press the audio button only Tuner, CD, AUX show up
what is the MULF?

if the radio head unit shows AUX, what is it for if not associated with the AUX port?
I can only go by what the BMW guys told me and that is if the AUX button is pressed and I plug my Ipod headphone out to the AUX in, I should get music but I have to select songs thru the IPod menu.

Hondo
I would guess that no music is heard via AUX when you plug the iPod headphone jack to the AUX port, regardless of the volume of the iPod and the radio, correct?

The MULF is the module that controls the USB and the AUX port, as stated before.

By not having sound via the AUX, just having charging power via the USB and not having the USB selection when an USB device is plugged into the USB then the logical conclusion is that there could be something wrong with the MULF module.

The technician should have determined that without wasting your time.

At least it is a fact that there is a MULF installed in your car. My advice is to get a cheap USB stick, put some MP3 songs in it and try it in that USB port. You should see the USB selection in the radio and the songs should play.

If the USB shows up in the radio menu, and music plays fine then the USB section is functional but somehow the AUX port is defective. It could be the actual port jack, the wiring between the jack and the MULF or the MULF itself. Getting the OEM "Y" iPod cable will not help as you will have control and display of the iPod contents via the radio but no sound. Sound with the OEM "Y" cable is routed via AUX... the same AUX that is defective.

If nothing happens -no USB in the menu, no songs played with the USB stick- then the module must be defective; when both the USB and the AUX are defective then it must be the MULF itself that it is defective -they do not share any cabling or the ports.
Reply With Quote
  #16  
Old 11-09-2012, 01:20 PM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by gpburdell View Post
Where did I suggest he NOT check for a MULF unit before buying a cable?

I didn't think it necessary to explicitly direct the OP to perform the free look-for-the-MULF step *before* the $20 order-a-cable-and-wait-for-days step. Perhaps I'm overly optimistic, but I assumed the OP was smart enough to do the no-cost step first. (and strictly speaking, my cable mention was merely offering an alternative source and not a recommendation that the cable would solve the OP's issues)
Just calm down. This is not a pissing contest.
Reply With Quote
  #17  
Old 11-09-2012, 03:40 PM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
Well the good news, I bought the car at car max, they have a 30 day fix almost anything that goes wrong, went by told them the problem and they said they would fix it

so keep you posted as to what the problem is or was

Hondo
Reply With Quote
  #18  
Old 11-09-2012, 04:10 PM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by hondo402000 View Post
Well the good news, I bought the car at car max, they have a 30 day fix almost anything that goes wrong, went by told them the problem and they said they would fix it

so keep you posted as to what the problem is or was

Hondo
Reply With Quote
  #19  
Old 11-09-2012, 04:13 PM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
for now!
Reply With Quote
  #20  
Old 11-10-2012, 07:10 AM
gpburdell gpburdell is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Sep 2012
Posts: 404
Mein Auto: 2010 335i Cabrio
Quote:
Originally Posted by Technic View Post
Just calm down. This is not a pissing contest.
I'm perfectly calm, just clarifying my statements in light of an apparent misunderstanding. You have plenty of knowledge and its great that you volunteer your time helping others, no pissing contest necessary.

Last edited by gpburdell; 11-10-2012 at 07:46 AM.
Reply With Quote
  #21  
Old 11-10-2012, 08:40 AM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,807
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by gpburdell View Post
I'm perfectly calm, just clarifying my statements in light of an apparent misunderstanding. You have plenty of knowledge and its great that you volunteer your time helping others, no pissing contest necessary.
No problem here... have a nice weekend.
Reply With Quote
  #22  
Old 11-16-2012, 07:18 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
well just got back from CarMax where I purchased the car, they said the aux cable was bad, I have no idea how they confirmed that, but said they had to get the radio out because there were sever different cables and had to get a SN off the head unit to get the correct cable and I didnt want to leave the car there for the weekend so they reschedulded me for 11-26 so they can have the car all day. My question is does anyone know how difficult it is to get the head unit and center consol out? If there is a chance they will destroy the dash getting a new AUX cable installed I might tell them just to forget it

thanks
Hondo
Reply With Quote
  #23  
Old 11-16-2012, 09:17 AM
haskindm haskindm is offline
Officially Welcomed to the 'Fest
Location: Southern Maryland
 
Join Date: Jun 2011
Posts: 396
Mein Auto: 335I Convertible
Any Auxiliary Cable should work. It should have a male stereo headphone jack at each end. Just go from the headphone jack on your i-pad, phone, mp3 player, walkman, etc to the aux jack in your console. In your radio INPUT SCREEN (where you can adjust the tone, and balance and fade) you will see an adjustment for the auxiliary input volume - adjust it to mid-range. If it is set to 0 the radio cannnot "hear" your device. This is not rocket science and there is absolutely no need to remove the radio. The cable you need should cost less than $10.
Reply With Quote
  #24  
Old 11-16-2012, 09:32 AM
hondo402000 hondo402000 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Nov 2012
Posts: 1,596
Mein Auto: 2007-335 HTC
there again, it is NOT the input cable, I have checked the cable I am using on my 4 runner and the AUX works fine, its either the Aux socket thats not working or a wire is loose on the head unit

still working on it

thanks
Hondo
Reply With Quote
  #25  
Old 11-16-2012, 10:58 AM
haskindm haskindm is offline
Officially Welcomed to the 'Fest
Location: Southern Maryland
 
Join Date: Jun 2011
Posts: 396
Mein Auto: 335I Convertible
Quote:
Originally Posted by hondo402000 View Post
there again, it is NOT the input cable, I have checked the cable I am using on my 4 runner and the AUX works fine, its either the Aux socket thats not working or a wire is loose on the head unit

still working on it

thanks
Hondo
Have you checked the AUDIO INPUT volume on the radio? It must be set to something other than "0" for your auxiliary jack to work. A bad jack or cable will USUALLY give you static or only one channel (left side/right side) will work. No sound at all would indicate that your input volume is set to "0". Do you hear anything when you pug the cable in? You should hear a "pop" at least.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms