Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-27-2012, 08:09 AM
jmears jmears is offline
Biggles
Location: England
 
Join Date: Nov 2012
Posts: 6
Send a message via Skype™ to jmears
Mein Auto: 520i
Wiper problem

Hi everyone, can any of you suggest why my wipers will not switch off unless I shut the ignition off?
I have a 98 520i auto with 133k on the clock and love everything about it except maybe the fuel consumption (Petrol) I get 35 on a good long run but only 26 at other times.

The only way I can stop them is to pull number 1 fuse but this is obviously a real pain.
I have scoured the forum but so far been unable to find a thread dealing with this particular fault.
Hope someone can help me.

Biggles
Reply With Quote
Ads by Google
  #2  
Old 11-27-2012, 09:23 AM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,896
Mein Auto: '97 540i 6 speed
It's possible that the park switch in the wiper gearbox is dirty or broken.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 11-27-2012, 09:42 AM
vavet5308 vavet5308 is offline
NADAVAN
Location: Mechanicsville, VA
 
Join Date: Dec 2005
Posts: 503
Mein Auto: 2002 525it
The wiring diagram is a little vague as to the actual operation. There is a relay in the electronics box on the right side of the engine compartment in the back (under the microfilter housing I think). I suppose that relay could be stuck. I'd start there.

My original thought was that it was a fail-safe type of thing with the general module turning on the wipers because it didn't see the input from the switch. That could certainly be the case. The description of the circuit doesn't confirm that's the scheme of operation though.

Here's the wiring diagram I'm using. I don't know all the specifics of your car, but I'm assuming it's a right hand drive.
http://www.bmw-planet.com/diagrams/r...9old/index.htm
Reply With Quote
  #4  
Old 11-28-2012, 02:02 AM
jmears jmears is offline
Biggles
Location: England
 
Join Date: Nov 2012
Posts: 6
Send a message via Skype™ to jmears
Mein Auto: 520i
Thanks for your response guys.
However, (vavet5308) I cannot get the wiring diagram to open in the 'search' window. I think it may not work on a Mac?

Cheers,

John
Reply With Quote
  #5  
Old 11-28-2012, 03:08 AM
vavet5308 vavet5308 is offline
NADAVAN
Location: Mechanicsville, VA
 
Join Date: Dec 2005
Posts: 503
Mein Auto: 2002 525it
Quote:
Originally Posted by jmears View Post
Thanks for your response guys.
However, (vavet5308) I cannot get the wiring diagram to open in the 'search' window. I think it may not work on a Mac?

Cheers,

John
It might not be compatible with Mac. I find it works better in Internet Explorer than in Firefox. Try a different browser if you have one.
Reply With Quote
Reply

Bookmarks

Tags
can't switch off, wipers


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms