Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-29-2012, 10:50 AM
NorthWest85 NorthWest85 is offline
Registered User
Location: Oregon
 
Join Date: Nov 2012
Posts: 1
Mein Auto: 1995 BMW 525i
Ignition Issue

I have a 1995 525i BMW and my ignition does not engage. The problem: I put the key in and it will turn all the way to the start position but I do not feel the tumbler engage anything as I turn it. The Electrical doesn't come on, the steering doesn't unlock, and I cannot change my gear from Park to Neutral. It acts as if there isn't a key in the ignition but when I remove the key and open my door I get the "Key in Ignition" warning. My question is: Do I need to just simply replace the ignition barrel and or do I need to remove the entire assembly and replace it? Or is there a whole other problem I'm not seeing? Help is greatly appreciated. Thanks
Reply With Quote
Advertisement
  #2  
Old 11-29-2012, 02:41 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Is this an EWSII related issue ? Please google that for more info, or maybe someone else will confirm. If it is, then you'll find the fix right here :

http://www.bimmerfest.com/forums/sho...d.php?t=536505
Reply With Quote
  #3  
Old 11-29-2012, 03:26 PM
supertech777's Avatar
supertech777 supertech777 is offline
Officially Welcomed to the 'Fest
Location: springfield , missouri
 
Join Date: May 2008
Posts: 758
Mein Auto: 1995 525i
Quote:
Originally Posted by NorthWest85 View Post
I have a 1995 525i BMW and my ignition does not engage. The problem: I put the key in and it will turn all the way to the start position but I do not feel the tumbler engage anything as I turn it. The Electrical doesn't come on, the steering doesn't unlock, and I cannot change my gear from Park to Neutral. It acts as if there isn't a key in the ignition but when I remove the key and open my door I get the "Key in Ignition" warning. My question is: Do I need to just simply replace the ignition barrel and or do I need to remove the entire assembly and replace it? Or is there a whole other problem I'm not seeing? Help is greatly appreciated. Thanks
I just did this and mine turned out to be the ignition housing itself , it has sheared off and not engaging the ignition switch and lock . You can find the procedure in YouTube its simple just time consuming . The guy in YouTube was working on a e36 and its the same as our e34 . Goodluck . One thing for sure is diconect your battery before you take the airbag off , so it doesn't trigger a fault on the dash

Sent from my Desire HD using Bimmer App
Reply With Quote
  #4  
Old 11-29-2012, 04:35 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
I agree with Noel (Supertech777). I don't think that it is an EWS II issue.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #5  
Old 11-29-2012, 07:12 PM
supertech777's Avatar
supertech777 supertech777 is offline
Officially Welcomed to the 'Fest
Location: springfield , missouri
 
Join Date: May 2008
Posts: 758
Mein Auto: 1995 525i
Quote:
Originally Posted by BMR_LVR View Post
I agree with Noel (Supertech777). I don't think that it is an EWS II issue.
And by the way Steve thanks for walking me through my darn ignition tumbler ! Couldn't have done it without your help

Sent from my Desire HD using Bimmer App
Reply With Quote
  #6  
Old 11-29-2012, 07:56 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Quote:
Originally Posted by supertech777 View Post
And by the way Steve thanks for walking me through my darn ignition tumbler ! Couldn't have done it without your help

Sent from my Desire HD using Bimmer App
Ummmm ....... Was that me ??? I'd love to take the credit for helping you on that, but I only remember helping you with the EWS issue (of course my rapidly advancing age is taking its toll on my memory ). Unfortunately, I only know how to replace the tumbler, not the ignition housing.

Hope NorthWest85 gets it figured out. He does have to remember to mind the EWS system and the antenna ring in particular.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms