Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-17-2014, 02:17 PM
BMW_Azul BMW_Azul is online now
Registered User
Location: New York
 
Join Date: Jan 2014
Posts: 59
Mein Auto: 2006 BMW 530XI
How to fix AWD DSC EMERG EBV alarms on dash

Help on this guys... the battery has been replaced on my 06 530xi but the above alarms are the dashboard

Car at the dealer...they can't seem to know how to fix the AWD and brake functionality and get rid of the alarms....I don't know if they are trying to rip me off...by saying that is hard to fix that.....

Also they claimed that they had to program many modules on the car after the battery change!! That it took 2 whole days! !! It sounds bull**** to me...but I don't know. ..

Thanks for any information

Sent from BimmerApp mobile app
Reply With Quote
Ads by Google
  #2  
Old 04-18-2014, 12:09 AM
JocoRacing JocoRacing is online now
Joe B.
Location: Colorado
 
Join Date: Feb 2013
Posts: 54
Mein Auto: 2008 535xi
When I changed my battery (2008 535xi), when I turned it on after the new battery was installed, I got the awd malfunction and dsc malfunction which freaked me out. I drove it out of the driveway and down the street maybe 100ft then the lights went off automatically. I think the system just needed to recalibrate it's self. Are the lights in after driving it a bit still? If so I would suspect a fuse was blown during the install


Sent from BimmerApp mobile app
Reply With Quote
  #3  
Old 04-18-2014, 12:44 AM
BMW_Azul BMW_Azul is online now
Registered User
Location: New York
 
Join Date: Jan 2014
Posts: 59
Mein Auto: 2006 BMW 530XI
Thanks for the info. At the very least I know that it's a battery related problem.

The alarms have been on for about a week now.... I am very worried. And dealer BMW is not making things easier by not knowing how to fix it...

Sent from my SAMSUNG-SGH-I337 using BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms