Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-13-2014, 06:59 PM
bmw325 bmw325 is online now
Officially Welcomed to the 'Fest
Location: New York, NY
 
Join Date: Dec 2001
Posts: 8,601
Mein Auto: 528i
Bunch of coding questions (2014 NBT)

Hi-

Finally got everything setup for coding and read (and backed up) the ncd files from my car. I've been going through the NBT config and have a few questions. Also tried changing the language to UK English since I can't stand the American voice on the NBT.

I have a Feb buld 2014 528i (US). Has sport auto and msport (relevant later)

1. When I chnaged HU_NBT => 3000 => LANGUAGE_ENGLISH_UK => master I noticed that "one shot destination entry" didn't seem to work correctly. It was asking me to spell some part of the address (can't remember now). I'm guessing this is because I need to speak to say the address in a different way? Does anyone know how to say a US style address to it when the language is set to UK?

On a related note, I'm thinking of just adding UK English as another option to the list. That way i can turn it on and off when i feel like it. I'm assuing that setting LANGUAGE_4 (next open slot) to UK English and setting LANGUAGE_ENGLISH_UK to list should do the trick?

2. As some of you may know, setting "MARCO_FDS" to "popup_and_config" no longer seems to work on 2014s without electronic dampers or adaptive drive. Thanks to tokenMaster's excellent NCDCAFD tool's "what if" feature, I tried checking the electronic damper option to see if anything else got enabled. Lo and behold, it spat out 'EDC_CIC" to Activ. On EDC equipped cars, what does this do? Is there anyother idrive setting related to EDC? Trying to assess the risk of enabling it on my non EDC car to see if maybe it allows popup_and_config to actually work.

3. Does anyone have experience or knowledge with any of the following:
NAVI_ROUTE_STUDY
(hoping this enables the "learn route" function mentioned in the manual. The comments mention something about it being for Asia.)
NAVI_ONLINE_OPTIMIZATION_BUTTON
( I found a thread where someone claims they enabled this, but it sound like it needs a backend to connect to-- does BMWNA have the servers setup for this to actually work?)
NAVI_FREE_TEXT_SEARCH
HVAC_POPUP_AIRDISTR

4. Any tips on removing a stuck coding cable? Found a bunch of threads with no real answers other than "pull hard", I can't even get a good enough grip on the plug to pull hard because its small and made of smooth plastic. Obviously dont want to pull on the cable. I saw some mention of screw dirvers but I'm not exactly sure where to start prying.

That is all- my wife is going to kill me if I spend another minute on this tonight!

Thanks!
__________________

Last edited by bmw325; 06-13-2014 at 07:03 PM.
Reply With Quote
Advertisement
  #2  
Old 06-13-2014, 08:28 PM
TokenMaster's Avatar
TokenMaster TokenMaster is offline
Token Master
Location: Java Land
 
Join Date: Jul 2013
Posts: 732
Mein Auto: Coded F30
On #4, OBD port on MY2014, at least on F30, has moved slightly towards the rear and right, so you have less leverage. If you look closer at the connector, there's a small tab that locks the connector in place. You can break this tab off as it's really not needed. The connector should stay snug even without it.
__________________
Code My Bimmer| FDL Coding Video Guide -Blogspot/Youtube | TokenMaster's EST Software Token demo - Blogspot | Never download already patched E-Sys from Torrent sites
Reply With Quote
  #3  
Old 06-15-2014, 02:14 PM
bmw325 bmw325 is online now
Officially Welcomed to the 'Fest
Location: New York, NY
 
Join Date: Dec 2001
Posts: 8,601
Mein Auto: 528i
Bunch of coding questions (2014 NBT)

Quote:
Originally Posted by TokenMaster View Post
On #4, OBD port on MY2014, at least on F30, has moved slightly towards the rear and right, so you have less leverage. If you look closer at the connector, there's a small tab that locks the connector in place. You can break this tab off as it's really not needed. The connector should stay snug even without it.

Hmm-but how do I get it out of the socket for now? It's still stuck in there and I've tried: pulling, pliers and screwdriver. Spent about 30 minutes on it last night and it won't budge

Is there a certain spot I shoukd press on?


Click image for larger version

Name:	ImageUploadedByBimmerApp1402863231.880599.jpg
Views:	52
Size:	315.0 KB
ID:	445981
__________________

Last edited by bmw325; 06-15-2014 at 02:16 PM.
Reply With Quote
  #4  
Old 06-15-2014, 08:44 PM
egon0119 egon0119 is offline
Registered User
Location: PA
 
Join Date: Feb 2012
Posts: 14
Mein Auto: 2014 328i
I've had this kind of problem. The OBD2 port's latch got caught on a tab on my device. See the circled section of the image below. Putting a spudger through that window underneath the tab and prying it outwards until it cleared the port's latch finally got it free.
Attached Thumbnails
Click image for larger version

Name:	obd2-connector.jpg
Views:	26
Size:	40.6 KB
ID:	446067  
Reply With Quote
  #5  
Old 06-22-2014, 03:22 PM
bmw325 bmw325 is online now
Officially Welcomed to the 'Fest
Location: New York, NY
 
Join Date: Dec 2001
Posts: 8,601
Mein Auto: 528i
Bunch of coding questions (2014 NBT)

Quote:
Originally Posted by egon0119 View Post
I've had this kind of problem. The OBD2 port's latch got caught on a tab on my device. See the circled section of the image below. Putting a spudger through that window underneath the tab and prying it outwards until it cleared the port's latch finally got it free.

Thanks - that worked!
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms