Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-17-2012, 11:45 AM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
Rear door speakers are popping and sound blown...

As of the other day my rear speakers started popping and I don't remember turning the volume way up to where they would have simultaniously blown but who knows.. I can't see this happening at the same time and wondering if this could be a fuse or something? I remember looking on here yesterday for a thread saying it might be my L7 amp and that someone in S.F. can repair it if it is, but cannot find that thread anywhere and starting to think I am dreaming. Not even sure if that is the issue either... Car just went out of its 50k warentee awhile back and now on the bmw 100k warentee but sure they don't cover electronics. Grrrr. Guessing this will cost me another arm and leg repair IF anyone has any thoughts or recommendations I would greatly appreciate it. Guessing my BMW dealer will rape me on this one...
Reply With Quote
Advertisement
  #2  
Old 12-17-2012, 01:10 PM
dsaautocustomz's Avatar
dsaautocustomz dsaautocustomz is offline
Donny A
Location: michigan
 
Join Date: Feb 2012
Posts: 115
Mein Auto: 14 Sierra, 13 Denali XL
hey bud sorry to hear your having problems with your amp
__________________
 photo 20130520_153149_zpsfd8ec578.jpg

Last edited by PAPER; 07-02-2013 at 08:36 PM.
Reply With Quote
  #3  
Old 12-17-2012, 01:14 PM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
cool... I was just calling the salvage yard and they quoted me $450 here in sacramento with a 6 month warentee. They said this is an easy replacement and don't need to reprogram anything... Is this an easy install .... for a beginner? He said its pretty much just plug and play. Obviously I'd rather get it fixed with better components if this guy you mentioned can do that rather than run into the same problem again, but who knows. More I've looked on here it sounds like a regular issue with the amp. grrrrr... Thanks for the reponse.
Reply With Quote
  #4  
Old 12-17-2012, 01:57 PM
dsaautocustomz's Avatar
dsaautocustomz dsaautocustomz is offline
Donny A
Location: michigan
 
Join Date: Feb 2012
Posts: 115
Mein Auto: 14 Sierra, 13 Denali XL
also the guy offers you a one year warranty on his work
__________________
 photo 20130520_153149_zpsfd8ec578.jpg
Reply With Quote
  #5  
Old 12-17-2012, 03:30 PM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
How hard is the removal and install once he sends back? Shot him an email earlier so hoping to get a response.
Reply With Quote
  #6  
Old 12-17-2012, 03:32 PM
dsaautocustomz's Avatar
dsaautocustomz dsaautocustomz is offline
Donny A
Location: michigan
 
Join Date: Feb 2012
Posts: 115
Mein Auto: 14 Sierra, 13 Denali XL
Yes it is very easy to remove and put back i think rookie2008 has a video of how to do it on here or YouTube

Sent from my DROID RAZR using Bimmer App
__________________
 photo 20130520_153149_zpsfd8ec578.jpg
Reply With Quote
  #7  
Old 12-17-2012, 03:59 PM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
cool, thanks for the input. Hoping to get a response back. Also... wondering how I would for sure know its the L7 amp..? Guess if I hear from him I'll ask how I would troubleshoot..

Last edited by nagelmotox; 12-17-2012 at 04:07 PM.
Reply With Quote
  #8  
Old 12-18-2012, 08:31 AM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
you dont happen to have his phone number do you??
Reply With Quote
  #9  
Old 01-29-2013, 06:34 PM
bigeasy bigeasy is offline
Registered User
Location: Twin Cities, Minnesota
 
Join Date: Jul 2010
Posts: 3
Mein Auto: 2003 745Li
I have a 2003 745Li sounds like same problem. One day I was playing sound with deep base then it dropped out. Bass Sound came back a week later. Then out month. Then one day briefly came in/out but my basshead listening gone....

Symptoms sound like highs/mids crackly no lows.

Thoughts? I emailed him also
Reply With Quote
  #10  
Old 01-29-2013, 07:17 PM
nagelmotox nagelmotox is offline
Registered User
Location: CA
 
Join Date: Jun 2011
Posts: 82
Mein Auto: 07 BMW 750i
Is it your rear speakers and sub?
Reply With Quote
  #11  
Old 01-29-2013, 07:36 PM
bigeasy bigeasy is offline
Registered User
Location: Twin Cities, Minnesota
 
Join Date: Jul 2010
Posts: 3
Mein Auto: 2003 745Li
It is subs for sure...no appreciable sound in rear at all.
Reply With Quote
  #12  
Old 01-31-2013, 05:51 PM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
it's your logic 7 amp...... Same issues I had with mine
Reply With Quote
  #13  
Old 02-01-2013, 12:58 PM
ISIS27 ISIS27 is offline
Registered User
Location: Chicago
 
Join Date: Nov 2012
Posts: 26
Mein Auto: 2006 750Li
the L7 controls the rear door speakers and the subs under the front seat & your center speaker, the ask module (your radio) controls the front door speaker. Def sounds like the L7 is the issue, mine went out as well I am currently in the process of repairing it. Ship it out for repair or do it yourself if you can, if you get a used one, the same issue will occur garunteed, so I would just replace the components and make it better. there is 1 transitor that controls the rear door speakers and1 resistor per sub, and lastly one for the center speaker.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms