Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)

E46 M3 (2001-2006)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-17-2012, 03:04 PM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
E46 Power Seat problems

The passenger side power seat in my E46 M3 does not work. None of the power functions work. I checked the fuse already, and it is good. I also checked switch. I changed it with the drivers side. The switch works fine. Has anyone had a similar problem? I figure that it is unlikely that it is the motors, as none of functions work. Any help would be appreciated.

Thanks
Reply With Quote
Advertisement
  #2  
Old 12-17-2012, 03:31 PM
m3e46freak m3e46freak is offline
FREQ
Location: MD
 
Join Date: Dec 2012
Posts: 39
Mein Auto: m3
Sometimes if you accidentally drop stuff under the seat and try to move it will rip off some of those underlying wires...check there.
Reply With Quote
  #3  
Old 01-06-2013, 08:40 AM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
I tried looking under the seat to see if anything is disconnected, but the seat is all the way at the bottom position so I could really see if anything was disconnected or broken. I am thinking of pulling the seat out to check everything, but the seat is also in the all the way forward position. Is there anyway to manually move the seat back to access the bolts to remove the seat?
Reply With Quote
  #4  
Old 01-06-2013, 02:14 PM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
So I figured out how to disconnect the tilt up bracket and lift the bottom of the seat up and see under the seat. All the wires look like fine. I tested the connections in the front tilt motor and the forward/back motor. They are not getting the power they should. The only thing I am thinking it could be is the seat control unit. Just have to figure out how to get my hands on another one to test.

UPDATE:

I solved the problem. I found the 2 bracket (one on each side of the front of the seat) that attach the front tilt motor to the seat bottom, and removed them. This allow me to lift up the seat bottom enough to see and have access to everything under the seat. The wiring was fine, so I removed the seat control module and swapped it with the drivers seat. They both ended up working. It may have been as simple as the system being reset when I unplugged the battery or something was loose with module. In either case everything now works fine.

Last edited by his15153; 01-07-2013 at 07:14 AM.
Reply With Quote
  #5  
Old 01-07-2013, 11:02 AM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
Update #2

Now the drivers side seat stopped working. It was working, then in the middle of moving the seat it stopped. Now I am completely stumped as to what the problem could be. Its clearly not the seat motors, the control module, or the fuses. Also, after the drivers seat stopped moving, I took out the fuse and placed it back in. The seat moved for about a half a second and then stopped again.
Reply With Quote
  #6  
Old 01-07-2013, 11:19 AM
Pinecone's Avatar
Pinecone Pinecone is offline
M Mad
Location: Maryland
 
Join Date: Apr 2002
Posts: 10,480
Mein Auto: M Roadster/M3
You said that you swapped the seat control modules.

So I suspect that one that is installed in the driver's seat (which was the one that was in the passenger seat when it was not working) is bad. When you swapped them, it temporarily worked, but I would replace it.
__________________
Terry Carraway

'95 Alpine M3 LTW
'00 Dakar M Roadster
'02 Topaz M3
Red/White SRF #4 (Chassis 561)
Reply With Quote
  #7  
Old 01-08-2013, 01:21 PM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
I had swapped them back previous to the issue (so the drivers seat module is the same one as originally in the drivers seat).
Reply With Quote
  #8  
Old 01-15-2013, 08:46 AM
his15153 his15153 is offline
Registered User
Location: Miami
 
Join Date: Dec 2012
Posts: 10
Mein Auto: 2001 BMW M3
Updated. I didn't do anything, and it all started working again. I'm thinking it might have just been that the connections where a little dirty.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms