Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #651  
Old 01-17-2013, 11:18 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by sirstopher View Post
All I hear is you complaining. Why not stop while your ahead.
Well my friend, as others have said about you since you've started posting on here, your either good at brown nosing or extremely ignorant.. Just because I am the only one speaking the truth doesn't mean I am the only one who feels that way. This thread that everyone finds so interesting and wants to keep alive, you included, it's built on my saga, and I've shared every bit of information I have found every step of the way. I've spent about $1,500 learning all of this, and guess what, I figured out the problem! We didn't have everyone running off buying coolant pipes for nothing did we?

So yes, if I am a little upset that others have resolutions to our problems and won't share, I think I have a right.. Others are pissed too, and they've not contributed anything close..

I don't know what your issue is, but someone said the other day, "Sristopher will figure it out, obviously later than sooner".. So lets see how this plays out, and how long it takes to get some valid information..

Your a moderator.. you should out of everyone know these boards are all about sharing information and bettering our cars as a whole. When I realized my car was running over 105c there was NO INFORMATION on here at all about it. NOTHING but SFBay saying it's cut and dry head gaskets. Now look at the information we have.. whole cooling system replaced, down to the heater lines, and what was the issue? Electric fan.. Maybe I should edit my posts and get rid of the information..

I ripped this whole issue open on this board, nobody knew anything about it, and many didn't waste time checking their temps. I am happy to share my information and proud to get the chance to help others. You may try and turn this around trying to make it look like I am attacking SF, and trying to belittle him or something. I am simply stating the facts. I am upset he isn't sharing this information or at the very least being truthful and telling us the reason why, because him not wanting us to have to waste money isn't it. Want to know the truth? Even after all of this, I think SF is one of the smarter ones on this board, he has ALOT of good information, but I call it how I see it.

Last edited by cmpcpro; 01-17-2013 at 11:22 PM.
Reply With Quote
  #652  
Old 01-17-2013, 11:27 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Listen I am not going to keep going back on this.. lets all try and figure out how to get our temps down and move on.. If SF doesn't want to share that's on him. I just want us to all get this resolved. It will save us all money, keep our cars in better shape and hopefully stop our car values from plummeting so fast.. to me getting this resolved is a win win for everyone, and that's the best type of deal..
Reply With Quote
  #653  
Old 01-17-2013, 11:30 PM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,102
Mein Auto: POS Honda
Quote:
Originally Posted by cmpcpro View Post
Well my friend, as others have said about you since you've started posting on here, your either good at brown nosing or extremely ignorant.. Just because I am the only one speaking the truth doesn't mean I am the only one who feels that way. This thread that everyone finds so interesting and wants to keep alive, you included, it's built on my saga, and I've shared every bit of information I have found every step of the way. I've spent about $1,500 learning all of this, and guess what, I figured out the problem! We didn't have everyone running off buying coolant pipes for nothing did we?

So yes, if I am a little upset that others have resolutions to our problems and won't share, I think I have a right.. Others are pissed too, and they've not contributed anything close..

I don't know what your issue is, but someone said the other day, "Sristopher will figure it out, obviously later than sooner".. So lets see how this plays out, and how long it takes to get some valid information..

Your a moderator.. you should out of everyone know these boards are all about sharing information and bettering our cars as a whole. When I realized my car was running over 105c there was NO INFORMATION on here at all about it. NOTHING but SFBay saying it's cut and dry head gaskets. Now look at the information we have.. whole cooling system replaced, down to the heater lines, and what was the issue? Electric fan.. Maybe I should edit my posts and get rid of the information..

I ripped this whole issue open on this board, nobody knew anything about it, and many didn't waste time checking their temps. I am happy to share my information and proud to get the chance to help others. You may try and turn this around trying to make it look like I am attacking SF, and trying to belittle him or something. I am simply stating the facts. I am upset he isn't sharing this information or at the very least being truthful and telling us the reason why, because him not wanting us to have to waste money isn't it. Want to know the truth? Even after all of this, I think SF is one of the smarter ones on this board, he has ALOT of good information, but I call it how I see it.
I asked you yesterday to give the guy a break.........that's all I was saying.

But, yea..I like a brown nose and I will be the first to admit I don't know **** about these cars.
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #654  
Old 01-17-2013, 11:37 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by sirstopher View Post
I asked you yesterday to give the guy a break.........that's all I was saying.

But, yea..I like a brown nose and I will be the first to admit I don't know **** about these cars.
Well it sure seemed like you were dogging me for trying to get information to better ALL OF US.
Reply With Quote
  #655  
Old 01-17-2013, 11:39 PM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,102
Mein Auto: POS Honda
Honestly all I think I am trying to get across is that you can beat the horse all you want...., its not going to make a difference until he is ready to share or charge everyone.

I think that this thread has had great value and is the root to all of the ****ing gaskets and rubber in our cars go to crap. I am not the first one spending thousands but I can say I spent 6 grand last year and I haven't even touched the surface.

BTW I am not moderating, just being a member.
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #656  
Old 01-17-2013, 11:40 PM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,102
Mein Auto: POS Honda
Quote:
Originally Posted by cmpcpro View Post
Well it sure seemed like you were dogging me for trying to get information to better ALL OF US.
Nope, would have PMed you.
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #657  
Old 01-18-2013, 06:24 AM
First_745Li's Avatar
First_745Li First_745Li is online now
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,141
Mein Auto: '03 745Li
@ SF - How do we go about ordering the new tstat?
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold & new owner totaled it 4 hours later)
Reply With Quote
  #658  
Old 01-18-2013, 07:32 AM
rideme2's Avatar
rideme2 rideme2 is offline
rideme2
Location: new york
 
Join Date: Dec 2009
Posts: 548
Mein Auto: 2006li bmw
Yes let's forget and forgive, move on and let's get this stact on the move:-) like I said before I'm only looking to cool down the car.
__________________
2006 750li K&N Filters Giovanna Kilis on 265/30/22 305/25/22 HID fogs 6000k Mtec angel eyes all lights 6000k ACS front lip,ACS rear wing,ACS rear window wing.dual exhaust working qual tips, rear camera, upgrade DVD to front watch jl13.5t sub with jl500/1v2 amp power cap.PassPort 9500ci,CrossDrilled&Slotted Rotors with EBC Brake Pads.Rear comfort seats, Fully loaded from dealer. Next mod iPhone hookup, .
Reply With Quote
  #659  
Old 01-18-2013, 07:39 AM
First_745Li's Avatar
First_745Li First_745Li is online now
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,141
Mein Auto: '03 745Li
Quote:
Originally Posted by rideme2 View Post
Yes let's forget and forgive, move on and let's get this stact on the move:-) like I said before I'm only looking to cool down the car.
+1 Amen to that!
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold & new owner totaled it 4 hours later)
Reply With Quote
  #660  
Old 01-18-2013, 08:52 AM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by First_745Li View Post
@ SF - How do we go about ordering the new tstat?
I agreed yesterday on that 100tstats offer, so I'm waiting for their response today. That's good I speak a little deutch
Reply With Quote
  #661  
Old 01-18-2013, 09:05 AM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by cmpcpro View Post
Well it sure seemed like you were dogging me for trying to get information to better ALL OF US.
Dude, I told you in the beginning:
-replace all cooling system, incl heater core coolant pipe etc.
- if no help it might be head gaskets
So, stop saying I made you to spend 1000$.
THE WHOLE POINT OF THIS TOPIC IS NOT LOWER TEMP TSTAT, BUT THE PROPER WAY TO IDENTIFY COOLING PROBLEM. LOWER TSTAT WILL NOT FIX ANYTHING AT ALL! WITH OEM 105C the car runs for 7-10yrs easy, so it's not that bad. Problems happen only when it's not functioning properly, and the worst part is that you don't know this exact moment, bc it won't tell you. LOWER TSTAT WILL ONLY HELP TO PREVENT PROBLEMS.


No your fan didn't do a sht. In the summer you'll get 108 anyways.
Lower hose temp matters on idle.
Even with 95C my lower hose is dropping.
Reply With Quote
  #662  
Old 01-18-2013, 09:59 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by SFbay View Post
Dude, I told you in the beginning:
-replace all cooling system, incl heater core coolant pipe etc.
- if no help it might be head gaskets
So, stop saying I made you to spend 1000$.
THE WHOLE POINT OF THIS TOPIC IS NOT LOWER TEMP TSTAT, BUT THE PROPER WAY TO IDENTIFY COOLING PROBLEM. LOWER TSTAT WILL NOT FIX ANYTHING AT ALL! WITH OEM 105C the car runs for 7-10yrs easy, so it's not that bad. Problems happen only when it's not functioning properly, and the worst part is that you don't know this exact moment, bc it won't tell you. LOWER TSTAT WILL ONLY HELP TO PREVENT PROBLEMS.


No your fan didn't do a sht. In the summer you'll get 108 anyways.
Lower hose temp matters on idle.
Even with 95C my lower hose is dropping.
I am sorry but that is NOT TRUE! You may have gone back and edited it, I haven't looked, but you told me NOT to "follow in your footsteps" and make the mistakes you did and replace everything. You NEVER mentioned coolant pipe until lately, you almost to exact quote said, quit wasting money and time and just replace your head gaskets. If you can do the job, just do it.

I don't know if you are not reading what I am actually writing or just getting it all confused, but I never once said you MADE ME SPEND $1,000. I am a big boy, when I do something it's because I WANT TO.

You still won't let us know what thermostat you used.. why should it matter now if you found a company to make you thermostats? Just release it then, obviously it's a dead project, and your going a different way.
Reply With Quote
  #663  
Old 01-18-2013, 10:00 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by SFbay View Post
No your fan didn't do a sht. In the summer you'll get 108 anyways.
Lower hose temp matters on idle.
Even with 95C my lower hose is dropping.
I hear my fan going on at idle, I have no idea what lower hose temp is at, but it seems to go on fairly often.. If I step out of the car and leave it running I hear it kicking in.
Reply With Quote
  #664  
Old 01-18-2013, 10:30 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
I believe his point is fan will only help at idle speed, typically you dont routinely idle for 30 mins but i believe the main point was if there is air pockets or a leak etc etc it wont matter because your tstat wont open properly. And you will still have your leak or problem etc etc fix your problems or whatever you believe is your problem etc and then lower the temp with a tstat and your overhauls should cease or atleast double in the time in between them
We should just agree to disagree and move forward
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #665  
Old 01-18-2013, 10:43 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by 745iguy View Post
I believe his point is fan will only help at idle speed, typically you dont routinely idle for 30 mins but i believe the main point was if there is air pockets or a leak etc etc it wont matter because your tstat wont open properly. And you will still have your leak or problem etc etc fix your problems or whatever you believe is your problem etc and then lower the temp with a tstat and your overhauls should cease or atleast double in the time in between them
We should just agree to disagree and move forward
Well then what he is not understanding is, even from the get go my car has always ran at 105/103 until coming to a stop.. At a stop or under 15MPH is when the car would heat up.. Thats all. Fan resolved that.
Reply With Quote
  #666  
Old 01-18-2013, 11:22 AM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by 745iguy View Post
I believe his point is fan will only help at idle speed, typically you dont routinely idle for 30 mins but i believe the main point was if there is air pockets or a leak etc etc it wont matter because your tstat wont open properly. And you will still have your leak or problem etc etc fix your problems or whatever you believe is your problem etc and then lower the temp with a tstat and your overhauls should cease or atleast double in the time in between them
We should just agree to disagree and move forward
+100
If there is a problem with the system and if aux wp is making noise after you shut off the engine, it means you've got air bubbles and if you do it means your engine cooling is inefficient on any loads (idle or running) which leads to serious problems.
Lower hose has to be 65+ on idle without dropping.

Last edited by SFbay; 01-18-2013 at 11:27 AM.
Reply With Quote
  #667  
Old 01-18-2013, 12:54 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by SFbay View Post
+100
If there is a problem with the system and if aux wp is making noise after you shut off the engine, it means you've got air bubbles and if you do it means your engine cooling is inefficient on any loads (idle or running) which leads to serious problems.
Lower hose has to be 65+ on idle without dropping.
My aux pump doesn't make any noise anymore, and fan is kicking on at idle..

Now that I am running correctly I was trying to find the thermostat you used so I could try and make it work.. there should be no reason why you can't release that information..
Reply With Quote
  #668  
Old 01-18-2013, 05:14 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by cmpcpro View Post
My aux pump doesn't make any noise anymore, and fan is kicking on at idle..

Now that I am running correctly I was trying to find the thermostat you used so I could try and make it work.. there should be no reason why you can't release that information..
And waterpump isn't making any gurgling noise anymore??? Or was it alternator noise?
I told you I'm a little bored documenting my mod, bc it's useless if you can get factory 95c tstat from that company.
Reply With Quote
  #669  
Old 01-18-2013, 07:01 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by SFbay View Post
And waterpump isn't making any gurgling noise anymore??? Or was it alternator noise?
I told you I'm a little bored documenting my mod, bc it's useless if you can get factory 95c tstat from that company.
It's not useless to me, even if I only use it for two months.. I would REALLY APPRECIATE if you could just let us know what it was, I drive maybe 30-40 miles a day and it's all bumper to bumper traffic, it's killing me that this car is running at 105 when most are at 85c..

My aux pump is brand new and making no noise. My alt. doesn't seem to be making noise but the noises I heard before WAS my aux pump, but that is all gone now. Also, I bought the three heater hoses from the firewall (heater core).

EDIT: Oh your talking about that noise when the car starts? It still happens only when cold but I think it's a broken pipe for the sec. air system, I may be wrong but I don't have a working INPA anymore to get into the engine.. I upgraded my ver. to 5.0.2 and now I have a no module found error for motor.. would have to dig out my DVD w/ 3.0 but even that doesn't allow me to reset DME adaptations.

Last edited by cmpcpro; 01-18-2013 at 07:03 PM.
Reply With Quote
  #670  
Old 01-19-2013, 03:10 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Quote:
Originally Posted by cmpcpro View Post
Well then what he is not understanding is, even from the get go my car has always ran at 105/103 until coming to a stop.. At a stop or under 15MPH is when the car would heat up.. Thats all. Fan resolved that.
Thats what scares me. If i cant get this done before summer who knows what more ill have to change out because my engine likes to fry rubber prematurely
My car wouldnt reach 105 in this current weather at idle unless i drove hard on the highway then pull over and idle for 20+mins. it was 25F today here. summers 90+ and i think in the summer ill be ruined. I started getting leaks by the fall that i had to start replacing probably all from over the summer and the fact the car is older now and maybe even had original parts for most of what i changed out. i will be changing my alt bracket gasket next week, and its a shame i cant get the tstat now, because when i do that id just drain the block flush with prep and replace with evans and install tstat all at that same time since ill be draining to take out the alt anyway. I will have to wait and see what happens with this now and hope nothing else happens until then
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #671  
Old 01-19-2013, 06:24 AM
rideme2's Avatar
rideme2 rideme2 is offline
rideme2
Location: new york
 
Join Date: Dec 2009
Posts: 548
Mein Auto: 2006li bmw
What happeneds if you over filled you cooling???? Those it comes out some where??
__________________
2006 750li K&N Filters Giovanna Kilis on 265/30/22 305/25/22 HID fogs 6000k Mtec angel eyes all lights 6000k ACS front lip,ACS rear wing,ACS rear window wing.dual exhaust working qual tips, rear camera, upgrade DVD to front watch jl13.5t sub with jl500/1v2 amp power cap.PassPort 9500ci,CrossDrilled&Slotted Rotors with EBC Brake Pads.Rear comfort seats, Fully loaded from dealer. Next mod iPhone hookup, .
Reply With Quote
  #672  
Old 01-19-2013, 09:49 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
If you overfill you are creating too much pressure, it will release the cap when hot and overflow from expansion.
Reply With Quote
  #673  
Old 01-19-2013, 10:43 AM
rideme2's Avatar
rideme2 rideme2 is offline
rideme2
Location: new york
 
Join Date: Dec 2009
Posts: 548
Mein Auto: 2006li bmw
Ok so my problem is that two wks ago I changed the cooling pipe. All good but I found antifreeze on the ground two days later. On the passenger side behind the front wheel. The front of engine is bone dry. I checked the heater coil hose and dry. Right now I just finish changing the tranny tsact. Drained all the cooling AGAIN dry up the whole engine bay left car on lift for two hours no leak??? I'm waiting for car to cool down so I can fill up the cooling again. I was hoped that there a drain so where for the over flow??? I lost about two cups of antifreeze on my floor?
__________________
2006 750li K&N Filters Giovanna Kilis on 265/30/22 305/25/22 HID fogs 6000k Mtec angel eyes all lights 6000k ACS front lip,ACS rear wing,ACS rear window wing.dual exhaust working qual tips, rear camera, upgrade DVD to front watch jl13.5t sub with jl500/1v2 amp power cap.PassPort 9500ci,CrossDrilled&Slotted Rotors with EBC Brake Pads.Rear comfort seats, Fully loaded from dealer. Next mod iPhone hookup, .
Reply With Quote
  #674  
Old 01-19-2013, 10:59 AM
dolfan13's Avatar
dolfan13 dolfan13 is offline
Officially Welcomed to the 'Fest
Location: lexington,ky usa
 
Join Date: Jan 2011
Posts: 797
Mein Auto: 545i
Might try the glow stuff for leak check.Auto parts places sell it.Some comes with a special light.


Sent from my M975 using Bimmer App
Reply With Quote
  #675  
Old 01-19-2013, 12:21 PM
First_745Li's Avatar
First_745Li First_745Li is online now
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,141
Mein Auto: '03 745Li
Quote:
Originally Posted by rideme2 View Post
Ok so my problem is that two wks ago I changed the cooling pipe. All good but I found antifreeze on the ground two days later. On the passenger side behind the front wheel. The front of engine is bone dry. I checked the heater coil hose and dry. Right now I just finish changing the tranny tsact. Drained all the cooling AGAIN dry up the whole engine bay left car on lift for two hours no leak??? I'm waiting for car to cool down so I can fill up the cooling again. I was hoped that there a drain so where for the over flow??? I lost about two cups of antifreeze on my floor?
Maybe its your expansion tank, sensor or the cap? All located on the passenger side wheel well area..
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold & new owner totaled it 4 hours later)
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms