Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-25-2012, 10:38 AM
kenza kenza is offline
Officially Welcomed to the 'Fest
Location: Santiago, Chile
 
Join Date: Aug 2009
Posts: 625
Mein Auto: 2007 X3 2.0d MT
PDC reset

Hi everyone!

I was installing a hitch on a friend's X3 and now rear parking distance sensors do not work. Everything was connected as it was before the hitch was installed.

Any suggestions on how to reset the PDC?

Thanks in advance!
Reply With Quote
Advertisement
  #2  
Old 12-26-2012, 12:16 PM
kenza kenza is offline
Officially Welcomed to the 'Fest
Location: Santiago, Chile
 
Join Date: Aug 2009
Posts: 625
Mein Auto: 2007 X3 2.0d MT
Come on, nobody ever had a PDC issue?
Reply With Quote
  #3  
Old 12-26-2012, 10:03 PM
x3oiler x3oiler is offline
Officially Welcomed to the 'Fest
Location: Melbourne Australia
 
Join Date: Jun 2009
Posts: 171
Mein Auto: Touareg TDI
"Installing a hitch" meaning what? setting up the draw bar on an existing installation, or a complete installation of drawbar and light control box from scratch?.
If from scratch then I believe that the factory trailer light interface box will disable the rear PDC sensors. I am not sure if permanent or not.
I have aftermarket interface unit that does NOT disable the rear PDC and it is a pain - when the tow ball is installed (not even a trailer connected) the PDC goes off as soon as reverse is selected so disabling is good IMO.
__________________
VW Touareg V6 TDI 4Motion with a smooth as AISIN 8 speed auto gearbox that WORKS!
X3 3.0d 2006 (MY07) sold
Reply With Quote
  #4  
Old 12-26-2012, 10:36 PM
x3brian x3brian is offline
Officially Welcomed to the 'Fest
Location: Sacramento CA
 
Join Date: Jan 2011
Posts: 1,007
Mein Auto: X3
That is correct. The installation of the interface box on the e83 kit will disable the PDC if the system senses a load on the pins only. Will not help if you have a bike hitch installed. That's when you use the dash mounted defeat switch.

Now on the f25 you need to recode a module if you install a hitch with PDC....I seem to remember reading the system recodes automatically with the new module but I could be wrong...

I personally haven't seen a bulletin on PDC reset for the e83.

Last edited by x3brian; 12-26-2012 at 10:47 PM.
Reply With Quote
  #5  
Old 12-27-2012, 05:43 AM
kenza kenza is offline
Officially Welcomed to the 'Fest
Location: Santiago, Chile
 
Join Date: Aug 2009
Posts: 625
Mein Auto: 2007 X3 2.0d MT
Thanks guys! I did not install the factory trailer control box as the car is euro version (no pre-wiring). Actually, I haven't touched the wiring yet (planned for the upcoming weekend). So, from PDC perspective, I removed the bumper and put it back.
Reply With Quote
  #6  
Old 12-29-2012, 05:34 PM
kenza kenza is offline
Officially Welcomed to the 'Fest
Location: Santiago, Chile
 
Join Date: Aug 2009
Posts: 625
Mein Auto: 2007 X3 2.0d MT
Ok, found the problem - one of the sensors was not correctly connected. As soon as the connector clicked, everything went back to normal. No need to reset anything.

BTW, it was possible to see which sensor exactly had a problem from diagnostic software.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms