Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 12-25-2012, 11:11 PM
OzzyX5 OzzyX5 is offline
Registered User
Location: Australia
 
Join Date: Dec 2011
Posts: 39
Mein Auto: 2006 X5 3.0d
X5 electrics

Hellow and Merry Christmas to all,
I have had a real fun time with my X5 recently, the steering wheel controls, horn, DSC, Transmision fail safe program comes on, Down hill desent, wipers, radio, windscreen washers, passenger seat weight sensor(chime), interior lights, stoped working. They do come on at there own will for a short time.
After some studying of related electrical diagrams I have found there is no power to my fuse No 7,8,or 9 which are responsible for thoes functions. These fuses are powered by the ignition key, which Fuse 3 is responsible for, I have power at Fuse 3.
I'm thinking possibly a bad conection in steering column or worn ignition switch.
Wish me luck
Reply With Quote
Advertisement
  #2  
Old 12-26-2012, 07:28 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 956
Mein Auto: 2001 X5 3.0L
Ignition switch problems are quite common and can cause all sorts of odd behavior. I had a dim airbag light when my switch was failing. Some have removed the switch and cleaned it with good results but I choose to have it replaced by my indy. I bought the switch from Bavauto.
GL.

Last edited by Zulu95; 01-09-2013 at 07:20 AM.
Reply With Quote
  #3  
Old 01-08-2013, 07:17 PM
OzzyX5 OzzyX5 is offline
Registered User
Location: Australia
 
Join Date: Dec 2011
Posts: 39
Mein Auto: 2006 X5 3.0d
Thanks for the info Zulu,
I have done some more tests at the back of the ignition switch and am 98% sure it is the switch, I will pull it apart and clean it out to get it going until a replacement comes in.
Reply With Quote
  #4  
Old 01-09-2013, 01:01 AM
OzzyX5 OzzyX5 is offline
Registered User
Location: Australia
 
Join Date: Dec 2011
Posts: 39
Mein Auto: 2006 X5 3.0d
Yep, its the ignition switch,
I cleaned the contacts and lubricated the sliding components, reassembled and it works fine. I will replace it though, I don't trust it.
Reply With Quote
  #5  
Old 01-09-2013, 07:21 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 956
Mein Auto: 2001 X5 3.0L
Such a little item to produce so many problems! Glad you worked it out.
Cheers,
Reply With Quote
  #6  
Old 04-09-2015, 05:24 PM
joe1807b joe1807b is offline
Registered User
Location: San Diego
 
Join Date: Jul 2014
Posts: 13
Mein Auto: 2006 X5
I have the same issues this week with my 2006 X5 3.0. Weird gremlin like problems.
Heard from the dealership this afternoon, that they believe it to be the "ignition switch".
I hope they're right. Cost $650 here in San Diego.
Reply With Quote
  #7  
Old 08-30-2016, 09:19 PM
sgtsquarepants sgtsquarepants is offline
Registered User
 
Join Date: Aug 2016
Posts: 4
Mein Auto:
I have the same problems and purchased a new ignition switch. However, when I installed it, my key would no longer work. What do I do? Thank you
Reply With Quote
  #8  
Old 08-31-2016, 09:19 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 8,389
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by sgtsquarepants View Post
I have the same problems and purchased a new ignition switch. However, when I installed it, my key would no longer work. What do I do? Thank you
What do you mean exactly by the bolded text in your quote above? By "not work"...does this mean the key won't go all the way into the cylinder? If so, read the info below about aligning the new ignition switch to match the old. Or do you mean the key no longer starts the vehicle? Or do you mean that none of the 3 features of the remote key work any longer (FZV/DWA/EWS)...central locking/anti-theft alarm siren/immobilizer?

Hopefully you still have your old ignition switch...I say that because...the old switch will give indication of how a part of the new switch should be positioned before installing it.

You're going to have to go back in and re-position the switch so that the key aligns with it when inserted.

In the pic below (from D Cecil's DIY procedure from e38.org)...you should be able to get a visual gist of what was mentioned above as to how both the old & new switch need to be aligned the same. And to anyone in the future that may need the procedure...here's a direct link to how to remove/replace the igntiion switch. This will apply to the e38/e39/e53 which has the exact or very similar steering column layout: http://www.bimmerboard.com/forums/posts/244045


"The old part on the left, with the new part on the right. Use a small, flat-blade screwdriver to twist the center shaft of the new part to match the old part so that it will align properly when installed."

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 08-31-2016 at 09:29 AM.
Reply With Quote
  #9  
Old 09-01-2016, 07:48 PM
sgtsquarepants sgtsquarepants is offline
Registered User
 
Join Date: Aug 2016
Posts: 4
Mein Auto:
I saw that and I'm going to try it again this weekend. Hopefully properly aligning it will take care of the problem.

What I meant with "my key would no longer work" is that my key would insert (felt like it fully inserted but maybe not) but it would not turn to any position.

Last edited by sgtsquarepants; 09-01-2016 at 08:27 PM.
Reply With Quote
  #10  
Old 09-01-2016, 07:58 PM
sgtsquarepants sgtsquarepants is offline
Registered User
 
Join Date: Aug 2016
Posts: 4
Mein Auto:

Last edited by sgtsquarepants; 09-01-2016 at 08:27 PM.
Reply With Quote
  #11  
Old 09-05-2016, 08:51 PM
sgtsquarepants sgtsquarepants is offline
Registered User
 
Join Date: Aug 2016
Posts: 4
Mein Auto:
That worked perfectly. Thanks all!
Reply With Quote
  #12  
Old 09-06-2016, 12:11 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 8,389
Mein Auto: 1997 740iL / 2006 X5 4.4
Great!
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms