Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-26-2012, 07:23 PM
tjducet tjducet is offline
Registered User
Location: Vancouver
 
Join Date: Dec 2012
Posts: 7
Mein Auto: 2006 BMW 750Li
Post iDrive glitches

Hi Bimmerfest;

The iDrive on my 06' 750Li seems to have started doing the "funky chicken". If I try and access any menu options that are to the lower half of the main menu the selector switch knobs jums around in the menu options uncontrolably. I was thinking of fully disconnecting the battery and doing a "cold Re-boot" so to speak. anhy advice will be appreciated.
__________________
tjducet
Reply With Quote
Advertisement
  #2  
Old 12-28-2012, 08:33 AM
RichmondF RichmondF is offline
Registered User
Location: Saint Paul, Minnesota
 
Join Date: Dec 2012
Posts: 19
Mein Auto: 2002 BMW 745i
I have an 02, and I know that the iDrive itself has changed since then. However, one thing may remain the same...

Check your glove box and feel around on the ceiling of the glove box (from the inside). There should be a plastic door which swings down and inside there should be a "ring fuse" (black plastic O ring connected to a junction with cords leading from it). Turn off your vehicle and pull the ring fuse, wait a minute or so, and put the fuse back in. This restarts the iDrive. Then start your car and see if it works. If it does not work, pull the ring fuse again while the car is on/running and leave the ring fuse pulled then see if it works without the fuse. Mine had this issue just yesterday and curiously worked if I pulled the ring fuse and left it pulled.

As far as pulling the battery goes, Im not sure if it is the same on the 06, but if you pull the battery on my 02 then you have to re-register the battery to the computer when you connect it again. Check your battery voltage, my iDrive issues were solved by replacing the battery.
Reply With Quote
  #3  
Old 02-08-2013, 02:15 AM
tjducet tjducet is offline
Registered User
Location: Vancouver
 
Join Date: Dec 2012
Posts: 7
Mein Auto: 2006 BMW 750Li
Hi Rich;

I found the o-ring you mentioned unfortunately I can't seem to get it out. Is there any trick? I don't wan't to reef on it and risk breaking it or similar. Any advice?

Thanks.
__________________
tjducet
Reply With Quote
  #4  
Old 02-08-2013, 09:37 AM
cbell13055 cbell13055 is offline
Officially Welcomed to the 'Fest
Location: Moorestown NJ
 
Join Date: Oct 2012
Posts: 175
Mein Auto: 05 CTS-V
Hey not to thread hijack, but

Do you have the sport wheels powder coated black? I've been thinking about doing this, and was wondering what it would look like.

Could you send me some more pictures cbell13055@gmail.com
__________________
2008 Jet Black 750i. Sport, Luxury Seating, and Logic 7. <3
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms