Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-22-2010, 03:43 PM
lucyred62 lucyred62 is offline
Registered User
Location: Westchester county, ny
 
Join Date: Mar 2009
Posts: 63
Mein Auto: 2007 328XI Wagon
windshield wiper fluid light is on-need Help

The windshield wiper fluid light is on, and even after putting in washer fluid, the light remains on. In addition, every time I start the car, the check engine light flashes(on the dash board). I have included pictures. Someone told me it is probably a bad sensor. Also, they thought that the bad sensor caused the check engine light to come on everytime I restart the car(as I press the reset button on the top command center area, and that always clears it until I shut off the car again). Click image for larger version

Name:	IMG_0211_2-5.jpg
Views:	118
Size:	20.9 KB
ID:	222762

Click image for larger version

Name:	IMG_0212.jpg
Views:	99
Size:	24.6 KB
ID:	222763 Does anyone know where to purchase a new one, and what the part number is? thanks for any help. Also, please let me know if there are any other suggestions as to what it might be.
Reply With Quote
Advertisement
  #2  
Old 03-22-2010, 07:38 PM
03bmw525i 03bmw525i is offline
Officially Welcomed to the 'Fest
Location: newport, ri
 
Join Date: Sep 2007
Posts: 123
Mein Auto: 03 525iA, '87 325e 5spd
If I'm not mistaken, the 'check' light is suppose to blink each time you start the car as a reminder to 'check' the warning light panel above rearview mirror. It goes off when you push the brake pedal or the reset button. It's not a 'check engine' light. Not sure what's up with ww fluid light. Good luck.
Reply With Quote
  #3  
Old 03-23-2010, 09:51 AM
danielw05 danielw05 is offline
Officially Welcomed to the 'Fest
Location: Little Rock, Arkansas
 
Join Date: Mar 2006
Posts: 380
Send a message via AIM to danielw05 Send a message via MSN to danielw05 Send a message via Yahoo to danielw05 Send a message via Skype™ to danielw05
Mein Auto: 1990 325i
if you have plenty of fluid in there, then it has to be the sensor on the side of the washer fluid reservoir. when you start the car, the CHECK light is going to flash on the instrument panel until you have acknowleded on the check panel that something is lit up. Once you hit CHECK on the check panel, then the CHECK on the instrument panel will go away, but the light on the check panel under washer fluid will stay lit until the sensor is fixed.
Reply With Quote
  #4  
Old 03-24-2010, 05:50 AM
lucyred62 lucyred62 is offline
Registered User
Location: Westchester county, ny
 
Join Date: Mar 2009
Posts: 63
Mein Auto: 2007 328XI Wagon
thanks for the responses. If the sensor is bad, does anyone know where I can buy a new one to replace it, and what the part number may be. I have ordered a few parts for the car from ECS Tuning, but I need the part number? Thanks
Reply With Quote
  #5  
Old 03-24-2010, 08:53 AM
noexceptions325's Avatar
noexceptions325 noexceptions325 is offline
East Bound And Down
Location: Shenandoah Valley VA
 
Join Date: Dec 2007
Posts: 2,832
Send a message via AIM to noexceptions325
Mein Auto: 325e,Jeep,240z,528i
wanna fix it the easy way?
unplug the sensor and put a jumper wire across the contacts and then slap some electrical tape on it... the light will never come on again... lol
if you want a good sensor PM me i am running with no wiper fluid reservoir, hence why i know how to make the little light turn off
__________________

Built 325e too much to list, Heavily modified Jeep, Datsun about to get a 351, and now a 528i
Reply With Quote
  #6  
Old 03-25-2010, 11:43 AM
Dirtboy's Avatar
Dirtboy Dirtboy is offline
Ring Junkie
Location: Las Vegas
 
Join Date: Apr 2002
Posts: 459
Send a message via ICQ to Dirtboy Send a message via AIM to Dirtboy Send a message via Yahoo to Dirtboy
Mein Auto: E46 E83 E30- all M sport!
Quote:
Originally Posted by lucyred62 View Post
thanks for the responses. If the sensor is bad, does anyone know where I can buy a new one to replace it, and what the part number may be. I have ordered a few parts for the car from ECS Tuning, but I need the part number? Thanks
realoem.com is your friend


so is Pelicanparts http://www.pelicanparts.com/cgi-bin/...I1.x=8&I1.y=12
__________________

Last edited by Dirtboy; 03-25-2010 at 11:46 AM.
Reply With Quote
  #7  
Old 03-29-2010, 11:44 AM
nadodude nadodude is offline
Registered User
Location: San Diego
 
Join Date: Jun 2006
Posts: 76
Mein Auto: '04 330ciC/ '02 C230K
It may not be bad, make sure the sensor did not turn over or else the float will be loating and not hitting the sensor. Take a look at what I'm atlking about. I turned mine over and the light turned off.
__________________
Reply With Quote
  #8  
Old 12-27-2012, 01:23 PM
tdennehy tdennehy is offline
1990 325i Convertible
Location: Sacramento, CA
 
Join Date: Dec 2012
Posts: 26
Mein Auto: 1990 325i convertible
I had this same problem. Sensor was fine. I shorted across the two wires and still... the light remained on.

I then removed the check panel from above the rear view mirror and disconnected the wiring harness and shorted the pin for the washer fluid to ground. How? I took some 12 guage stranded wire and removed the insulation. Took one very tiny strand and inserted it in the harness connector - on in the ground and the other in the one for the fluid sensor. Put the harness back on the panel and VOILA!. No more idiot light. Don't ask me which pin number it was, but if I found the wiring harness diagram on the internet, you can too...

Note. Be careful not to break anything when removing the check panel. I accidentally pryed off the clips that hold it in, and had to glue them back in. But like I said, that stupid light is no longer driving me crazy.

Now if I could only get that brake pad light to stop randomly coming on. That will be my next project.
Reply With Quote
  #9  
Old 12-27-2012, 03:46 PM
Chaunceton Chaunceton is offline
Officially Welcomed to the 'Fest
Location: Utah
 
Join Date: Dec 2012
Posts: 117
Mein Auto: 1989 325i
I had this problem too. Went to a parts yard and pulled the sensor out of a salvaged car. When I pulled my sensor I saw that mine had filled with fluid. So with the $5 sensor from the parts yard I'm good. If you don't care about the sensor but don't want to do permanent damage, you could pull it out and wrap the float up next to itself with some wire.
Reply With Quote
  #10  
Old 12-27-2012, 09:08 PM
WickedFast.Inc WickedFast.Inc is offline
Go Fast or Go Home
Location: Texas
 
Join Date: Nov 2012
Posts: 106
Mein Auto: 1989 325I
Tdennehey if your brake wear light keeps coming on but your brakes are good find each sensor on the wheels and make sure they are actually there mine came on because one sensor was missing

Wicked Fast Entertainment
Reply With Quote
  #11  
Old 12-28-2012, 07:52 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,698
Mein Auto: E23;E30;E38;E32;E34 +
Fixing the WS fluid light can't be that hard - its either the switch/sensor or a short. The 'CHECK' light - READ THE HANDBOOK like the rest of us. Car didn't have one - ebay.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms