Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-27-2012, 11:39 AM
J.Laco J.Laco is offline
Registered User
Location: Amsterdam
 
Join Date: Dec 2012
Posts: 4
Mein Auto: BMW e65 750i 2007
750i NAVI03 Initialization problem

Dear BMW fellows,

Since 3 days ago my NAVI03 unit simply stopped working.

When I insert the DVD in the Navigation Unit "light illuminates in the CD" but then the system displays the navigation screen "Initializing ..." and nothing else happens until the past few minutes the screen gives a flash and restart in order to appear again "Initializing".

In the same time radio is reset as well due to the MOST connection of the components.
Everything else is working just fine: radio, CD, CD charger, iDrive, telephone, Logic 7, etc...

I noted that the BMW Assist screen also displays "Initializing" forewer.

What can be the problem ?

I consulted the secret i-drive menu and my version is NAVI03 DVD from 02 07 2007. The software version is:
Navigation:
sotware version: 09.04. hex
Date of manufacture: 2007 02 07
Part number: 6590 9 122860

Some trials to solve the problem:
- I was suspecting the DVD Rom reader and replaced is yesterday. It did not solve the problem.
- I have an original Europe High navigation DVD from my dealer. I also copied / burned another DVD in order to see if the DVD-Rom was the problem. Same "Initializing" screen forewer.
- Also serveral times I reset the MOST fiber optics (from the trunk glove compartment), but didn't help as well.

Can you pls give me any hints: can it be the GPS signal (tribmble box integrated within the Nav unit)? Nav computer? Is there any fuse or relay that can cause this problem (all seams fine).

Your help is appreciated.

John

Last edited by J.Laco; 12-27-2012 at 01:09 PM.
Reply With Quote
Ads by Google
  #2  
Old 12-28-2012, 03:30 PM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
I have exactly the same problem, which was probably induced when trying an update.

When you say replaced dvd rom reader, do you mean the whole nav unit or dvd laser?

Would be interested to get an answer to this too.
Reply With Quote
  #3  
Old 12-29-2012, 01:08 AM
J.Laco J.Laco is offline
Registered User
Location: Amsterdam
 
Join Date: Dec 2012
Posts: 4
Mein Auto: BMW e65 750i 2007
No software update

Hi BSOD,

No, I did not carry out any software updates (firmware). The NAVI03 just simly stopped working and it is stuck in "´nitializing..." forever.

I replaced the DVD-ROM unit suspecting that this was the problem, but did not help.
I didn't want to change the laser only, thus replaced the DVD-ROM unit of the navigation.
This didn't solve the problem.

The DVD is also stucked inside and will not eject. I removed it manually by removing the fron cover carefully and pulling out the DVD disk.

It is interesting to note the follwing:
- The "Initializing ..." message is there even if there is no DVD in the NAVI03 unit !
- This means that I can not even attempt to update the NAVI03 firmware to V32 (latest version)
- The red beam light from the MOST (visible at the plugin entering the NAVI03 unit) is coming to the NAVI03, means there is no break / bridge of the MOST bus (fiber optic loop).


Any hints / help from the experienced users on the forum are appreciated !
Reply With Quote
  #4  
Old 01-24-2013, 11:42 PM
J.Laco J.Laco is offline
Registered User
Location: Amsterdam
 
Join Date: Dec 2012
Posts: 4
Mein Auto: BMW e65 750i 2007
Solved

Just to document it for the other users. Problem solved:

1. The NAVI03 computer was the problem;
2. Installed a second-hand Unit (found on ebay, similar but not the same S/N);
3. Updated firmware to V.32 (search the form, lots of posts);
4. Burned a double-layer DVD+R with Europe High maps;
5. Works smooth.
Reply With Quote
  #5  
Old 01-25-2013, 01:08 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 51
Mein Auto: E66 750li
This happens to me sometimes and lasts for up to a week.

what do you mean by NAVI03 ?

the screen it self or ? I am confused lol
Reply With Quote
  #6  
Old 01-25-2013, 02:33 AM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
Yeah, i'm a bit confused as well.

You said in post 3 that you replaced the DVD-ROM unit (@see-5 which is the Navigation drive in the boot known as a NAVI01(CD version) or NAVI02 or NAVI03 DVD version ) and it didn't work.

Are you saying that the original test replacement was also potentially duff and the new one you got of ebay has sorted it?

Just so happens I bit the bullet and ordered a new laser off ebay last night so hoping that will fix it.
Reply With Quote
  #7  
Old 01-25-2013, 08:06 PM
Rick in Yuma's Avatar
Rick in Yuma Rick in Yuma is online now
Officially Welcomed to the 'Fest
Location: Arizona
 
Join Date: Dec 2006
Posts: 153
Mein Auto: 05' 760li,94' H1,08'Smart
http://www.ebay.com/itm/390413934149...84.m1423.l2649

My unit is out. Dealer said 1500.. plus labor.. trying this first. Anyone use these guys before. here is the eBay info if link is gone.

Last edited by PAPER; 01-25-2013 at 08:11 PM. Reason: REMOVING ADVERTISMENT ...
Reply With Quote
  #8  
Old 02-04-2013, 04:59 AM
J.Laco J.Laco is offline
Registered User
Location: Amsterdam
 
Join Date: Dec 2012
Posts: 4
Mein Auto: BMW e65 750i 2007
Additional info

Guys,

The NAVI03 unit is the complete unit as shown on the picture (post by rick). This Unit has inside a DVD-rom, a computer and also a GPS hardware unit. The NAVI03 unit is connected via fiber optic to the MOST network. If this unit does not work, you may have no screen, radio failures (reset), BMW assist functions will not work, etc.

Previously I replaced the DVD-rom unit only, since I was suspecting that the laser is worn out. You can replace the DVD-rom or the laster only, search for the threads in this forum.

If this does not solve the problem, next is probably a navigation comuter failure (typically due to moisture and condensation).

That is why I ordered a second-hand complete NAVI03 unit on eBay. Thus, not just the DVD-rom, but the complete box. You can find one for 400-500 Euro. This solved the problem. It is important that you know which HW / SW you have and what type of NAVI UNIT you have (1, 2, 3, or 4). If you buy a similar version (second-hand), the software - firmware can be easily upgraded to the latest V32 (you need a special CD with the software).
Reply With Quote
Reply

Bookmarks

Tags
initialization, navi03, problem


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms