Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-27-2012, 07:27 PM
mannynews mannynews is offline
Registered User
Location: Hoboken, NJ
 
Join Date: Dec 2012
Posts: 2
Mein Auto: 2005 BMW X3 3.0i
Mystery Electrical Issue

Over the summer, lucked up on my first car purchase and found a 2005 BMW X3 3.0i with only 3,900 miles on it. I've been enjoying it, virtually problem free, except for this recurring issue that seems to be getting worse...

At random times, maybe every other time or so as I start the vehicle...there is a noticeable flickr in the headlights, and also the interior lights. Occasionally, the car's electrical system seems to stop, and restart itself immediately (the 4X4 light, and a few other lights come on, but then go off).

I've taken this to the local Pep Boys.....had them check the electrical system and battery....they said that something electrical seems to be on, even when the system is shut off. They thought the problem could be with the aftermarket radio.

Took it to the shop that did the radio, had them completely remove the radio, then reassemble it. The problem stopped for a while....but then returned.

Left it with the BMW Dealership for a few days, the problem did not replicate itself. They also checked the battery power (its the original battery), and report all is fine...they kindly did not charge me for anything....but said to keep in touch.

Since this is my first car ownership experience....can anyone offer assistance in troubleshooting this issue? Like many of you, I love my X3, replaced the tires earlier than needed, get the oil changed on a regular basis, and keep it in great condition. This electrical issue is one I want to resolve....so I can continue to safely enjoy the vehicle..

(One side note...wondering if this could be a weather related issue? Maybe it's getting worse because it's colder?)
Reply With Quote
Ads by Google
  #2  
Old 12-27-2012, 07:44 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,950
Send a message via AIM to AzNMpower32
Mein Auto: 2006 325i sport
I'm no expert, but my hunch is the aftermarket radio is still drawing power. There are certain lines that are always on (for example, the cigarette outlets) so if you're drawing power from one of those "always live" modules, that could be straining the battery.

Secondly, given your vehicle's age, I strongly recommend replacing the battery. Last year was when all the 2004 owners on this board (me included) had dead batteries after the summer. You have an '05 so its probably y'all's turn.
Reply With Quote
  #3  
Old 12-27-2012, 08:03 PM
mannynews mannynews is offline
Registered User
Location: Hoboken, NJ
 
Join Date: Dec 2012
Posts: 2
Mein Auto: 2005 BMW X3 3.0i
Will head for a new battery supply first thing tomorrow. Thanks so much for quick advice!
Reply With Quote
  #4  
Old 12-30-2012, 01:44 PM
shendrick shendrick is offline
Officially Welcomed to the 'Fest
Location: Near Boston MA
 
Join Date: Sep 2010
Posts: 129
Mein Auto: 08 M3, 05 e46 zhp, 07 X3
Our 2007 X3 would each a battery every year. Turns out that the TCU (telephone ? unit) was not disconnecting from the mobile phone properly when the car was turned off. This ran the battery down and then issues like moving the power seats while the car was off would not function properly. This would not explain your condition unless the battery was just about dead. If you don't see green on the battery eye then its time for a new battery. If the battery is OK, then you have some other intermitent electrical issue going on.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms