Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #101  
Old 02-03-2013, 10:38 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by shawnsheridan View Post
Ok. I have PM'd you the link. Good luck!
Mine calculates to 0:

Click image for larger version

Name:	VIN CheckDigit.png
Views:	169
Size:	13.7 KB
ID:	360571

I checked other VIN's and it changes.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #102  
Old 02-03-2013, 06:36 PM
hamfei hamfei is offline
Registered User
Location: Shanghai
 
Join Date: Apr 2012
Posts: 25
Mein Auto: 2012 E90 CLI
What VIN value did you change to in the EEPROM? Empty means FF not 00...
Reply With Quote
  #103  
Old 02-07-2013, 12:36 AM
hamfei hamfei is offline
Registered User
Location: Shanghai
 
Join Date: Apr 2012
Posts: 25
Mein Auto: 2012 E90 CLI
seems mate is not here...
Reply With Quote
  #104  
Old 02-07-2013, 03:32 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by hamfei View Post
What VIN value did you change to in the EEPROM? Empty means FF not 00...

Yes i did it to FF

Quote:
Originally Posted by hamfei View Post
seems mate is not here...
I´m very busy with my work , but your procedure doesn´t works.

Next post

Regards
Reply With Quote
  #105  
Old 02-07-2013, 05:37 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by mateforrest View Post
Yes i did it to FF



I´m very busy with my work , but your procedure doesn´t works.

Next post

Regards
Which procedure does not work? The Tool32 KOMBI01.prg?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #106  
Old 02-07-2013, 06:31 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Click image for larger version

Name:	ImageUploadedByBimmerApp1360247261.460126.jpg
Views:	185
Size:	102.1 KB
ID:	361162

Click image for larger version

Name:	ImageUploadedByBimmerApp1360247389.225603.jpg
Views:	135
Size:	96.4 KB
ID:	361163

Click image for larger version

Name:	ImageUploadedByBimmerApp1360247406.360511.jpg
Views:	113
Size:	100.6 KB
ID:	361164

Click image for larger version

Name:	ImageUploadedByBimmerApp1360247444.741877.jpg
Views:	118
Size:	101.3 KB
ID:	361165
Reply With Quote
  #107  
Old 02-07-2013, 06:37 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
I can't find the commands hamfei said.

Hamfei, could you help me please?
Reply With Quote
  #108  
Old 02-08-2013, 07:10 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Any idea please?
Reply With Quote
  #109  
Old 02-09-2013, 12:23 PM
djsaad1 djsaad1 is offline
Officially Welcomed to the 'Fest
Location: austin
 
Join Date: Sep 2012
Posts: 670
Mein Auto: range rover
Quote:
Originally Posted by mateforrest View Post
Shawn Thanks million for all your help.

This is the proof of vin erased:
Attachment 360512

No CAFD.

And this problem:
com.bmw.esys.domain.psdz.PsdzException: Failed to get CAFs for SWE "swfl_000003c1-004_054_006". [C111]
at com.bmw.esys.domain.psdz.Psdz.getCafsForSWE(Psdz.j ava:2088)
at com.bmw.esys.domain.svt.SvtLogic.getCAFsForSWE(Svt Logic.java:395)
at com.bmw.esys.gui.svt.SvtCompareController.callActi onGetCafsForSWE(SvtCompareController.java:695)
at com.bmw.esys.gui.svt.SvtTargetView$ActionGetCAFFor SWE.doActionPerformed(SvtTargetView.java:549)
at com.bmw.esys.gui.AbstractView$AbstractGuiProgressA ction$1.init(AbstractView.java:389)
at com.bmw.esys.gui.component.DialogProgress$2.constr uct(DialogProgress.java:136)
at com.bmw.esys.gui.component.SwingWorker$2.run(Swing Worker.java:145)
at java.lang.Thread.run(Unknown Source)
Caused by: KIS error: Die technische Einheit 000003C1 konnte in der KIS-Wissensbasis nicht gefunden werden.
Timestamp: Thu Jan 31 23:32:05 CET 2013
SessionId: default
ErrorCategory: SYSTEM_ERROR ID: 1283
Class: com.bmw.psdz.uc.LogicImpl
ExecutionContext={category=KIS, ecuid=(UNKNOWN,?)}
at com.bmw.psdz.uc.LogicImpl.getCAFsForSWE(LogicImpl. java:1173)
at com.bmw.esys.domain.psdz.Psdz.getCafsForSWE(Psdz.j ava:2085)
... 7 more



Attachment 360513

Attachment 360514

Please friends, any advice?
I am getting this same error with a different file when trying to install a new 6wb from 6wa.
Reply With Quote
  #110  
Old 02-09-2013, 01:57 PM
djsaad1 djsaad1 is offline
Officially Welcomed to the 'Fest
Location: austin
 
Join Date: Sep 2012
Posts: 670
Mein Auto: range rover
Quote:
Originally Posted by mateforrest View Post
Any idea please?
bimmertech is going to code my new 6wb. It seems like it doesn't have a vin and I am getting the same error you are getting. I will watch what they do and let you know. Hopefully they will be able to do it in the next couple days.
Reply With Quote
  #111  
Old 02-09-2013, 02:18 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by djsaad1 View Post
bimmertech is going to code my new 6wb. It seems like it doesn't have a vin and I am getting the same error you are getting. I will watch what they do and let you know. Hopefully they will be able to do it in the next couple days.
It must be due to KOMBI not having the car's VIN. I have just replied to your PM.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #112  
Old 02-10-2013, 10:24 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by djsaad1 View Post
bimmertech is going to code my new 6wb. It seems like it doesn't have a vin and I am getting the same error you are getting. I will watch what they do and let you know. Hopefully they will be able to do it in the next couple days.
Thanks, plese tell me the solution when you know.
Reply With Quote
  #113  
Old 02-10-2013, 04:11 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
With KOMBI01.prg, jobs cps_lesen and kombi_uhrzeit_datum_stellen, what do you show for VIN and Mileage?

cps_lesen (VIN):

Click image for larger version

Name:	cps_lesen.jpg
Views:	171
Size:	112.3 KB
ID:	361728

kombi_uhrzeit_datum_stellen (Mileage):

Click image for larger version

Name:	kombi_uhrzeit_datum_stellen.jpg
Views:	150
Size:	124.2 KB
ID:	361729

The Mileage is in KM, so the 39899 km in my case is 24792 miles (km x 0.621371 = miles)
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #114  
Old 02-11-2013, 11:52 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Shawn i Will check, it's so laborious swap the speedometer.

Thanks
Reply With Quote
  #115  
Old 02-11-2013, 12:07 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by mateforrest View Post
Shawn i Will check, it's so laborious swap the speedometer.

Thanks
Really? The Video makes it out to be simple. 2 Fasteners and a connector plug...
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #116  
Old 02-11-2013, 12:14 PM
djsaad1 djsaad1 is offline
Officially Welcomed to the 'Fest
Location: austin
 
Join Date: Sep 2012
Posts: 670
Mein Auto: range rover
Quote:
Originally Posted by shawnsheridan View Post
Really? The Video makes it out to be simple. 2 Fasteners and a connector plug...
I am not sure about the 5 series, but on the 6 series you have that huge arc above it. http://www.cartype.com/pics/9492/ful...cluster_13.jpg

It's not hard to unlatch it but maneuvering it out and in without scratching anything is pretty hard.

Bimmertech coded mine, but after getting the ip from zgw search it seems like he was able to vpn straight to the car with his computer through edibias tool. I didn't get to see anything.
Reply With Quote
  #117  
Old 02-11-2013, 12:18 PM
snj1013 snj1013 is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jul 2011
Posts: 501
Mein Auto: 2011 528i
Quote:
Originally Posted by djsaad1 View Post
I am not sure about the 5 series, but on the 6 series you have that huge arc above it. http://www.cartype.com/pics/9492/ful...cluster_13.jpg

It's not hard to unlatch it but maneuvering it out and in without scratching anything is pretty hard.

Bimmertech coded mine, but after getting the ip from zgw search it seems like he was able to vpn straight to the car with his computer through edibias tool. I didn't get to see anything.
Damn the luck...
Reply With Quote
  #118  
Old 02-16-2013, 07:47 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by snj1013 View Post
Damn the luck...
Hello do you have more information?
Reply With Quote
  #119  
Old 02-16-2013, 10:00 AM
djsaad1 djsaad1 is offline
Officially Welcomed to the 'Fest
Location: austin
 
Join Date: Sep 2012
Posts: 670
Mein Auto: range rover
Quote:
Originally Posted by mateforrest View Post
Hello do you have more information?
What psdzdata are you running? When I updated mine to 48.3 it found the missing swfl files for the 6wb so now I can detect cafd from swe while before I wasn't able to. Is it possible you are using old psdzdata that doesn't have all the swfls for the 6wa?
Reply With Quote
  #120  
Old 02-16-2013, 10:13 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Hello I using 47.5, but i not sure if i can use 48.3, what about token code?

Shawn any help?

regards
Reply With Quote
  #121  
Old 02-16-2013, 10:15 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by shawnsheridan View Post
With KOMBI01.prg, jobs cps_lesen and kombi_uhrzeit_datum_stellen, what do you show for VIN and Mileage?

cps_lesen (VIN):

Attachment 361728

kombi_uhrzeit_datum_stellen (Mileage):

Attachment 361729

The Mileage is in KM, so the 39899 km in my case is 24792 miles (km x 0.621371 = miles)
I sent you an email

Regards
Reply With Quote
  #122  
Old 02-16-2013, 10:19 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by djsaad1 View Post
What psdzdata are you running? When I updated mine to 48.3 it found the missing swfl files for the 6wb so now I can detect cafd from swe while before I wasn't able to. Is it possible you are using old psdzdata that doesn't have all the swfls for the 6wa?
You mean 6WA, not 6WB?

Well, it is good that Detect CAF for SWE is now working, although it is hard to understand why with 48.3 PSdZData it is suddenly working considering 6WA has been around since 0311 when 46.1 was out.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #123  
Old 02-16-2013, 10:21 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by shawnsheridan View Post
You mean 6WA, not 6WB?

Well, it is good that Detect CAF for SWE is now working, although it is hard to understand why with 48.3 PSdZData it is suddenly working considering 6WA has been around since 0311 when 46.1 was out.
I think the same.
Reply With Quote
  #124  
Old 02-16-2013, 10:23 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,811
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by mateforrest View Post
Hello I using 47.5, but i not sure if i can use 48.3, what about token code?

Shawn any help?

regards
You can use 48.3 for F10, no problem. The Patch / Token issue is only for the 48.3 F20 PSdZData.

Quote:
Originally Posted by mateforrest View Post
I sent you an email

Regards
Got it.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #125  
Old 02-16-2013, 10:24 AM
djsaad1 djsaad1 is offline
Officially Welcomed to the 'Fest
Location: austin
 
Join Date: Sep 2012
Posts: 670
Mein Auto: range rover
Quote:
Originally Posted by shawnsheridan View Post
You mean 6WA, not 6WB?

Well, it is good that Detect CAF for SWE is now working, although it is hard to understand why with 48.3 PSdZData it is suddenly working considering 6WA has been around since 0311 when 46.1 was out.
No it started working for 6wb, my car came with 6wa. Even after bimmertech coded my car I still couldn't detect cafd on 48.1. But once I updated to 48.3 it detected the cafd from swe.

Is it possible he needs to be at 48.1 to get those swfls he is missing?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms