Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-14-2013, 11:09 AM
jimharsh jimharsh is offline
Registered User
Location: Hagerstown, MD
 
Join Date: Jun 2008
Posts: 5
Mein Auto: Nissan
Won't start, battery and alternator OK

Have an issue with my 2005 525I. Get nothing when I turn the key, but battery and alternator check out OK. Dash lights up but no sound at all from engine. Any ideas as to what the problem might be?
Reply With Quote
Ads by Google
  #2  
Old 06-14-2013, 11:19 AM
H F H F is online now
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,466
Mein Auto: 2005 545i
Quote:
Originally Posted by jimharsh View Post
Have an issue with my 2005 525I. Get nothing when I turn the key, but battery and alternator check out OK. Dash lights up but no sound at all from engine. Any ideas as to what the problem might be?
I bet the starter
__________________
Reply With Quote
  #3  
Old 06-14-2013, 11:49 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,279
Mein Auto: 2004 545i
If no click from the starter at all, most likely starter solenoid.
Reply With Quote
  #4  
Old 06-14-2013, 02:04 PM
93 525 Paul 93 525 Paul is offline
Registered User
Location: Fresno
 
Join Date: Jun 2013
Posts: 10
Mein Auto: 525i 550i 2002c
Starter

Quote:
Originally Posted by schpenxel View Post
If no click from the starter at all, most likely starter solenoid.
The wife's starter went last week. It also was all good, but made no sound if you were in the driver's seat. A very light "click" was audible when my head was under the hood and someone else hit the starter button. Hers is a 100k mile 07 525i.
Took the starter apart and the brushes on the positive side were melted to the stator and to the retainers.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms