Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-29-2012, 03:47 PM
Kparmar Kparmar is offline
Registered User
Location: Alberta
 
Join Date: Dec 2012
Posts: 2
Mein Auto: 2007 X5, 2006 525i
2007 X5 Problem

Hi guys, I was trying to find more insight into what might be causing my X5 to have some issues.

Lately, the cars been giving me trouble when it comes to starting it up. And the Idrive system will give me errors like: 4x4, DSC,... failed and wont start up.

But if I get a jump from another car it starts up fine. Also keep in mind it does start up normally for a few days then just dies out again. I had the battery replaced roughly a year ago but didn't see this problem until a few weeks ago.

Thanks for your help

**also if there is a post about this problem from the past I apologize but if someone could lead me into the right direction it would help**

Last edited by Kparmar; 12-29-2012 at 03:48 PM. Reason: for people to let me know if this problem has come up in the past
Reply With Quote
Advertisement
  #2  
Old 12-29-2012, 05:58 PM
ChuckGr ChuckGr is offline
Officially Welcomed to the 'Fest
Location: San Diego, CA, USA
 
Join Date: Dec 2009
Posts: 316
Mein Auto: X5 35D
You need a new battery. A bad battery will give those errors.

Chuck
Reply With Quote
  #3  
Old 12-31-2012, 10:28 AM
onebadgix onebadgix is offline
Registered User
Location: atlanta
 
Join Date: Dec 2012
Posts: 24
Mein Auto: 2009 x5
Or at least take the battery back to where you bought it and have them run a load test on it. If it can hold a load, then maybe your alternator is not charging it up properly and it needs to be replaced.
Reply With Quote
  #4  
Old 12-31-2012, 10:53 AM
ard ard is offline
Resident Curmudgeon
Location: Sierra foothills
 
Join Date: Jul 2009
Posts: 10,148
Mein Auto: '12 X5 35d/E39M5/996TTX50
Original battery???? GET A NEW BATTERY

Do no screw around with testing the battery on the bench or on the car.

My opinion

A
__________________
Keep it as simple as possible...but no simpler.
Reply With Quote
  #5  
Old 12-31-2012, 02:24 PM
Kparmar Kparmar is offline
Registered User
Location: Alberta
 
Join Date: Dec 2012
Posts: 2
Mein Auto: 2007 X5, 2006 525i
Hey, Thanks for all your help

Im going to take it back to the dealer I bought the battery from since I think it still holds its 1 year warranty.

The battery is new it was replaced about 8 to 10 months ago

The thing I dont understand is why would the battery randomly start to fail after about 8 months.

If it is the alternator do you guys know much it usually cost to replace it?
Reply With Quote
  #6  
Old 02-07-2014, 07:30 PM
Jon_B_X5 Jon_B_X5 is offline
Registered User
Location: Orlando, Florida USA
 
Join Date: Feb 2014
Posts: 1
Mein Auto: 2007 X5 4.8
Hey, did you get this fixed? I'm having the same exact issue. Please let me know. Thanks!!
Reply With Quote
  #7  
Old 02-17-2014, 09:50 PM
ADeCArolis ADeCArolis is offline
Registered User
Location: Michigan
 
Join Date: Feb 2014
Posts: 5
Mein Auto: 2010 E63 M6, 2013 E70 X5
Buddy had this problem with the same year. He said the battery kept draining and the engine light would turn on. Needed to replace positive battery terminal/lead... cost 1k he said.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms