Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-13-2012, 02:06 PM
Anders1986 Anders1986 is offline
Registered User
Location: Norway
 
Join Date: Feb 2012
Posts: 1
Mein Auto: 97' 520i
E39 Business Stereo problem

Hi!

First of all, i have searched everywhere without finding a solution for my problem.

I have recently bought a 97' 520 with the Business stereo / Cassette / Amp in trunk.

Picture of a similar player is attached.

The problem is that it simply wont turn on. The lights and clock work, nothing else.

I have checked all fuses, including the 30A in the trunk and the fuse on the back of the cassette player, all are fine. I have also tried to unplug the battery.

The weird thing is that the casette player gets 12V constant, but not 12V igniton. So i tried to to plug 12V ignition directly 12V constant, and now the lights on the casette deck works, and i can take casettes in and out.

But still nothing else.

Does ANYONE have a clue? Igniton problem? Does anyone know if there are more units that need 12V ignition? Like AMP, MID, or should they get this from the casette deck?

I would highly appreciate all help, i hate to drive without music, and will try this before i go for the (rather ugly) aftermarket 1-din solution...

Regards
Anders

Attached Thumbnails
Click image for larger version

Name:	E39_Business_Tape_Fader.jpg
Views:	60
Size:	20.5 KB
ID:	312152  
Reply With Quote
Ads by Google
  #2  
Old 02-02-2013, 03:20 PM
manminder singh manminder singh is offline
Registered User
Location: UK ENGLAND ( DERBYSHIRE)
 
Join Date: Oct 2007
Posts: 43
Mein Auto: 525 DIESEL 2000
Hi
I am having the same problem now. Did you find out what the problem with your car was? Any help will be really appreciated.
regards
Reply With Quote
  #3  
Old 02-02-2013, 09:12 PM
JimLev JimLev is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,641
Mein Auto: 540/6, S60 Volvo, Tribeca
Does the MID display radio stations?
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
  #4  
Old 02-03-2013, 09:18 AM
manminder singh manminder singh is offline
Registered User
Location: UK ENGLAND ( DERBYSHIRE)
 
Join Date: Oct 2007
Posts: 43
Mein Auto: 525 DIESEL 2000
Hi
Last week only the clock would show on the radio screen and after about 15 minutes driving the radio would just come on and now nothing ( no clock or radio at all ). Checked all fuses, which are all ok.
Checked power going in to the radio and found only one live IN. Shoud there be two live in, one for back up power or something?

Thanks
any help will be reall appreciated
Reply With Quote
  #5  
Old 02-03-2013, 08:18 PM
Bwood1 Bwood1 is offline
Officially Welcomed to the 'Fest
Location: Austin, TX
 
Join Date: Aug 2009
Posts: 121
Mein Auto: 1999 528i, 2002 540i
I have a 99 528i and the radio drops out from time to time as well. Everything works but no sound comes out. I find a severve bump like a pothole would knock it out and another bump would bring it back on. I never turn it off, just down and that seems to help. It has acted this way for years.
Reply With Quote
Reply

Bookmarks

Tags
business stereo problem


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms