Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2013, 04:20 AM
brock5ga brock5ga is offline
Registered User
Location: Monroe, GA
 
Join Date: May 2012
Posts: 96
Mein Auto: Z4
Installing E46 Aux Input in E85

I purchased an E46 aux input to install in my 03 Z4, which I have seen others install. The car had a factory ipod adapter when purchased. I want to leave it in place to charge my daughters ipod. The E46 adapter has a 10 pin connector and the ipod connector has a 12 pin connector, which matches the back of the stereo. I removed the pins from the 10 pin connector, and installed them in the 12 pin connector where they appeared to go. It looked as if they would either intertwine with the ipod adapter or 2 wires would go in the same connectors as the ipod connector, depending on where you put the 10 pin connector. Bottom line, not working. Can someone who has installed this tell me the pin numbers and wiring colors that the E46 aux. input should match up to on the Z4? Thanks
Reply With Quote
Ads by Google
  #2  
Old 01-04-2013, 03:36 PM
SD Z4MR's Avatar
SD Z4MR SD Z4MR is offline
(formerly SD 335is)
Location: San Diego, CA
 
Join Date: Jan 2011
Posts: 4,258
Mein Auto: '06 Z4 MR | '11 335is E92
I just installed an AUX input in my car. I used the Auxiliary Input Retrofit Kit from ECS Tuning, BMW #65120153502, ECS Part# ES#180582 . The AUX input for the Z4 has only three pins which are installed in the 12-pin connector in the BLACK plug, not the 12-pin connector for the iPod adapter which is in a WHITE plug.

If you are looking at the back of the radio harness, the black plug (with a black 12-pin connector, Nav and Bluetooth) is in the lower right corner, the white plug (with a black 12-pin connector, iPod adapter) is in the lower left corner. If you don't have Nav and Bluetooth, then the lower right socket may be blank.

This kit includes the 12-pin connector as well as the black plug which plugs into the back of the radio harness. If you have Nav and Bluetooth, you have to remove either the 3 pins from the 12-pin connector in the kit or the existing 2 pins from the existing 12-pin connector and combine them. This kit includes a stereo mini plug on a cheap metal bracket which can be removed.

I should have bought the AUX input for the Mini as detailed in this post, which details the installation along with pictures: http://www.zpost.com/forums/showpost...80&postcount=5. It's about half the cost and appears to be the exact same thing. I've also attached a JPEG scan of a page that shows the pin outs from the installation instruction of a different OEM Aux Input Kit.

I also bought the Auxiliary Input Socket from ECS Tuning, BMW #84109237655, ECS Part# ES#2207518 to fill the hole in the under radio panel that I bought so I could use it to install a Homelink garage door opener. (The panel is no longer available without the AUX input jack hole already in it.) This takes an odd-shaped 4-pin plug in the back as below. Anyone know what the part number is for this four-pin plug?

Attached Thumbnails
Click image for larger version

Name:	Installation Instructions 5 - Auxiliary Audio Input Kit #82110142174.jpg
Views:	336
Size:	171.2 KB
ID:	355992  
__________________
- Tom
-------
Mine: 2006 Z4 Roadster (E85) | Interlagos Blue Metallic | Black Extended Nappa Leather | Carbon Leather Trim | Purchased 7/19/12
Hers: 2011 335is Coupe (E92) | Le Mans Blue Metallic | Black Dakota Leather | Dark Glacier Aluminum | 6MT | ED 5/12/11

BMWCCA #444696 - Click to join and a chance to win a 1-Day M School at the BMW Performance Center!



Last edited by SD Z4MR; 01-04-2013 at 04:47 PM.
Reply With Quote
  #3  
Old 01-05-2013, 03:02 AM
brock5ga brock5ga is offline
Registered User
Location: Monroe, GA
 
Join Date: May 2012
Posts: 96
Mein Auto: Z4
Thanks SD Z4MR. I didn't get the one for the Mini, but for the E46. It has a 10 pin connector instead of a 12 pin. It didn't look like it would lock into the connector, so I assumed since the ipod was also an add on, it would go into that connector. It appears that the connector that came with the E46 input will plug into the blank connector, just not lock. The attached file should give me the pin numbers I need to transfer the wires back to the connector and move it to the other side. I will try that and see what happens. Sounds like I should be fixed.
Reply With Quote
  #4  
Old 01-05-2013, 11:51 AM
brock5ga brock5ga is offline
Registered User
Location: Monroe, GA
 
Join Date: May 2012
Posts: 96
Mein Auto: Z4
Thanks. That is exactly what I needed. Moved wires to pins 3,4 and 10 as in the attachment and to the other side and now working. Now, just waiting for my coolant tank which just sprung a leak.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms