Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Everything Else > General Automotive Forum

General Automotive Forum
All non-BMW car talk goes here...

Reply
 
Thread Tools Display Modes
  #1  
Old 01-06-2013, 04:51 AM
phatness phatness is offline
phatness
Location: boston, Ma
 
Join Date: Aug 2012
Posts: 27
Mein Auto: 5 series
95 e34 525i BMW sputtering

Ok guys I've had a long road with my trusty 525i ( I bought 6 months ago not running). After I bought it it took me about a week to get her running correctly (first time owning and working on a BMW).
I have many questions but will post new forums for each of my processes in time, first we will try to tackle this one.
I have a sputtering when I step on the gas it rarely happens when cold mostly happens after its warm.
I've herd it could be any of the following,
Coils
Plug
Valve cover no good (leaking oil onto spark plugs)
So I start with the 1st Wich was checking the coils so I start with the coil closest to the radiator an work my way back to the fire wall an they all have the same effect when removed (engine consistently missfires).
All coils good correct?
So now I'm gonna pull the coils an check for oil on the spark plugs and all were clean except the spark plug closest to the fire wall it was coated in oil. I then proceed to clean the oil and pull the spark plug and clean that, when I pulled the plug I noticed that it was really burnt and the ceramic white had a crack (spark plugs still say BMW on it, still from 95?
So I clean it all up and put it all back together ( yea same plugs back in it) I still get a sputter but not as bad, any ideas? I was going to replace the valve cover gasket and plugs today but it is now snowing out so it will have to wait.
Ok so is there anything else I should check?
What are BMW's recommended spark plugs, besides dealer?
Oh and I have a low idle of .500rpm when hot, when cold it idles at .900 right where it should be normally correct?
Could it be the alternator?
Could it be a clogged fuel filter?

Thanks in advanced to any help!

Sent from my HTC Vision using Bimmer App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1357474973802.jpg
Views:	83
Size:	128.7 KB
ID:	356203  
Reply With Quote
Ads by Google
  #2  
Old 05-11-2013, 10:53 PM
Justinnn93 Justinnn93 is offline
Registered User
Location: Queensland, Australia
 
Join Date: May 2013
Posts: 2
Mein Auto: BMW e34 525i
Re: 95 e34 525i BMW sputtering

Hey I had the exact same problem and what I did was take all the spark plugs out give them a clean make sure there alright, no liquid leaking into the top, and then an oil change after that ran perfectly.
Hope that helps

Sent from my GT-N7105 using BimmerApp mobile app

Last edited by Justinnn93; 05-11-2013 at 10:55 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > Everything Else > General Automotive Forum
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms