Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-09-2013, 01:33 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
745i back from the garage :)

Now that I finally have my car back in my possession I'll introduce myself and my car.

Im 23, from the UK, on my placement year studying Computer Network Technology at the University of Northumbria in Newcasle.

I owned a 745i last year but was in an unfortunate accident in May, but I bought another mid December from a small trader (basically a guy who buys and sells cars).

Took it for a 20 mile test drive and was trading in my previous car (Volvo XC90) and all seemed well.

40 miles later on the way home to Newcastle (from York) I noticed the car was in 4th gear at 70mph in drive. I switched to manual to try to change up and it wouldn't do it. I knew something was wrong so I slowed to 50 to pull off at the next junction.

As I pulled off I got the "Transmission overheated, Stop when safe" warning. I waited for it to cool and tried to start the car to move it as I had a friend near where I was stuck on the A1.

The car wouldn't go into D, R or N saying the engine must be running to change gear (which it obviously was).

The trader was sympathetic and seemed to try to help and genuinely didn't seem to know of any faults with the car mechanically and he let me speak to the garage he had the car checked out at.

I had the car recovered to Newcastle and ended up having the box and torque converter replaced at a cost of 1600 in total (inc front brake pads that needed doing) by an independent garage.

Got the car back yesterday and it now works which is nice. It doesn't smoke and I haven't seen the coolant temp reach more than 93 degrees on the dash computer.

There are a couple of things I wanted to ask about that I haven't seen while reading threads on here though:

1. Clicking noise under very slight load (sounds like something is catching / rattling but only happens at like 800-1000 rpm). Doesn't sound like its coming from the engine itself so I'm not too concerned but its a little irritating.

2. When "cruising" (only been able to test at low speed due to not leaving the city yet) at about 20-30mph in gear the rpm sometimes flutters between about 1200-1500, but it doesn't feel unsmooth. The car did this a couple of times on the test drive too but I didn't think anything of it.

3. Adaptive cruise control - when I try to activate it it comes up on the cluster saying "ACC ---mph" then turns off. I thought this was due to the front pads needing replacing at first as I read on a BMW pdf that if the brakes weren't in order that it wouldn't start. Unfortunately now that are done it is still doing it. I have INPA and the error on the ACC is "lens heater error" but it says it would not show a warning light and it's only needed in winter / heavy rain so I was hoping that it should still work in normal conditions. Since doing the brakes and box nothing else (other than the CD changer) has any errors.

4. The replacement box seems to have the infamous "hard downchange to first" but otherwise is working fine. I know I could take it to the dealer for reprogramming, but I have BMW Standard Tools myself and was wondering how hard / risky it is to update it myself?

Thanks in advance ^^

Piers
Reply With Quote
Ads by Google
  #2  
Old 01-09-2013, 06:25 AM
1bad540's Avatar
1bad540 1bad540 is offline
Officially Welcomed to the 'Fest
Location: newyork
 
Join Date: Jan 2006
Posts: 9,395
Mein Auto: E65 750i Sport,C5 z51 e46
you couldnt just get your money back??
__________________
[SIGPIC]
e39 540i sport, acs type 2's chrome, acs spler pdls,Euroclrs
e65 745i aw sport,21's aib's acspedals& rf splr(sold)
e46 328i Prem Aw18" 335spt whls(sold)
c5 Corvette 6sp,z51,2"drp,19"ccw'sshrt shft,corsa exh,dd nav
e53 X5 3.0, pana rf,nav,xenon,cldweather, premium.ipod hookup, 20"4.6rims staggered 315rrs.
e65 750I aw, sport. chrome21's,acs pdls,acs rfsplr,mtecs,8k hid fogs,Leds.oem ipod&sirius
Srt10 VIPER, 19-20" rennen forgedwheels,tune,exhaust,intake.
Reply With Quote
  #3  
Old 01-09-2013, 06:29 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
If RPMs are fluctuating when cruising it's a tranny issue.. It's a common issue.. I think personally it's the torque converter going out, but it could very well be something else internally in the trans.. I was able to get mine to go away (Mine was doing it very very slightly only for the first minute of cold operation) by changing my fluid to Redline D4.
Reply With Quote
  #4  
Old 01-09-2013, 06:41 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by 1bad540 View Post
you couldnt just get your money back??
Nope I tried.

The guy who sold it was helpful i guess but hes just a normal guy who trades cars in spare time, not a dealer or car company.

After I drove it and signed the receipt saying I accept the car and have test driven it hes within his rights to not take it back and he didn't.

Sucks to be me but theres not much else I could do.


Torque converter would make sense I guess regarding the RPM's, the car was cold when it was doing it this morning so ill see if it still does it while hot.

The transmission I got it replaced with was used with 80k miles but it was all I could afford. Ideally I'll get it reconditioned and the torque converter replaced but it's going to be a while before I have significant spare cash for that.

I kept the old box too to play around with / investigate in my spare time.

I was thinking the issue with my old box going could have just been the torque converter but labor to replace was more than the box itself so it wasn't worth trying out a replacement converter as if it didn't work I'd have to remove / replace again.
Reply With Quote
  #5  
Old 01-09-2013, 07:15 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
That down shift and upshift hard is typically mechatronics adapter And sleeve.
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #6  
Old 01-09-2013, 07:45 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
The seal as changed when the new box was fitted and the sleve on the connection was checked too, so hopefully they arent the cause.

It isnt always doing it (depends on type of deceleration) and its not that hard shifting compared to several people who said it was like being rear ended.

The worst ive felt it was breaking relatively hard and then picking up speed again just as it changed.

Also on all upshifts it seems okay.

Last edited by Piers1989; 01-09-2013 at 08:12 AM.
Reply With Quote
  #7  
Old 01-09-2013, 08:56 AM
johndade johndade is offline
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Nov 2006
Posts: 1,642
Mein Auto: 2002 bmw 745li
Have you changed the guibo? Fluid with new pan / filter?
Reply With Quote
  #8  
Old 01-09-2013, 09:15 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
The guibo I don't believe was changed, but it was in good shape visibly at least.

And yes there was a new pan, seal, filter and oil all fitted with the box.

Also good news from Citizens Consumer Advice. - As I bought the car from a trader (regardless of how small he is he is still registered as a trader and it was a trade sale), he is liable for the costs in theory.

Also when I asked for a refund when it broke down 40 miles after buying it I was entitled to one which he refused.

Will keep you all updated.
Reply With Quote
  #9  
Old 01-09-2013, 09:20 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,204
Mein Auto: '03 745Li
That's good news, hopefully he can give you a refund for the car and the repair charges so far or just pay for the repairs.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #10  
Old 01-09-2013, 10:08 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by Piers1989 View Post
The guibo I don't believe was changed, but it was in good shape visibly at least.

And yes there was a new pan, seal, filter and oil all fitted with the box.

Also good news from Citizens Consumer Advice. - As I bought the car from a trader (regardless of how small he is he is still registered as a trader and it was a trade sale), he is liable for the costs in theory.

Also when I asked for a refund when it broke down 40 miles after buying it I was entitled to one which he refused.

Will keep you all updated.
Thats great, try and get your money back.. you may eat the repairs, but you probably spent way more on the car, so even if you loose a little, it's better than getting a car that is still having trans issues after replacing the trans.
Reply With Quote
  #11  
Old 01-09-2013, 10:24 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by cmpcpro View Post
Thats great, try and get your money back.. you may eat the repairs, but you probably spent way more on the car, so even if you loose a little, it's better than getting a car that is still having trans issues after replacing the trans.
Yeah I'm hoping for the best.

When I told the guy consumer advice told me to ask for a refund he got abit angry.

Hes saying that even tho he bought the car as a trade seller, he bought it for personal use and sold it privately.

Will see what Consumer Advice say, but I'm pretty sure thats illegal to do, and if he bought the car as a trader then i should be ok.
Reply With Quote
  #12  
Old 01-09-2013, 10:32 AM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Quote:
Originally Posted by Piers1989 View Post
Yeah I'm hoping for the best.

When I told the guy consumer advice told me to ask for a refund he got abit angry.

Hes saying that even tho he bought the car as a trade seller, he bought it for personal use and sold it privately.

Will see what Consumer Advice say, but I'm pretty sure thats illegal to do, and if he bought the car as a trader then i should be ok.
If he is a trader they will see right through that, it's a complete cop out.. don't let this guy take advantage of you.. if the thing broke down 40 miles away, he obviously knew about it.. they don't just break when the new buyer happens to leave with the car..
Reply With Quote
  #13  
Old 01-09-2013, 10:42 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I'll keep you updated.
Hopefully Consumer advice will agree...
Reply With Quote
  #14  
Old 01-10-2013, 04:19 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Well Citizens Consumer Advice have advised me that if he is a trader selling multiple cars (which is very apparent from his ebay, all with practically identical listings), regardless of if it was his house and his name or his company name, I should still press for a refund, and I've just drafted a letter of formal complain from their template.

They are also asking Trading Standard to look into this practices.

The letter I've just drafted is just requesting what I already have again so I'm sure it'll get rejected by him, but once he rejects a formal letter then we can move forward.

On another note, I am considering going to a friends for the weekend tonight, its a 90 mile drive each way though.
I'm not sure if I should drive the car on a long drive with the RPM flutter? It doesn't affect the drive at all and only seems to do it at low speed cruise, but if its going to overheat the torque converter (assuming it is slipping) then maybe it isn't a good idea.

Last edited by Piers1989; 01-10-2013 at 04:21 AM.
Reply With Quote
  #15  
Old 01-10-2013, 08:14 PM
Expo BMW's Avatar
Expo BMW Expo BMW is offline
Local Enthusiast
Location: City of L.A.
 
Join Date: May 2008
Posts: 1,216
Mein Auto: E65,P71 Police Intercept.
The rpm fluctuation is an electronic issue if I recall correctly. Will have to do a search to know for sure.
__________________

. 360infiniteusa Angel Eyes . H&R Springs . mObridge AUX Integration .
Reply With Quote
  #16  
Old 01-10-2013, 08:24 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Not for me, I believe it was my Tq converter, but I know for sure it was my tranny because after changing the fluid to Redline D4 it went away. Keep in mind, mine only happened when cold for the first minute or so of driving, after that it went away.
Reply With Quote
  #17  
Old 01-11-2013, 01:49 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I had a look around and spent an hour or 2 googleing rpm fluctuation / flutter but I can imagine people will describe it in such different ways that it makes searching difficult.

I asked my garage about the RPM issue and described it in detail:

Happening when warm OR cold.
Only happens under very light load.
Needle "bounces" around 300-400 RPM up and down
Usually only happens at low RPM (around 1000-2000), though I haven't driven more than 50mph yet to find out due to living in a city
Happens in all gears and in manual mode

The garage said the torque converter wouldn't be the first thing they would check. Also I have noticed it does kind of feel "unsmooth" when its doing it, but it doesn't feel like any significant deceleration or acceleration, but I assume thats what it is, and I guess the torque converter is smoothing that out considerable compared to the RPM change.

I ran a full scan of the car (as I cant scan my DME directly as it says the control unit is not the model it was expecting) and got the fault code 277F which I believe is crankshaft sensor speed.

The garage has advised this could result in unsmooth operation and that they would recommend replacing the sensor.

I don't know much about engine internals other than a basic knowledge of the theory behind how one works, does it sound plausible that that could be causing the issue?
Reply With Quote
  #18  
Old 01-11-2013, 09:37 AM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,864
Mein Auto: 750I
If idle is not fluctuating when in Neutral or Park then its something in your transmission ...most likely the torque converter.

When the car is acelerating or decelerating the RPM of the Engine Flywheel and Transmission input (Drive shaft) are at different speeds.... This means the torque converter has to do torque manipulation to make sure the car operates transparently to the user.

RPM fluctuation happens in this case when the torque converter is not doing enough torque manipulation or its slipping and having issues cancelling out the difference in RPM between the flywheel and the transmission input shaft. It doesnt happen past a certain RPM because the torque converter locks up ..basically connectiong the input shaft of the drive shaft directly to the flywheel. This is done for better gas mileage once the car has gotten up to speed in that gear...saves on gas by eliminating ineffeciencies within the torque converter

If your torque converter is failing your car can also feel very sluggish from the start...its its slipping then your RPM will go up fast but the car wont be moving like it should...if it is locking up prematurely and sticking then your engine will "bog down" when getting off the line because the torque converter is not "stalling" enough to allow the engine to reach its optimum power band before transfering power into the input shaft of the transmission.

Sometimes the torque converter is not working right because bad or low fluid. It is fluid controlled so changing or topping up the fluid can work. Other times its a mechanical problem and the torque converter needs to be replaced.
__________________
Reply With Quote
  #19  
Old 01-11-2013, 09:53 AM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,864
Mein Auto: 750I
.
__________________
Reply With Quote
  #20  
Old 01-11-2013, 10:09 AM
E92-Lighting's Avatar
E92-Lighting E92-Lighting is offline
info@e92-lighting.com
Location: Walnut CA
 
Join Date: Sep 2008
Posts: 4,572
Send a message via AIM to E92-Lighting Send a message via MSN to E92-Lighting Send a message via Yahoo to E92-Lighting Send a message via Skype™ to E92-Lighting
Mein Auto: 335i
sorry to hear
__________________
Reply With Quote
  #21  
Old 01-11-2013, 11:27 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by DFEL750I View Post
If idle is not fluctuating when in Neutral or Park then its something in your transmission ...most likely the torque converter.

When the car is acelerating or decelerating the RPM of the Engine Flywheel and Transmission input (Drive shaft) are at different speeds.... This means the torque converter has to do torque manipulation to make sure the car operates transparently to the user.

RPM fluctuation happens in this case when the torque converter is not doing enough torque manipulation or its slipping and having issues cancelling out the difference in RPM between the flywheel and the transmission input shaft. It doesnt happen past a certain RPM because the torque converter locks up ..basically connectiong the input shaft of the drive shaft directly to the flywheel. This is done for better gas mileage once the car has gotten up to speed in that gear...saves on gas by eliminating ineffeciencies within the torque converter

If your torque converter is failing your car can also feel very sluggish from the start...its its slipping then your RPM will go up fast but the car wont be moving like it should...if it is locking up prematurely and sticking then your engine will "bog down" when getting off the line because the torque converter is not "stalling" enough to allow the engine to reach its optimum power band before transfering power into the input shaft of the transmission.

Sometimes the torque converter is not working right because bad or low fluid. It is fluid controlled so changing or topping up the fluid can work. Other times its a mechanical problem and the torque converter needs to be replaced.
Thanks for the information.

As the box was just replaced, the fluid is new and has been filled to the correct level. Also there are no leaks.

The RPM seems to stay ABOUT level when idling, but if im honest it doesn't idle as smoothly as my old 745i did, you can feel it occasionally through the car.

I haven't really tired putting my foot down since I got the car back, but it seems to set off fine.

From doing more driving and being aware of an issue I've realised to power deliver when it does fluctuate does feel a bit unsmooth, and I was thinking that if rather then "bouncing around" on cruise, the revs are actually just dripping then rising then is it possible that the engine is causing the fluctuation and the torque converter is actually masking some of the issue by allowing some slip from normal operation?

I know in most auto cars as you adjust load when under very light load the rev needle doesn't stay directly synced with the speed. (My old volvo, proton, mates 335i)

Does that make sense or am I talking out of my ass xD

Last edited by Piers1989; 01-11-2013 at 11:33 AM.
Reply With Quote
  #22  
Old 01-11-2013, 11:54 AM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,864
Mein Auto: 750I
Quote:
Originally Posted by Piers1989 View Post
Thanks for the information.

As the box was just replaced, the fluid is new and has been filled to the correct level. Also there are no leaks.

The RPM seems to stay ABOUT level when idling, but if im honest it doesn't idle as smoothly as my old 745i did, you can feel it occasionally through the car.

I haven't really tired putting my foot down since I got the car back, but it seems to set off fine.

From doing more driving and being aware of an issue I've realised to power deliver when it does fluctuate does feel a bit unsmooth, and I was thinking that if rather then "bouncing around" on cruise, the revs are actually just dripping then rising then is it possible that the engine is causing the fluctuation and the torque converter is actually masking some of the issue by allowing some slip from normal operation?

I know in most auto cars as you adjust load when under very light load the rev needle doesn't stay directly synced with the speed. (My old volvo, proton, mates 335i)

Does that make sense or am I talking out of my ass xD
If the RPM is fluctuating when the engine is not under load in P or N then you have to fix that issue. When the engine is under load it would only be worst. The fluctuating idle can be cause by a number of factors that would screw up the air, spark, gas ratio within the engine. This includes....vacuum lead, bad mass air flow sensor, bad coil, bad spark plug, bad or leaking injector, bad O2 sensor etc. The only way to know is to have the car diagnosed.

If you have INPA you can check to see which cyclinder is not idling smoothly under the engine options. I dont remember under which menu exactly but there is one of the display functions that shows you each cylinder...INPA gives you a number...the further the number is from 0 the less efficient that cylinder is running. Normally you will just see one that seems and little different compared to the rest. If you can find that cylinder you can start by swapping the ignition coil in that cylinder with one that is idling smoothly to see if the problem follows the coil. If it doesnt follow the coil then do the same thing but this time with spark plugs. Past that you are looking at another issue but this is a good place to start
__________________
Reply With Quote
  #23  
Old 01-11-2013, 12:49 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I have INPA but I cant open the DME do to an error about it not expecting the control unit name (my actual control unit has a slightly different name than INPA thinks it should).

The only related error code when i go a full scan of the car is 277F on the DME which i believe is crankshaft sensor speed.

Under idle it is almost fine but i can just barley tell its not perfect.

I'll try hold it at about 1500 RPM when its in N at some point and see if it still fluctuates.

Last edited by Piers1989; 01-11-2013 at 12:52 PM.
Reply With Quote
  #24  
Old 01-14-2013, 12:21 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I went out in the car with my flatmate tonight looking at my laptop running diagnostics(status) on the gearbox through INPA.

It seems that the turbine speed (Torque converter output speed) is regularly less than the input (engine) speed. Even under relatively hard acceleration.

I don't know when out TC's are supposed to lock up, but even putting the car in 4th gear at a solid 3k RPM the turbine speed was fluctuating from locked at 3k and about 2.85k RPM, and the engine RPM was slightly fluctuating by maybe 50RPM.
The TC seems to be spending most of the time locked at speed but sometimes dipping to less than 1:1.

At lower speeds/RPM (when the car is doing the noticeable RPM fluctuations of 100-300) the turbine speed is staying at about 1200 though the engine speed is fluctuating between 1250 and 1450ish.

Also when coming to a stop the converter allows the engine to drop to its idle of 750 RPM while the turbine is still spinning at 1.2k RPM (I've been in several cars that did this, however I don't believe my last 7 did this).

Does this sound like a duff torque converter or normal operation, or indicative of an engine or gearbox fault?

EDIT: Also I cleared the fault log on the DME last week and no fault codes have returned. Also the Gearbox module has not reported any faults at all.

Last edited by Piers1989; 01-14-2013 at 12:25 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms