Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-17-2013, 04:43 AM
relinuca relinuca is offline
Registered User
Location: Cincinnati, OH
 
Join Date: Oct 2012
Posts: 17
Mein Auto: '08 X3
a TPMS question, please

I'm getting a TPMS warning sign indicator on my '08 X3. But when I check the tires with a pressure gauge, they are all at 31-32 psi. Is there a re-set function for the warning sign?

relinuca
Reply With Quote
Ads by Google
  #2  
Old 01-17-2013, 06:00 AM
awdrev awdrev is offline
Registered User
Location: Maryland
 
Join Date: Dec 2012
Posts: 82
Mein Auto: 2004 BMW X3 3.0 Auto Tran
To reset it, you just press it and hold it down for about 10-15 seconds and your dashlight should blink and then go off.

If that doesn't work, the system itself may be having issues.
Reply With Quote
  #3  
Old 01-17-2013, 08:21 AM
timfitz63's Avatar
timfitz63 timfitz63 is offline
MT = Doppler Shifting
Location: Lorena & San Antonio, TX
 
Join Date: Aug 2010
Posts: 858
Mein Auto: 2007 X3 (MT)
Quote:
Originally Posted by awdrev View Post
To reset it, you just press it and hold it down for about 10-15 seconds and your dashlight should blink and then go off...
Per my 2007 Owner's Manual, one also has to drive the vehicle after initiating the reset sequence via the dashboard button. If the vehicle isn't moved, I don't think the reset process is completed.
__________________

X3 w/6-speed & Sport Package:
A sports sedan disguised as an SUV...
Reply With Quote
  #4  
Old 01-17-2013, 02:21 PM
cagui1223's Avatar
cagui1223 cagui1223 is offline
Officially Welcomed to the 'Fest
Location: Connecticut
 
Join Date: Nov 2012
Posts: 168
Mein Auto: 2007 BMW X3 3.0si [e83]
ASSuming makes an @SS out of you n me...
With that said, the TPMS button is located on the center console in front of the shift-knob. Looks like (,,!,,). Both methods should work actually. Try driving it around after pressing the button. Uh.. also try another pressure gauge?
Reply With Quote
  #5  
Old 02-13-2013, 06:16 PM
dukedkt442 dukedkt442 is offline
Registered User
Location: Upstate, NY
 
Join Date: Feb 2013
Posts: 60
Mein Auto: 08 E83; 97 MKIII; 84 GMC
The tire pressure drops in cold weather, so if the light came on when it was cold, it will stay on until it is reset, even if you checked the pressure in warmer weather after the tire pressure increased. This happened to me a few weeks ago; each tire took 2 pounds, and I reset the system with the button on the console. Also, you don't know what pressure the system was initially set for; if a previous owner set the system to 35 psi, 31 psi could certainly put the light on. Also, try a different gauge; the dial gauge that I had for over 10 years was reading almost 10psi off.
__________________
Reply With Quote
  #6  
Old 02-14-2013, 07:08 AM
relinuca relinuca is offline
Registered User
Location: Cincinnati, OH
 
Join Date: Oct 2012
Posts: 17
Mein Auto: '08 X3
TPM vs. TPMS

After careful reading of the '08 X3's owner's manual, I realize it has a TPM system, not the more sopihisticated TPMS. The former measures pressure variance between the tires and the latter measures absolute pressures in each tire.

In any event, we have put new tires on and re-set the TPM per the manual, and now everyting is fine.

(I know, I know...when in doubt, read the darn manual!)

relinuca
Reply With Quote
  #7  
Old 02-14-2013, 08:26 AM
vern vern is online now
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,718
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Quote:
Originally Posted by timfitz63 View Post
Per my 2007 Owner's Manual, one also has to drive the vehicle after initiating the reset sequence via the dashboard button. If the vehicle isn't moved, I don't think the reset process is completed.
+1 That system is very temperamental. The icon come up when ever there is a temp change and when you check the psi there is only 1 psi difference in all the tires. That has been going on since day one.
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms