Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-17-2013, 12:19 AM
Mada_infinity Mada_infinity is offline
Mada
Location: USA
 
Join Date: Feb 2013
Posts: 15
Send a message via MSN to Mada_infinity Send a message via Yahoo to Mada_infinity
Mein Auto: 2003 bmw 530i
Dashboard light

Hey guys I was trying to reset the oil service indicator and I did the Gage's test any way after I'm done this light came on and it doesn't want to go away

Click image for larger version

Name:	ImageUploadedByBimmerApp1363501115.623909.jpg
Views:	456
Size:	24.8 KB
ID:	366753
Reply With Quote
Advertisement
  #2  
Old 03-17-2013, 10:20 AM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 22,082
Mein Auto: 02 BMW 525i M54 auto 130K
Quote:
Originally Posted by Mada_infinity View Post
Hey guys I was trying to reset the oil service indicator and I did the Gage's test any way after I'm done this light came on and it doesn't want to go away
EDIT: Removed stuff about oil service interval as per QSilver7 post #3 below (it's not the oil service interval light in the OPs cluster which is lit).

This thread would be more apropos:
- What does the warning light in the instrument cluster that shows one car behind another mean?
Attached Thumbnails
Click image for larger version

Name:	moto0098.jpg
Views:	16
Size:	29.1 KB
ID:	366813  
__________________
Please read the suggested threads, where the best always add value to those threads, either by pictures or by descriptions, so the next person with the same problem stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need

Last edited by bluebee; 03-17-2013 at 11:31 AM.
Reply With Quote
  #3  
Old 03-17-2013, 10:45 AM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 6,190
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by Mada_infinity View Post
Hey guys I was trying to reset the oil service indicator and I did the Gage's test any way after I'm done this light came on and it doesn't want to go away

If the light in your pic came on...it's not because of the normal service indicator reset procedures that is performed by pressing the buttons on the instrument cluster.

What went wrong though, is questionable, because there isn't any indication if you may have done something different (operator error) or if there are other issues with your car.

First, that icon has NOTHING to do with the service display reset, nor does it have anything to do with any options on your car because that option was NEVER offered on e39 BMWs imported to the USA.

If there is something missing in the info you have listed, then you'll have to tell us or reveal it...again because the ACC option (active cruise control) was never offered here in the states on the e39. Perhaps a temporary battery nap (remove negative battery cable for approx 5 minutes) will get rid of this odd electrical gremlin. BTW, how old is your car battery and have you had any other odd electrical gremlins recently that might point to an electrical issue (like a dying battery)?





(ACC sensor location in front bumper area)
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 03-17-2013 at 12:07 PM.
Reply With Quote
  #4  
Old 03-17-2013, 01:21 PM
Mada_infinity Mada_infinity is offline
Mada
Location: USA
 
Join Date: Feb 2013
Posts: 15
Send a message via MSN to Mada_infinity Send a message via Yahoo to Mada_infinity
Mein Auto: 2003 bmw 530i
Thank u so much guys I disconnected the battery for a min and now the light is gone
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms