Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-16-2012, 05:08 PM
TDiLisio TDiLisio is offline
Registered User
Location: Stephens City, Va
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 1992 525i E34/M50 227K mi
Question Windows stopped working until ignition reset

Hi Folks,

I'm new to the forum, and new to BMW DIY. Hello from Stephens City, Va.

The wife recently purchased a 1992 525i with the M50 engine and 227k Miles. The guy she bought it from told her that his mechanic said everything under the car looked fine. Well... he needs to find a new mechanic. I won't go into what I found and fixed already, but obviously the mechanic wasn't familiar with thrust and control arms.

So today we were out test driving the car after replacing the thrust and control arms (which did help immensely on the shimmy at 65mph-ish. Thanks forum members)... I tried to roll down the windows at a drive thru... no windows would roll down. Playing with the switches didn't do anything. So I figured something electrical went wrong. I turned the ignition off, and restarted the engine and the windows worked...???

So we stopped and fed with the windows down, restarted the car and drove off. Was a little cold so we tried to get the windows up. Nothing. Stopped the car, turned the engine off and then turned the key to the second position (before hitting the starter) and the windows rolled up. But that was it... they wouldn't work again until the power was cycled.

Damn... I can see another weekend shot to crap working on this thing.

From sifting thru the forum, I see mention of 2 items... Fusible link and a GM. I'm kinda leaning toward the GM because the windows work when there is a power cycle (it seems). I think I would benefit from replacing both (future problems) in that the fusible link is fairly cheap (I think).

Is there a proper part name for these? or better yet a part number?... I can't seem to find a "general module" or "fusible link" on the BMW parts site in south Atlanta. I found a basic module... but at $400... I'm hoping that's not it.

Whats in the GM that fails? relays? computer chips? solder joints?

Thanks for any help you can provide.
Tony.
Reply With Quote
Ads by Google
  #2  
Old 12-17-2012, 05:57 PM
paperplane94 paperplane94 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jan 2012
Posts: 927
Mein Auto: 1989 525i M20B25
your problem is pretty unique, so you may have to open it up and find out yourself.
Reply With Quote
  #3  
Old 12-18-2012, 03:23 AM
TDiLisio TDiLisio is offline
Registered User
Location: Stephens City, Va
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 1992 525i E34/M50 227K mi
I hope to get to it tonight. Purchased a few fuse links beforehand just in case...

The wife got in it yesterday and it worked fine.

But... I'm still gonna pull the seat, replace the fuse and check the GM.
Reply With Quote
  #4  
Old 01-20-2013, 03:56 PM
TDiLisio TDiLisio is offline
Registered User
Location: Stephens City, Va
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 1992 525i E34/M50 227K mi
Well... I replaced the fuse even though it looked ok, I attempted removing the GM module with no luck. I just pushed it in real good and screwed the cover back down. Haven't had any problems with it since.

Took it on a first voyage (for the car) to key west... car was a dream to drive. decent gas mileage... 25-27MPG. Probably could have been better had I chose a lower cruise speed. I think this car is a keeper.
Reply With Quote
  #5  
Old 01-20-2013, 08:47 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 1,908
Mein Auto: E23;E30;E38;E32;E34 +
Could be you settled in a plug correctly. Cheap fix!! Hope it stays good. Enjoy your drive!
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E30 318i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms