Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-20-2012, 09:13 AM
MurrayP MurrayP is offline
Registered User
Location: Kingston Ontario
 
Join Date: Apr 2009
Posts: 78
Mein Auto: 98 540i
1998 540i M62 Water Pump

Just replaced my water pump in the last couple of weeks (along with all other cooling system components since I had a leaking valley pan gasket and high milage). I used the BMW OEM version with the plastic impeller (metal impeller was out of stock and not available). My old water pump was fine and did not make the noise this one is making. What do you think - is this a warranty claim??

Reply With Quote
Advertisement
  #2  
Old 05-20-2012, 10:32 AM
JimLev JimLev is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,647
Mein Auto: 540/6, S60 Volvo, Tribeca
Are you sure it's coming from the water pump?
Bring it back to BMW, 2 yr warranty on parts.
Years ago I bought a new WP from BMW. It had a slight squeak when idling at 500 rpm. If you turned on the AC the idle goes up to 700 RPM and the squeak goes away. BMW gave me a new pump and even offered to install it for free.
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
  #3  
Old 05-20-2012, 11:36 AM
MurrayP MurrayP is offline
Registered User
Location: Kingston Ontario
 
Join Date: Apr 2009
Posts: 78
Mein Auto: 98 540i
I purchased about $1,500 of parts from an online house in CA that makes the boarder to Canada easy. They are very good but I don't see them listed as a site sponsor so I won't advertise them. It started with the valley pan, CCV, VCG, water pump, thermostat, spark plugs and all hoses. Got her all back together, overfilled the expansion tank (didn't pay attention to the proper process) and quickly burst (on 1 mile test drive) the radiator hose at the famous driver side upper hose connection point.

Yes, I know, I've read it a thousand times here, you have to do a complete cooling system overhaul...

So, I ordered the fan, clutch, expansion tank and radiator. Installed them this weekend. Used the special BMW blue coolant (for a second time). Bled the system properly this time and all appears to be well...except for this ticking water pump! I'll send a link to the video to the parts house and see what they have to say.

I've never wrenched on a car before but all the help on this forum in particular gave me the stones to try. The day I got the car in Toronto last July, I droped by the BMW dealer closest to me (2.5 hrs away from my home but was on the way home from Toronto) and spent $170 on an oil change. Had I had all of the above done at that same dealer, I suspect I would be out $3-$4K by now.

I got pricing on some of the parts from that dealer (Endras) and they were x4 in comparison on some of the parts I purchased in CA. The difference was staggering! I got the coolant from Endras (twice) in the last few weeks and bought oil and a filter kit - $90 friggen bucks yall for 8 quarts!

Yes I know, reasonable to buy, expensive to maintain! Lot's of fun though!
Reply With Quote
  #4  
Old 01-30-2013, 11:18 PM
killahbeatz killahbeatz is offline
Registered User
Location: CT
 
Join Date: Jun 2011
Posts: 12
Mein Auto: 540i
MurrayP did you ever find out if it was the pump. I just installed a new water pump and it did the same noise. I drove it for an hour and the noise was gone. I am going to see if it still make's that noises in the morning. I'm thinking that I tighten the belt tension to tight
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms