Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2013, 09:13 AM
ddudaski ddudaski is offline
Registered User
Location: New Jersey
 
Join Date: Jan 2013
Posts: 3
Mein Auto: 2000 528i/5mt
Nav help please...

Sorry to post on this topic but I really cant find any info on my particular setup. I have a 2000 528 with the cassett player and small nav screen. I purchased the car one week ago and the seller said the screen worked until he changed the battery a week ago. I checked all the fuses, disconnected the battery overnight, and checked all the connections. Anyone have any suggestions on what to do next. This is my first BMW and i dont really know my way around yet. Thanks
Reply With Quote
Advertisement
  #2  
Old 01-29-2013, 06:21 PM
Trauma hawk Trauma hawk is offline
Registered User
Location: Queens NY
 
Join Date: Feb 2012
Posts: 37
Mein Auto: 99 528it w sport package
Might be your navigation computer where the cd goes in it probably went bad it happen to me when I first got my 99 528it bought a used on from my mechanics friend and it works fine now

Sent from my SGH-T999 using Bimmer App
Reply With Quote
  #3  
Old 01-30-2013, 05:38 AM
JKRIT JKRIT is offline
Officially Welcomed to the 'Fest
Location: Hollis, NH
 
Join Date: Feb 2008
Posts: 497
Mein Auto: '03 525i
Clean the disc and try it again. Mine intermittently failed to run when I first got it from the PO, and the dealer said the disc unit was probably on its way out. I just cleaned the disc so the unit could read it properly, and I have never had any trouble with it since.
Reply With Quote
  #4  
Old 01-31-2013, 07:27 AM
ddudaski ddudaski is offline
Registered User
Location: New Jersey
 
Join Date: Jan 2013
Posts: 3
Mein Auto: 2000 528i/5mt
thanks. I will try that tonight. anyone know why that stops the clock and radio display. also, would the screen be completely dead if that was the case
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms