Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2013, 01:20 PM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,548
Mein Auto: 2003 530iA
Electronic problem I believe related to the crash recognition program

Here is what happens:
When I want to start the car (key in ignition, Pos "0"), the flashers all of a sudden start, doors unlock and the cabin light is on. You can stop the flashers by pressing the central button for them, the light stays on. They remote key is not operating. you have to hit the unlock button - one beep, then lock button - 2 beeps, the light turns off and the car is OK now. Sometimes it happens when I arrive home, just before turning off the engine.

It is very similar to the crash recognition program for these cars, which at an iminent crash will do exactly the same plus the airbag(s) would deploy.

I had this symptom sporadically for about 4-5 years now - it happened usually in winter once or twice, when I entered a heated garage from the cold. It had to be very cold, like -30C or lower (this is -22F or lower). heated garage is above +10C (50 F). This winter however it started going gangbusters on me, almost every day, no matter what the ambient temp is.

I checked the battery, and it checks OK. I checked the ignition switch and it still looks good.

Anyone can help me out with this? Can it be a bad contact, and if yes, where? Is the respective module going out, and if yes, which exactly is it, and where is it located? There are absolutely no codes.
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
Advertisement
  #2  
Old 01-04-2013, 01:38 PM
Josh P.'s Avatar
Josh P. Josh P. is offline
Bimmerholic
Location: Philly
 
Join Date: Jul 2009
Posts: 1,686
Mein Auto: 2001 530 SP/PP/CWP/Slush
What happens with the other key? have you tried re-initializing your keys?

IIRC the crash recognition program also blows off the + battery cable and clearly that is not happening.

This sounds more like it's related to the alarm and remote locking/unlocking, at least to me.
__________________

2001 530 Steel Blue Metallic, purchased Dec 03
SP/PP/CWP/Slushbox (I know I know)

OEM M5 bumper, 40% Huper Optik ceramic tint, Dice Silverline Pro iPod adapter, 540SP radial spokes, Zimmerman Z-Coat rotors w/ Hawk HPS pads
"Mods": driveshaft, cooling system, Vanos, CCV, PSR, VCG, FSU, spark plugs, buncha belts-n-hoses, & other things I'd just as soon forget

BMW CCA member for 12 years
Reply With Quote
  #3  
Old 01-04-2013, 02:25 PM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,548
Mein Auto: 2003 530iA
Quote:
Originally Posted by Josh P. View Post
What happens with the other key? have you tried re-initializing your keys?

IIRC the crash recognition program also blows off the + battery cable and clearly that is not happening.

This sounds more like it's related to the alarm and remote locking/unlocking, at least to me.
Both keys work the same and have same issue. It's random, but over the last month or so it happens at least every other day. Really annoying and it's almost like waiting for something to fail in a manner that the car will be immobilized. I don't know?

Maybe the battery cable, airbag(s) and seat belt tensioner are set off by another sensor triggered in tandem with the crash sensor?
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
  #4  
Old 01-24-2013, 12:38 PM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,548
Mein Auto: 2003 530iA
Update:

GT1 showed nothing. Tested charging system: OK, checked continuity: OK, checked for loose ground wires: none.

Last thing - the battery. Because it's fairly new. Turned out it doesn't hold charge.
Replaced the battery under warranty, symptoms gone. All's good.

Another thread with the exact symptoms, on a different forum, in case one of you exhibit this.
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
  #5  
Old 01-29-2013, 08:24 AM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,548
Mein Auto: 2003 530iA
Symptom is back.

As soon as i put the key in the ignition and barely turn 1/100" (pos I is not reached - the key just moves from pos 00:
  1. hazard lights are on
  2. doors unlock
  3. dome light turns on
Have to take the key out, use the remote to lock-unlock (otherwise the dome light stays on, and the central console locking mechanism does not work).

Scanned with GT1, and in INPA I got:
512001 DWA-LED flashes after activation
512002 Anti-theft alarm system, false alarm
512003 Central locking unlocks or locks automatically
512004 Central locking button not functioning
512048 radio and reception problem during vehicle access.

Contents of defect code memories (not selectable or deletable):
Radio - No communication possible
ZKE - 94 GM: LED for anti-theft alarm system, open circuit
ZKE - 5E GM: Central-locking drive, passenger's door

The battery looks strong. Not sure what the problem is.

I really need some help with this.

P.S.: Also the INPA Diagnosis Test Schedule gave me this:
ZKE - 94 GM: LED for anti-theft alarm system, open circuit
Burglar alarmsystem (ZKE) zke
ZKE - 5E GM: Central-locking drive, passenger's door
Seat/steering - column memory slm
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby

Last edited by doru; 01-29-2013 at 09:22 AM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms