Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2013, 05:19 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
NAV turning on and off affecting radio play

Hi E65/E66ers,

Recently I noticed that my NAV would flicker and then turn off and come back on. When it turns off, so does my radio. So i went to the back of the car and noticed the the unit actually never turns off and just keeps spinning the disk. And I can't eject the disk, it seems to be stuck. It's the older CD not DVD unit which I planned to upgrade it anyway but it's annoying that it's not working now...

This morning I disconnected the NAV unit and now my iDrive is not working and neither is the radio. Is this right? I did notice that there are some fiber optics connection that stayed on so I figured there's some kind of "check and balances" thing going on with the system. Since the NAV is not there maybe it shut everything down?

Can I bypass the NAV to get the radio and iDrive working again?

Thanks in advance for your help!


EazyE66
Reply With Quote
Advertisement
  #2  
Old 01-21-2013, 05:22 PM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,866
Mein Auto: 750I
Yes..you need a fiber optic diagnostic loop. You can buy it from the dealer for under $40.
__________________
Reply With Quote
  #3  
Old 01-21-2013, 05:40 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
Quote:
Originally Posted by DFEL750I View Post
Yes..you need a fiber optic diagnostic loop. You can buy it from the dealer for under $40.
Cool, I was thinking to loop it but wasn't sure if they had one for this.

Thanks!
Reply With Quote
  #4  
Old 01-21-2013, 05:48 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
the fiber optic network is a ring network. disconnect any device and you break the ring, and nothing works.... (bare minimum on i drive)

but if hte nav has a physical problem, it shouldnt affect th whole system (but it can)... when does the problem happen... when you are imputting data into navi in i drive or while being directed? does the radio go off when not using navi...

what is it like when this happens.. does it "glitch out"? do you get like a static beep from your speakers and everything kinda reboots? or is it like some one hit the volume knob and it just turned off and you have to turn it back on?
Reply With Quote
  #5  
Old 01-21-2013, 06:08 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
^^

This makes sense to me. (fiber ring network)

The Navi is fck'd up, it never turns off and now it won't eject the CD. I don't use the NAV feature because it sucks but I leave the map on just to see whats coming up. When the radio is on, the nav will randomly black out along with the radio. The nav used to black glitch out and not affect the radio, but now it totally blacks out and takes the radio with it, no static beeping or noise, just cuts out.
Reply With Quote
  #6  
Old 01-21-2013, 06:32 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
hmmm... well i was asking becasue i had a similar problem... radio would glitch out and static noise (like a glitch) and the whole i drive would go blank and come back... at first it was while being guided by navi on freeway while listening to music, then without navi, then whole dash would glitch and it got worse and worse to the point where the whole car would literall shut down on the freeway and then start back up because it was already rolling at 70 lol.... anyway it was the alternator and IVM..... but radio/display was first symptom...
Reply With Quote
  #7  
Old 01-23-2013, 01:30 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
Quote:
Originally Posted by 7Rage View Post
hmmm... well i was asking becasue i had a similar problem... radio would glitch out and static noise (like a glitch) and the whole i drive would go blank and come back... at first it was while being guided by navi on freeway while listening to music, then without navi, then whole dash would glitch and it got worse and worse to the point where the whole car would literall shut down on the freeway and then start back up because it was already rolling at 70 lol.... anyway it was the alternator and IVM..... but radio/display was first symptom...
It did kind of do the same thing you are saying sometimes. What is IVM?

Also, will the loop fit on the NAV harness in the trunk?
Reply With Quote
  #8  
Old 01-23-2013, 02:52 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
loop should... all fiber optic harnesses look the same from what I have seen... IVM is integrated voltage module.... causes various problems.... someone just got one one ebay for 100 or 200.... and its a 20 minute job....
Reply With Quote
  #9  
Old 01-23-2013, 02:59 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
Interesting, I wonder if it is worth changing the IVM as part of preventive maintenance. Where is it located?
Reply With Quote
  #10  
Old 01-23-2013, 03:05 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
http://www.flickr.com/photos/2810754...n/photostream/ this is a guide from keif, a memeber on here.... preventaiv maintenance? ehh... i dunno... i wouldnt.... but if you find it cheap may be useful to have a spare...
Reply With Quote
  #11  
Old 01-23-2013, 03:09 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
yea, $135 shipped for a new one
Reply With Quote
  #12  
Old 01-23-2013, 03:13 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
brand new or new to you (used)
Reply With Quote
  #13  
Old 01-23-2013, 03:25 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
brand new, new, not new to me used
Reply With Quote
  #14  
Old 01-23-2013, 03:39 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
i'd buy it at that price... but i dont know what they go for TBH.... but that sounds like a good deal on that module compared to what dealer cost is.... If it were brand new I would scoop it up to have it on hand....
Reply With Quote
  #15  
Old 01-23-2013, 10:17 PM
Dan_E65 Dan_E65 is offline
Registered User
Location: Essex, UK
 
Join Date: Feb 2012
Posts: 59
Mein Auto: '06 E65 730d Sport
Before you start replacing modules all over the place, it's best to zero in on the actual cause of the problem. I'd put money on it being a faulty nav drive (not the whole module, just the drive or maybe even just the laser unit).

Concentrate on the nav unit. You should be able to eject the disc by holding down the eject button. Sometimes this can take a minute or two. Hopefully it will come out and you can see if the network runs ok without a nav disc (effectively jumping out the nav drive from the loop). If not, disconnect the nav unit with a fibre optic ring either bought from a dealer or borrowed from a friends car... Don't use the one in your glovebox as you'll just be creating another break in the loop).

If the network functions ok, you've found the problematic module. This can probably be repaired.
Reply With Quote
  #16  
Old 01-23-2013, 10:21 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
Just FYI eazy and dan, I wasnt saying that IVM is definitely the problem.. It was my problem and explained my symptoms to see if they were similar.... the IVM seems to go out for quite a few people, so i was saying if it were me, I would pick up a spare for out of warranty repair...

@Eazy, definitely get that loop and cancel out the navi....
Reply With Quote
  #17  
Old 01-25-2013, 04:08 AM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
I agree, it's the NAV drive.

Got the same problem with a NAVI03 I recently purchased so plugged in the old NAVI01 and audio resets and screen resets went away.

Its as if the NAV cant initialise (in my case i think the laser needs replacing) and every maybe 5 minutes it forces a MOST Bus reset causing the audio reset
Reply With Quote
  #18  
Old 01-30-2013, 11:37 AM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
okay, So i received a replacement Nav last night and installed it temporarily. I upgraded to an '06 version that came with the disk, but burned a 2012 disk a while back so i popped that one in this morning. It looks to be all good now! Got to listen to my tunes and see the newer map style without it resetting or shutting off.

Now my question is - Am I missing anything if I don't update my screen? I believe I saw somewhere that people are replacing both the drive and screen when doing the upgrade.

Thanks All!
Reply With Quote
  #19  
Old 01-30-2013, 12:26 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by EAZYE66 View Post
okay, So i received a replacement Nav last night and installed it temporarily. I upgraded to an '06 version that came with the disk, but burned a 2012 disk a while back so i popped that one in this morning. It looks to be all good now! Got to listen to my tunes and see the newer map style without it resetting or shutting off.

Now my question is - Am I missing anything if I don't update my screen? I believe I saw somewhere that people are replacing both the drive and screen when doing the upgrade.

Thanks All!
No it's not necessary bc you will also need new ask unit and fm tuner and etc
Reply With Quote
  #20  
Old 01-30-2013, 12:40 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by SFbay View Post
No it's not necessary bc you will also need new ask unit and fm tuner and etc
WRoNG !!!

True it is not necessary , but not true you would need to also upgrade the
Ask unit & FM tuner & ect ...




However You would get some more Navi features & better color & picture quality if you
Also upgrade your MMI ...
Reply With Quote
  #21  
Old 01-30-2013, 01:11 PM
EAZYE66 EAZYE66 is offline
Registered User
Location: CA
 
Join Date: Feb 2012
Posts: 21
Mein Auto: E66
Quote:
Originally Posted by PAPER View Post
WRoNG !!!

True it is not necessary , but not true you would need to also upgrade the
Ask unit & FM tuner & ect ...




However You would get some more Navi features & better color & picture quality if you
Also upgrade your MMI ...


Thanks Paper!
Anyone selling one? What's the right $ range for them? Or what's the right part# for me to get? They are kind of all over the place on fleabay.

And can you PM me some details about the custom 2013 map? thanks!

Last edited by EAZYE66; 01-30-2013 at 01:23 PM.
Reply With Quote
  #22  
Old 01-30-2013, 01:24 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by EAZYE66 View Post
Thanks Paper!

I take it, MMI is the monitor? Anyone selling one? What's the right $ range for them? They are kind of all over the place on fleabay.

And can you PM me some details about the custom 2013 map? thanks!
You can find an MMI on ebay usually between $500 & $700 ...
Ill pm you now regarding my disc
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms