Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 02-26-2013, 06:41 PM
Ena01 Ena01 is offline
Registered User
Location: Georgia
 
Join Date: Oct 2012
Posts: 26
Mein Auto: 525i and 325is
1995 525i Alternator won't charge correctly

Ok, replaced the computer for the 525i since it wouldnt start now it starts. But now it wont run on the alternator? It only runs on the battery, i have changed the alternator 2 times!!! and still it will not charge right. I think it might be burning them I dont know why. I try the stomp test and it wont work neither. I know who to do it since i have done it on my brothers 325is. Please i need any tips.

Last edited by Ena01; 02-26-2013 at 06:45 PM. Reason: heading was to simple
Reply With Quote
Advertisement
  #2  
Old 02-27-2013, 12:30 AM
_Ethrty-Andy_'s Avatar
_Ethrty-Andy_ _Ethrty-Andy_ is offline
E34 Converted E30 Fanatic
Location: Humble New Zealand
 
Join Date: Nov 2008
Posts: 6,140
Send a message via MSN to _Ethrty-Andy_
Mein Auto: E34 Touring AC Schnitzer
is the cable connected etc? inspect grounding straps.

also is the alternator you replaced it with a rebuilt item or just out of a wreckers yard?
__________________

E30 above Sold

E34 V12 Project Thread Here: http://www.bimmerfest.com/forums/sho...=502437&page=4
Last updated 2nd January 2014
Reply With Quote
  #3  
Old 02-27-2013, 08:14 AM
imae34driver imae34driver is offline
FCK HONDA
Location: Orange County , CA
 
Join Date: Feb 2013
Posts: 2,305
Mein Auto: 1995 540i SPORT /6 spd
FIRST IDEA IN MY HEAD - some alternators come with a PIN OR TAB that once removed the brushes then will touch the stator (via spring) and the alternator then is ACTIVE.. this tab is supossed to be removed before install.. USUALLY RED AND ON THE BACK OR SDE!

other than that, 1 st check fuses and fused links ( aka ground straps), positive post on alternator.. and its connectors..

if it comes out agian test it and maybe the old part 2.. make sure you are working with know GOOD PARTS..

2nd make sure your battery is chargeable.. WHAT IF, your alternator worked but your battery so dead i'ts just killing the new alternator?

USE A DMM to check voltage output and let me know.

THE VOLTAGE REGULATOR MONITORS THE BATTERY VOLTAGE AND WILL SWITCH THE ALTERNATOR ON & OFF TO MANTAN 12.8V AS NEEDED..

IF INSTALLED AND ASSEMBLED PROPERLY, THIS SHOULD BE THE PART NOT DOING ITS JOB.. (inside alternator)

a ECU has no affect on charging i believe.. all the V regulator i think.. anyone back this up???

Last edited by imae34driver; 02-27-2013 at 08:21 AM.
Reply With Quote
  #4  
Old 02-27-2013, 11:04 AM
Ena01 Ena01 is offline
Registered User
Location: Georgia
 
Join Date: Oct 2012
Posts: 26
Mein Auto: 525i and 325is
the first one was a rebuilt i bought and the other one as well from autozone.
Reply With Quote
  #5  
Old 02-27-2013, 11:17 AM
Ena01 Ena01 is offline
Registered User
Location: Georgia
 
Join Date: Oct 2012
Posts: 26
Mein Auto: 525i and 325is
ok, where do i find the ground straps?
Reply With Quote
  #6  
Old 02-27-2013, 11:23 AM
imae34driver imae34driver is offline
FCK HONDA
Location: Orange County , CA
 
Join Date: Feb 2013
Posts: 2,305
Mein Auto: 1995 540i SPORT /6 spd
Exclamation just 2 be clear..

Quote:
Originally Posted by ena01 View Post
the first one was a rebuilt i bought and the other one as well from autozone.
you do remember removing the brush retainer pin before install??
Reply With Quote
  #7  
Old 02-27-2013, 11:44 AM
Ena01 Ena01 is offline
Registered User
Location: Georgia
 
Join Date: Oct 2012
Posts: 26
Mein Auto: 525i and 325is
it didn't bring a pin on the side.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms