Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2013, 06:06 AM
nedfunnell nedfunnell is offline
Registered User
Location: Indiana
 
Join Date: Sep 2012
Posts: 18
Mein Auto: 1985 325e
Rich running, high idle, and misfiring walk into a bar...

Good morning gents,

I have an ongoing issue with my 85 325e. For a while, it has been running rich. I has had an on-and-off misfire/stumbling issue. Lately, this got more interesting (and severe) and I would like your input. Here are the three symptoms:

1. Running rich. Sometimes more rich, sometimes less so.

2. Idles high. It varies between 1500 RPM and 2700 RPM when this issue is present. It never idles high when cold, but is now consistently idling high when hot. It is getting extra fuel and air somehow to cause this: enough to cause the high idle, and enough to give me unwanted power when going slowly: I can put it in 3rd at 20mph and accelerate to 25 and and beyond with my foot off the gas completely. It's weird to shift at 2500RPM and have your revs go up when you clutch out with your foot off of the gas.

3. Really bad misfire/stumbling issue happens when driving sometimes. The bad, not-all-my-power-strokes-are-happening-and-I-have-no-power kind that makes your car lurch back and forth. This usually goes on for a minute or two and then smooths out. Seems to be better at higher RPM if I can get there.

I thought of a vacuum leak, and replaced the hose to my ICV- didn't affect it. My intake boot is only a few months old. There could be another one somewhere. I did the test of taking the vacuum hose off of my FPR and waiting for an RPM rise. The rise did happen, albeit slowly and after a slight delay. The plugs and plug wires are recently new. The PO changed out an O2 sensor before I got the car (10k miles ago?). Could it have gone bad again due to an underlying issue and have this problem?

What should I look at next?
Reply With Quote
Advertisement
  #2  
Old 02-04-2013, 05:46 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 7,293
Mein Auto: 2012 hypermotard 796
sounds like the fpr is bad or the tps is out of wack
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms