Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-28-2014, 10:51 AM
Tourque Junkie Tourque Junkie is offline
Registered User
Location: Massachusetts
 
Join Date: Oct 2011
Posts: 32
Mein Auto: Acura TL
Electrical Gremlins

It all seems to have started with a small burn mark on the lower left side of my nav screen. The burn mark has been expanding and now measures about an inch and a half. Next the radio would go silent for a few seconds then return to normal. At first the display remained on. The frequency of this condition has increased over time. Now the display goes dark when this occurs. Almost daily now the 4 wheel drive inactive fault activates corresponding with the radio issue. Several times the hazard lights activate along with the other faults. I have not searched the threads to learn if others have experienced this. Any thoughts?
Reply With Quote
Ads by Google
  #2  
Old 02-28-2014, 10:55 AM
tmvE39/E53/Z32's Avatar
tmvE39/E53/Z32 tmvE39/E53/Z32 is offline
Officially Welcomed to the 'Fest
Location: Seattle --> Atlanta
 
Join Date: Dec 2010
Posts: 1,880
Mein Auto: 03 540, 06 E53 4.8, Z32TT
Are we talking about the Acura TL or what?
__________________

FS 2001 ///M5
http://www.bimmerfest.com/forums/sho...d.php?t=791509
2000 Dinan S1 //M5 (my DD) 06 DINAN E53 4.8iS (wife's DD), 90 Straman Z32TT (my pride & joy ride)

Gone, but not forgotten: 01 E53 3.0i, 01 525i Sport, 03 DINAN 540i MSport and 91 Z32TwinTurbo
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms