Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-28-2013, 09:23 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
Telescoping wheel moves up and dome light turned on while driving....

Just got off the freeway. Telescoping wheel moved up and domelight turned on as if i took the key out of the ignition. Cruise set at 70 change lanes and bam. Move back over a lane turn off cruise and again. And again. And then one last time but only the dome light turned on.

I think something electrical is loose. It happened when the road was bumpy or changing lanes hitting the lane markers. Ill search and see if i find anything but boy was that scary.
Reply With Quote
Advertisement
  #2  
Old 02-28-2013, 09:56 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
Ummm windows arent working either apparently. Central locking works. If i open a door and close it the dome light stays on. Guess i have another weekend working on her
Reply With Quote
  #3  
Old 02-28-2013, 09:56 PM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,507
Mein Auto: 2003 530iA
I think the ignition switch might be done.
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
  #4  
Old 02-28-2013, 10:02 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
Turned off the ca and the wheel didnt move up. Turned it back on windows worked but the one touch auto roll didnt. Im guess a loose fuse or wire somewhere.
Reply With Quote
  #5  
Old 02-28-2013, 10:13 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
Hmmm possible. I tried the sun visor test on my way home and nothing changed. Just got home and forgot my laptop at work! Booooooo. Ill reseat all fuses in the am just in case and hope i make it to work with out a major hiccup.
Reply With Quote
  #6  
Old 03-02-2013, 12:46 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
so yesterday morning i pushed in all my fuses. fuse 5,6,7 area is where the issue was. after looking up what the fuses did it was either 6, 7, or both. when i pushed this area this area the steering wheel moved up then back down.

so i pushed it in and all has been good so far. if any other issues arise however ill be quick to get on the ignition switch.

hope this can help someone in the future.
Reply With Quote
  #7  
Old 03-02-2013, 06:01 PM
cn90 cn90 is offline
Officially Welcomed to the 'Fest
Location: Omaha NE
 
Join Date: Mar 2006
Posts: 12,914
Mein Auto: 1998 528i 5-sp 140K+
The symptoms will be back and you will head to BMW dealer to buy a new ignition switch.
Reply With Quote
  #8  
Old 03-02-2013, 06:45 PM
rcmarty rcmarty is offline
Registered User
Location: Penticton B.C. Canada
 
Join Date: Oct 2011
Posts: 25
Mein Auto: 03 540 M sport
I replaced my ignition switch also. I had the visor crazyness in mine.

Another possible thing to look for is the connection on the side of the seat. It does the bi rocker. My front screw holding in the trim came loose/broke the little tab off i assume.

Anyways it was loose and with a few times in and out of the car i managed to half unplug the connector.

This connector loose caused all kinds of weird stuff including the sterring wheel.

Just another spot that causes havoc

martin
Reply With Quote
  #9  
Old 03-02-2013, 06:51 PM
Sgrim Sgrim is offline
Registered User
Location: Edmond, OK
 
Join Date: Feb 2013
Posts: 5
Mein Auto: 97 328i, 2000 528i Sport
I had same issue. Sun visor test did not work every time it did it. Some other things that would happen are: stereo shuts off, brake lights would come on, brake and abs light in dash would also come on. I purchased a ignition switch from local BMW dealer and for $82.00 and 20 minutes of my time, the issues were all fixed. Hope this helps and good luck.

Last edited by Sgrim; 03-02-2013 at 09:43 PM.
Reply With Quote
  #10  
Old 03-02-2013, 07:18 PM
daytradeoil daytradeoil is offline
Officially Welcomed to the 'Fest
Location: Canada's Mexico
 
Join Date: Mar 2010
Posts: 285
Mein Auto: 2001 bmw 525i
So far so good. Almost 200 miles. When and if it comes back ill get the switch.... Hopefully the fuses were the issue.

Thank u all
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms