Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-18-2014, 05:42 PM
miaogod miaogod is offline
Registered User
Location: London
 
Join Date: Jan 2014
Posts: 1
Mein Auto: E60 2004 530i
Help! Transmission Fault

My E60 2004 530i with 60,000 milage has transmission faulty issues. Sometimes it doesn't recognize P R N, or sometimes it doesn't recognize D, or occasionally recognize nothing. The car starts all right from cold. After driving for minutes, the transmission fault will dump out and turned into safe mode. If the whether is cold--below 5 degree celsius, the faults never comes out. Have the car diagnosed at main dealer. They told me code 5088--gear selector switch fault. However, when I diagnosed at an independent BMW specialist, I saw 11 times fault relating with valve on the diagnose machine which the specialist cleared the memory without explaining to me.
In addition, I noticed that there is noise like truck/diesel from the gear box, because I had carefully listened to the engine which sounds perfect and powerful when it is in neutral or parking stepping on the pedal.
Would it be problem with the gear box fluid problem? My understanding is bad gear box fluid caused the diesel like noise and the gear box got overheated that result EGS can not work properly. If the temperature is the issue, why there is no fault codes stating the high temperature?
Please help me. I have wasted lots of money in checking the faults and replaced the gear selector and end up with not being fixed.
Reply With Quote
Advertisement
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms