Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-12-2013, 08:24 AM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
Post CEL Codes with NO light

I recently had issues with misfires rough idle and oil leaking. I had 12 codes and my dash light was on. I replaced the CCV and all connecting hoses and the post cat O2 sensors. The oil leak was coming from a the broken hose that connects the CCV to the dipstick.

Now i dont seem to have any running issues at all. Idle has smoothed out and is constant along with the engine itself is running quieter and smoother. The oil leak was repaired....

BUT....now i have the following codes that dont seem to want to clear but yet they dont throw a CEL on the dash.

P0174 Bank 2 Lean
P0171 Bank 1 Lean
P0369 Exhaust camshaft position sensor
P0128 Thermostat Temperature Below regulated
P1193 PostCat Fuel Trim System Bank 2

Do i have a problem i wont see feel or hear? Should i just clear the codes and see if they return?

The last 3 codes appeared after i did the mentioned repairs. The top 2 were there prior to. My car has also passed emissions testing after the repairs as well.
Reply With Quote
Advertisement
  #2  
Old 02-12-2013, 08:29 AM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,786
Mein Auto: 2004 330Ci ZHP 3 pedals
Having stored codes doesn`t always trigger a CEL. Did you clear the codes recently ?
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #3  
Old 02-12-2013, 08:30 AM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
I haven't cleared them since i did the repairs because i wanted to see what codes would clear on their own after the work.
Reply With Quote
  #4  
Old 02-12-2013, 08:37 AM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,786
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by BROOKSBC View Post
I haven't cleared them since i did the repairs because i wanted to see what codes would clear on their own after the work.
I suggest clearing them all, and see if any return....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #5  
Old 02-12-2013, 08:59 AM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
Just re scanned on a cold engine and only the top 2 codes were present. I reset them.

Sent from my SAMSUNG-SGH-I747 using Bimmer App
Reply With Quote
  #6  
Old 02-12-2013, 11:41 AM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
Just re scanned on a warm engine and I have 2 codes

P0365 and P1191.



Sent from my SAMSUNG-SGH-I747 using Bimmer App
Reply With Quote
  #7  
Old 02-12-2013, 01:07 PM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,786
Mein Auto: 2004 330Ci ZHP 3 pedals
P0365 is Exhaust Cam Sensor

P1191 is Pre-Cat 02 sensor

There IS, however, a wrinkle attached to these 2 codes showing up together, to wit:

Your VANOS seals are probably shot, which allows the cams to go to full advance prematurely, triggering the above codes. The twist is that they`re *phantom* codes, there`s probably nothing wrong with the sensors, they`re being tricked by the cams advancing at the wrong time.
New VANOS seals will cure several problems....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #8  
Old 02-12-2013, 10:20 PM
heztheone heztheone is offline
Officially Welcomed to the 'Fest
Location: Lebanon (The Country)
 
Join Date: Oct 2009
Posts: 1,472
Mein Auto: 330i ZHP M/T
it could be as simple as a bad rewiring (in case u unplugged any wire while doing ur CCV). try unplug/plug tight everything you might have removed, clear your codes and check back.
same thing happened to me when i was cleaning my ICV/TB, got some codes, double checked everything, cleared codes, everything running smooth now.
if not, check your VANOS as Bob said
__________________


Give a man a fish and you feed him for a day. Give a man a Chef and he feeds him for a lifetime
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms