Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 02-22-2013, 09:31 AM
achtunge30 achtunge30 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Mar 2008
Posts: 149
Mein Auto: 87 325ic, 08 X3, 08 135i
08 X3 with Nav/Factory Sirius and installing Dice Mediabridge 1500

So i've searched and searched, read both the Sirius retrofit and Nav retrofit DIYs and even contacted BSW for install help but still very confused about the install...

I want to have the Mediabridge and still retain the factory Sirius option.

All the videos for the Mediabridge install indicate using the center console wiring. For Sirius equipped X3s, there is talk about adding a CDC extension cable that plugs into the back of the Sirius module in the trunk which would activate the center console wiring allowing this functionality.

BSW says that the CDC extension wiring would then plug into the Sirius and I either can install the Mediabridge in the trunk with the Sirius module or run the cabling all the way into the Center Console. This info contradicts what I've read about activating the already existing wiring in the console.

So to anyone that has done this install already, Mediabridge or other Dice, Dension Icelink etc., has factory Sirius and NAV, how do I enable the wiring in the center console to function. Surely people add CD Changers to X3s and they still go in the center console right??

I've already tried (without the CDC extension cable) to plug into the 3 and 6pin (non-SDARS) cabling in the center console and it seems the Mediabridge is powered and detected but no audio. I can switch between modes etc.. Again this configuration is without the CDC extension cable in place and rubber grommet still on the Sirius tuner.

I hope someone from this forum can help me and give me a reasonable answer and I am just overthinking this. I really want to be able to plug my iPhone in the center console area without having to take apart half the interior to run a long USB cable.
__________________
-Frank
1987 325ic Jet Black/Cardinal Red - S52'd
2008 135i Alpine White/Coral Red - Re-delivered 10/28/08
2008 X3 3.0si Monaco Blue/Gray
BMWCCA #397316

Last edited by achtunge30; 02-22-2013 at 03:01 PM.
Reply With Quote
Ads by Google
  #2  
Old 02-22-2013, 02:51 PM
achtunge30 achtunge30 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Mar 2008
Posts: 149
Mein Auto: 87 325ic, 08 X3, 08 135i
Couple of updates...

1.) Tried the CD-SDARS cable and same thing, Mediabridge detected on radio display, can switch modes but no audio.

2.) My CDC Extension cable arrived today, plugged in to Sirius Receiver and Mediabridge in the trunk area - basically, it replaces the rubber grommet on the receiver and plugs in there, then adds another 3 and 6 pin connector which you plug into the media bridge - everything works as designed, loving the A2DP streaming, but at some point, I will have to run a long USB cable to the console for iPhone charging and convenience or I can just go and buy a car charger for $10 and basically I paid $265 to stream bluetooth.

Please, if anyone has any prior installation experience that can chime in or is this pretty much all I can do?
__________________
-Frank
1987 325ic Jet Black/Cardinal Red - S52'd
2008 135i Alpine White/Coral Red - Re-delivered 10/28/08
2008 X3 3.0si Monaco Blue/Gray
BMWCCA #397316

Last edited by achtunge30; 02-22-2013 at 03:02 PM.
Reply With Quote
  #3  
Old 02-23-2013, 09:13 AM
bman12479 bman12479 is offline
Registered User
Location: Philadelphia
 
Join Date: Feb 2013
Posts: 2
Mein Auto: 2008 x3
Hi I just had Best Buy install mine last week and we had this same problem where the bridge was working but no audio.What you have to do is slide out the radio and you will see a connector that is just sitting there.Swap out the connector that is already plugged into the back of the radio with the one not in use and it will work.
Reply With Quote
  #4  
Old 02-23-2013, 09:19 AM
bman12479 bman12479 is offline
Registered User
Location: Philadelphia
 
Join Date: Feb 2013
Posts: 2
Mein Auto: 2008 x3
Actually I don't have factory Nav or Sirius in my x3 I had to get the scc1 sirius tuner to go with the dice but hey it's still work a try it may work

Sent from my SCH-I605 using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms