Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-23-2013, 11:41 AM
mco mco is offline
Registered User
Location: Wisconsin
 
Join Date: Feb 2013
Posts: 10
Mein Auto: X5 35D
X5 issues

New here. I have a 2010, X5 diesel that is CPO. Have had it for a couple of months and have been very happy with it. Experience a problem this week where I lost power steering to begin with, ending with a complete shut down of the car. Anyone else have this happen?
Reply With Quote
Advertisement
  #2  
Old 02-23-2013, 02:23 PM
PAX5 PAX5 is offline
Freude am Fahren
Location: Pennsylvania
 
Join Date: Jan 2011
Posts: 734
Mein Auto: X5 50i
Quote:
Originally Posted by mco View Post
New here. I have a 2010, X5 diesel that is CPO. Have had it for a couple of months and have been very happy with it. Experience a problem this week where I lost power steering to begin with, ending with a complete shut down of the car. Anyone else have this happen?
Please keep us posted ... this sounds extremely dangerous. Any symptoms while driving?

Apparently this is a relatively new problem and NHTSA is not involved yet, but your dealer should have been informed through BMWUSA.

Therefor, report this to NHTSA. Print a copy of your complaint registration and bring it with you to the dealer. You should also send a copy to BMWUSA.
__________________
PAX5
BMWCCA #20645
Reply With Quote
  #3  
Old 02-23-2013, 02:31 PM
Penguin Penguin is offline
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Aug 2003
Posts: 1,915
Mein Auto: Z4 and X5 Diesel
Quote:
Originally Posted by mco View Post
New here. I have a 2010, X5 diesel that is CPO. Have had it for a couple of months and have been very happy with it. Experience a problem this week where I lost power steering to begin with, ending with a complete shut down of the car. Anyone else have this happen?
Sounds like the alternator/idler pulley bolt breaking issue might be the problem. Bolt breaks, you lose power steering, loose belt get's into other stuff and causes the total shutdown.

There's a recent recall to replace the bolt and secure the new one with "loctite" type stuff. Do you know if the recall was done on your vehicle?
Reply With Quote
  #4  
Old 02-23-2013, 05:23 PM
ard ard is offline
Resident Curmudgeon
Location: CA
 
Join Date: Jul 2009
Posts: 9,575
Mein Auto: '12 X5 35d/E39M5/996TTX50
OP created two threads on the same issue.....
__________________
Keep it as simple as possible...but no simpler.
Reply With Quote
  #5  
Old 02-24-2013, 05:30 AM
mco mco is offline
Registered User
Location: Wisconsin
 
Join Date: Feb 2013
Posts: 10
Mein Auto: X5 35D
Penguin--My dealership is claiming to have done the recall repair Nov. 27th. The official letter of recall is dated Nov. 26th. I'm not believing they fixed it then...seems hard to believe BMW had all the repair parts ready at all dealerships the next day. Furthermore, my car was back at the dealership for another problem in January. If they didn't fix it in Nov. they certainly should have then.

PAX5--thanks for the advice. I did file a complaint like you mentioned. I'm just worried that if it was really fixed the first time, then the repair doesn't work and all of these vehicles are still on the road. No symptoms as I was driving...the steering got real stiff and I realized it was out. There was no code at the time thrown, but shortly after as I was attempting to get to a side street, I got a "battery discharge" warning.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms