Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2013, 06:18 AM
Zkanaan Zkanaan is offline
zeyad
Location: boston, ma
 
Join Date: Jan 2013
Posts: 17
Mein Auto: 2006 530xi
Oil level sensor malfunction

I have 06 530xi , i had my oil change done week ago , i only drove 200 miles and now i have msg says oil level sensor malfunction. Help
Reply With Quote
Ads by Google
  #2  
Old 01-27-2013, 09:50 AM
toga94m toga94m is offline
Registered User
Location: Upstate NY
 
Join Date: Apr 2012
Posts: 83
Mein Auto: 2006 530xiT
I don't know where in "USA" you live, but if it's somewhere cold and your car doesn't regularly get warmed up with a long drive, you might read this thread...

http://www.bimmerfest.com/forums/sho...d.php?t=419633

My car claimed I was below minimum on oil, but it turned out the sensor was confused and wanted a vacation somewhere warm.
__________________
2006 530xiT 6MT - 124k miles - 3rd owner - sport & cold packages
Reply With Quote
  #3  
Old 01-27-2013, 10:19 AM
Zkanaan Zkanaan is offline
zeyad
Location: boston, ma
 
Join Date: Jan 2013
Posts: 17
Mein Auto: 2006 530xi
oil level sensor

Thanks for your reply, I live in Boston, MA. Here it is below freezing, I dont drive much just to work which is five minutes away. Your message helped a lot you are rite. I shouldnt worry then? I love my car, so I panic with any message thats not good.
Thanks
Ziad
Reply With Quote
  #4  
Old 01-28-2013, 07:51 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,292
Mein Auto: '06 530i, '07 C280, ML320
Error message says "Oil level sensor malfunction"? Buy a new oil level sensor, take a CLEAN oil pan, let all oil drain in to pan, replace the the oil level sensor and then pour the oil back in to the engine. Be glad oil level sensor is mounted OUTSIDE the pan (unlike some MB cars) and it's accessible from below the car. It's mounted on the lower oil pan.

Since your car doesn't have dip stick to check oil level, you MUST rely on the integrity of the oil level sensor. Hence, my recommendation to go ahead and replace that sensor without much debate.

Last edited by pcy; 01-28-2013 at 07:59 AM.
Reply With Quote
  #5  
Old 01-28-2013, 01:56 PM
UltimateDriving UltimateDriving is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Oct 2007
Posts: 852
Mein Auto: A Car
Yeah, you should change the oil sensor with a new one ASAP.
Since you are going to drain the oil anyways, i would suggest you to change the oil also (So you save time and skip the next oil change) but that's just an extra that might not really be necessary, check when was your last oil change.
Reply With Quote
  #6  
Old 01-28-2013, 03:53 PM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,292
Mein Auto: '06 530i, '07 C280, ML320
Quote:
Originally Posted by UltimateDriving View Post
...
Since you are going to drain the oil anyways, i would suggest you to change the oil also (So you save time and skip the next oil change) but that's just an extra that might not really be necessary, check when was your last oil change.
OP says he had the oil changed 200 miles/ 1 week ago. Hence, it should be ok to pour the oil back in there.

Last edited by pcy; 01-28-2013 at 04:07 PM.
Reply With Quote
  #7  
Old 01-28-2013, 09:50 PM
UltimateDriving UltimateDriving is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Oct 2007
Posts: 852
Mein Auto: A Car
Quote:
Originally Posted by pcy View Post
OP says he had the oil changed 200 miles/ 1 week ago. Hence, it should be ok to pour the oil back in there.
Ooops, you are right.
Reply With Quote
  #8  
Old 03-06-2013, 08:05 AM
Zkanaan Zkanaan is offline
zeyad
Location: boston, ma
 
Join Date: Jan 2013
Posts: 17
Mein Auto: 2006 530xi
Thank u
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms