Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-05-2013, 10:46 AM
dakest dakest is offline
Registered User
Location: Florida
 
Join Date: Sep 2012
Posts: 40
Mein Auto: 2006 530i
Adaptive headlights error

My headlights won't move when I start the car, won't move when I turn the wheel and I got this message on idrive, led by light switch blinks.
All I have done recently was move the electronics from the bottom of the spare tire well to the driver's side of the trunk.
I did search but did not find much, help is appreciated.
Reply With Quote
Ads by Google
  #2  
Old 03-05-2013, 12:30 PM
German Steel German Steel is offline
Registered User
Location: Durham NC USA
 
Join Date: Dec 2012
Posts: 65
Mein Auto: 2008 535xi
Quote:
Originally Posted by dakest View Post
My headlights won't move when I start the car, won't move when I turn the wheel and I got this message on idrive, led by light switch blinks.
All I have done recently was move the electronics from the bottom of the spare tire well to the driver's side of the trunk.
I did search but did not find much, help is appreciated.
This might seem simple but consider if the light switch is in the proper position for the directional lights to function. I did not know about this until I read the manual.
Reply With Quote
  #3  
Old 03-05-2013, 12:41 PM
German Steel German Steel is offline
Registered User
Location: Durham NC USA
 
Join Date: Dec 2012
Posts: 65
Mein Auto: 2008 535xi
Quote:
Originally Posted by dakest View Post
My headlights won't move when I start the car, won't move when I turn the wheel and I got this message on idrive, led by light switch blinks.
All I have done recently was move the electronics from the bottom of the spare tire well to the driver's side of the trunk.
I did search but did not find much, help is appreciated.
OK if the switch is at the automatic position, and the LED on the headlamp switch is flashing, and the AHL still not functioning.

See if you can get the system scanned for faults stored related to the AHL system. If no faults are stored and LED is flashing, the problem may be cause by stucked stepper motor in the headlamp.

Someone with a scanner could also put the AHL through its paces to determine which component was faulty.

Last edited by German Steel; 03-05-2013 at 12:43 PM.
Reply With Quote
  #4  
Old 03-05-2013, 01:33 PM
dakest dakest is offline
Registered User
Location: Florida
 
Join Date: Sep 2012
Posts: 40
Mein Auto: 2006 530i
Quote:
Originally Posted by German Steel View Post
OK if the switch is at the automatic position, and the LED on the headlamp switch is flashing, and the AHL still not functioning.

See if you can get the system scanned for faults stored related to the AHL system. If no faults are stored and LED is flashing, the problem may be cause by stucked stepper motor in the headlamp.

Someone with a scanner could also put the AHL through its paces to determine which component was faulty.
The switch is on auto, neither side is moving what are the chances the both head lights have stuck motors?
If they are bad I have to replace the headlights, if so is there a way to override the error messages until I can fix them?

Thanks for your replies guys
Reply With Quote
  #5  
Old 03-05-2013, 04:10 PM
German Steel German Steel is offline
Registered User
Location: Durham NC USA
 
Join Date: Dec 2012
Posts: 65
Mein Auto: 2008 535xi
Quote:
Originally Posted by dakest View Post
The switch is on auto, neither side is moving what are the chances the both head lights have stuck motors?
If they are bad I have to replace the headlights, if so is there a way to override the error messages until I can fix them?

Thanks for your replies guys
Just to let the car have a say about things here, what were the error code #s? I'll try to look them up for you (key word "try")
Reply With Quote
  #6  
Old 03-05-2013, 08:12 PM
dakest dakest is offline
Registered User
Location: Florida
 
Join Date: Sep 2012
Posts: 40
Mein Auto: 2006 530i
Quote:
Originally Posted by German Steel View Post
Just to let the car have a say about things here, what were the error code #s? I'll try to look them up for you (key word "try")
Haven't pulled any codes yet, just getting the idrive message, just a while ago I started the car and the lights moved to self adjust the later got the message on I drive again.
I am baffled....
Reply With Quote
  #7  
Old 03-06-2013, 09:54 AM
pjinca pjinca is online now
USAF Pararescue Veteran
Location: SoCal
 
Join Date: Jun 2009
Posts: 1,897
Mein Auto: 2008 550i
Quote:
Originally Posted by dakest View Post
Haven't pulled any codes yet, just getting the idrive message, just a while ago I started the car and the lights moved to self adjust the later got the message on I drive again.
I am baffled....
Remove the headlights and check the wiring inside, it is known to crumble over time. This might be causing your issue, if there are exposed wires cover them and reinstall and see if the error returns. You may need new SMC modules (located on the underside of the headlight assembly), these can be found on eBay fairly cheap.
__________________

[B]2008 550 - Carbon Black/Black - M-sport, Cold Weather, Premium, NAV, Comfort Access, Logic 7 (LOADED, every option except night vision)

Previous 3 cars (the 550 is my 38th car):
2005 530i - Prem, Sport, NAV
2006 Jeep SRT-8
2003 Infiniti G35 coupe
Reply With Quote
  #8  
Old 03-06-2013, 11:48 AM
dakest dakest is offline
Registered User
Location: Florida
 
Join Date: Sep 2012
Posts: 40
Mein Auto: 2006 530i
Quote:
Originally Posted by pjinca View Post
Remove the headlights and check the wiring inside, it is known to crumble over time. This might be causing your issue, if there are exposed wires cover them and reinstall and see if the error returns. You may need new SMC modules (located on the underside of the headlight assembly), these can be found on eBay fairly cheap.
There is crumbling insulation, I saw it when I replaced my angel eyes, that was a while back, I brushed liquid tape on them.
this issue started a couple of days ago.
The headlights move up and down when I start the car but I don't see any side to side movement when I move the steering wheel.
Reply With Quote
  #9  
Old 03-06-2013, 04:01 PM
peachykonan peachykonan is offline
Registered User
Location: maryland
 
Join Date: Aug 2011
Posts: 13
Mein Auto: 2004 525i
@ GermanSteel - can you please help look up the following fault codes for me? I'm also having AHL issues and would like to know the repair procedure (and parts). I ran over a bump pretty fast which resulted in the following:

Autologic diagnostics quick test report for e60 525i 4 door m54

ADAPTIVE DIRECTIONAL HEADLIGHTS (AHL)

Contains 1 fault

A589 Communication with stepper motor box 1 impaired

LIGHT MODULE (LM)

Contains 1 faults

932E ALC-System defect
Reply With Quote
  #10  
Old 03-09-2013, 09:39 AM
German Steel German Steel is offline
Registered User
Location: Durham NC USA
 
Join Date: Dec 2012
Posts: 65
Mein Auto: 2008 535xi
Quote:
Originally Posted by peachykonan View Post
@ GermanSteel - can you please help look up the following fault codes for me? I'm also having AHL issues and would like to know the repair procedure (and parts). I ran over a bump pretty fast which resulted in the following:

Autologic diagnostics quick test report for e60 525i 4 door m54

ADAPTIVE DIRECTIONAL HEADLIGHTS (AHL)

Contains 1 fault

A589 Communication with stepper motor box 1 impaired

LIGHT MODULE (LM)

Contains 1 faults

932E ALC-System defect
Hi. I tried but using the Bently Publishers Service Manual I could not fiqure anything out. I believe as mentioned in previous posts that you have crumbled insulation on your electrical wires in the headlight assembly and going over the bump cracked them open. You will need to remove the headlight assembly from car and inspect the wiring and repair if that is the problem.
Do you need pics of the service manual to help you remove the headlight assembly?
Reply With Quote
  #11  
Old 12-17-2013, 07:41 AM
BraveHelios BraveHelios is offline
Registered User
Location: Boise, Idaho
 
Join Date: Oct 2012
Posts: 26
Mein Auto: 545i
2004 545i with AHL.

Has anyone ever heard of the LED flashing light by the headlight switch BECAUSE the fog light bulbs were replaced with different wattage (80 vs 51) or anything else concerning the fog lights?

My LED just stated flashing... although I cannot recall if it started flashing when I replaced the fog light bulbs.

Thanks!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms