Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-10-2013, 06:58 PM
Gus the Sig Gus the Sig is offline
Registered User
Location: Tennessee
 
Join Date: Jul 2012
Posts: 52
Mein Auto: 2007 335i
Quick Question

Hey everyone. I just replaced my spark plugs (first time on this car 07 335i) and I did the engine service reset thing on the computer. I did it, though, while the car was running. I see everywhere that people say do it while the ignition is on, not running. Is this going to be a problem? I had to turn the engine off and then back on for the reset to take hold, as I do not see the service light thing. When I start it now, I see the orange car icon which means no service due. So did I mess anything up by resetting the service light for spark plugs while the engine was on? Thanks. I can't find this answer anywhere.
__________________
Rather be driving a BMW.
Reply With Quote
Ads by Google
  #2  
Old 03-10-2013, 07:44 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by Gus the Sig View Post
Hey everyone. I just replaced my spark plugs (first time on this car 07 335i) and I did the engine service reset thing on the computer. I did it, though, while the car was running. I see everywhere that people say do it while the ignition is on, not running. Is this going to be a problem? I had to turn the engine off and then back on for the reset to take hold, as I do not see the service light thing. When I start it now, I see the orange car icon which means no service due. So did I mess anything up by resetting the service light for spark plugs while the engine was on? Thanks. I can't find this answer anywhere.


Have you tried doing it again with the engine off?

You need something like this to be sure you've read all codes.
Reply With Quote
  #3  
Old 03-10-2013, 08:00 PM
Gus the Sig Gus the Sig is offline
Registered User
Location: Tennessee
 
Join Date: Jul 2012
Posts: 52
Mein Auto: 2007 335i
I will try it again with the engine off, but the service lights have gone off. Just making sure that when I did it while the engine running, it didn't mess the computer or engine up any. First time I have ever really messed with the onboard computer. Thank you for your reply.
__________________
Rather be driving a BMW.
Reply With Quote
  #4  
Old 03-10-2013, 08:12 PM
Gus the Sig Gus the Sig is offline
Registered User
Location: Tennessee
 
Join Date: Jul 2012
Posts: 52
Mein Auto: 2007 335i
Just did it again with just the ignition turned on. Reset the oil thing. Forgot to do that. I turn on the ignition now and the Service Engine Light still comes on, not the symbol. I looked through everything and nothing is red or in need of service. Still has the orange car symbol. Any thoughts?
__________________
Rather be driving a BMW.
Reply With Quote
  #5  
Old 03-10-2013, 09:24 PM
Gus the Sig Gus the Sig is offline
Registered User
Location: Tennessee
 
Join Date: Jul 2012
Posts: 52
Mein Auto: 2007 335i
bump
__________________
Rather be driving a BMW.
Reply With Quote
  #6  
Old 03-11-2013, 09:17 AM
furby076's Avatar
furby076 furby076 is online now
IntarWeb Stalker
Location: 95 Feet Under
 
Join Date: Mar 2009
Posts: 8,939
Mein Auto: 2013 335xi M-Sport
Not sure if it's much of help, but whenever I have low air in my tires and then brought them back up, I would reset the light while the engine was on. It always turned off properly. I've also done it while the engine was turned off.
__________________
"Booberry" -ED 2013 335xi | B45 | ZMM | ZDA |Heated Seats | HK |EBII
My Drive Style

Because I can.
-
Quote:
Originally Posted by cwinter View Post
I agree with furby
Quote:
Originally Posted by guerilla twang View Post
Hahahaha, I like you furb, you like to live dangerously.
Quote:
Originally Posted by ProfessorCook View Post
I started to google to find a picture to match furby's suggestion to Gia, but it quickly became clear it was an inappropriate search to conduct at work.
Reply With Quote
  #7  
Old 03-14-2013, 05:44 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by Gus the Sig View Post
bump

Read the codes you can't see on the dash with the "something like this" linked above.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms