Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-11-2013, 06:51 AM
z33max z33max is offline
Registered User
Location: Bulgaria
 
Join Date: Jan 2013
Posts: 14
Mein Auto: BMW E34 520i V24
Exclamation 520i V24 strange RPM problem - SOLVED!

Hey again guys! After few days of researching and testing finally we found the solution of my strange RPM shaking (the car do the harlem shake ) so the problem is Lambda sensor!
We disconnect it and ...... nothing change! Same F@$%@#$%ing problem. The Lambda sensor "bring" information to the MAF sensor of the CO2 level, so the MAF knows if the car need more air or more gasoline. When the Lambda not working them MAF didn't know what to do...and start's to make bull$#@$ts .... So ... here is the moment when I need some help! In my country there is no original Lambda sensor for that car! Only some Chinese fakes. Can anyone help me with that!?
Reply With Quote
Advertisement
  #2  
Old 03-19-2013, 07:12 AM
z33max z33max is offline
Registered User
Location: Bulgaria
 
Join Date: Jan 2013
Posts: 14
Mein Auto: BMW E34 520i V24
So guys! Today I was at full computer diagnostic. In BMW. They check everything that technologies allow. And ... what's the BIG deal with my lambda sensor ... In fact the sensor work fine. (we check it with oscilloscope) but some smart guy move it in the middle of the car!!!!!!! (When they removed the catalyst) and the senor CAN'T reach the necessary temperature for working properly! Here is the picture that I make.


Last edited by z33max; 03-19-2013 at 07:17 AM.
Reply With Quote
  #3  
Old 10-27-2013, 03:46 AM
takis takis is offline
Registered User
Location: grecce
 
Join Date: Oct 2013
Posts: 1
Mein Auto: E36
I have the same problem and not blame the lambda or the MAF.

Last edited by takis; 10-27-2013 at 03:47 AM.
Reply With Quote
  #4  
Old 10-27-2013, 08:31 AM
imae34driver imae34driver is online now
FCK HONDA
Location: Orange County , CA
 
Join Date: Feb 2013
Posts: 2,152
Mein Auto: 1995 540i SPORT /6 spd
Ahahahah.. Getto section of exhaust.. Lol..

Thats your problem!
__________________
1995 540i /6 speed.Black on black. C.A.I/JBR LWFW/ Dinan tune/hi flow exhuast /545 SSK /3.15 with LSD / rev-shift racing motor mounts/stage 4, 6 puck clutch/ K Sport coil overs / 19" BBS LM's / suede sparco 368 steering wheel, Recaro bucket seats, sparco 4 point harnesses, NX wet kit, M/T drag slicks
"Skill can only get you so far, then comes money!"
R . I . P Paul Walker - 1973 - 2013
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms