Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 8 Series - E31 (1989 - 1999)

8 Series - E31 (1989 - 1999)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-13-2013, 02:22 PM
huntbenz huntbenz is offline
Registered User
Location: yuma az.
 
Join Date: Mar 2013
Posts: 5
Mein Auto: 840CSI
840csi

I have owned this BMW for a few weeks.It ran good when i first ran it.It has devloped a rought idle.I replaced the valve cover gaskets they were leaking.I have replased the plug wire off the coils And replaced the plugs NGK.Sprayed injectors with carb spray.Seamed that 1 injector had vacume leak.Pulled our injectors and they were all carbon up.So replaced them with rebuilt ones.I still have the rough idel.Off idle it runs great.The check engin light was on and whean i drove it went off.At idle it will go on.Whats up dose any body no what the matter with the idle.I was going to pull of the battery but then i have to get the code from BMW.This car is awsome i love it.
Thanks Rick
Reply With Quote
Advertisement
  #2  
Old 03-14-2013, 06:26 AM
02540ico 02540ico is offline
Officially Welcomed to the 'Fest
Location: Colorado Springs, Co
 
Join Date: Aug 2009
Posts: 278
Mein Auto: 1997 850Ci
So, you have a '95 840Ci that has an S70 V12 CSi engine/6spd transplant? Or does it have the factory V8?
Either get a code reader, or take it to Autozone and have the codes read. Otherwise, you'll waste a ton of cash just throwing parts at it.
Have you checked/changed the air filter? Cleaned the MAF?
__________________
http://www.bimmerfest.com/forums/image.php?type=sigpic&userid=163865&dateline=1256592405
Reply With Quote
  #3  
Old 05-05-2013, 09:25 AM
edes300 edes300 is online now
Registered User
Location: pittsburgh,pa
 
Join Date: Jul 2011
Posts: 79
Mein Auto: 2008 535XI
840csi

I would consider cleaning the MAF and throttle body. Another area in other types of cars that causes problems is the idle air control valve. I'm not sure if this car has one but usually it's connected to the throttle body.


Sent from BimmerApp mobile app
Reply With Quote
  #4  
Old 05-18-2013, 03:43 PM
huntbenz huntbenz is offline
Registered User
Location: yuma az.
 
Join Date: Mar 2013
Posts: 5
Mein Auto: 840CSI
840 ci

This BMW is one of the best looking of all BMW!
Reply With Quote
  #5  
Old 05-18-2013, 03:49 PM
huntbenz huntbenz is offline
Registered User
Location: yuma az.
 
Join Date: Mar 2013
Posts: 5
Mein Auto: 840CSI
Miss a idle when first start

Quote:
Originally Posted by edes300 View Post
I would consider cleaning the MAF and throttle body. Another area in other types of cars that causes problems is the idle air control valve. I'm not sure if this car has one but usually it's connected to the throttle body.


Sent from BimmerApp mobile app
The fuel rail had vary small fuel leak.Thank you for your help!
Reply With Quote
  #6  
Old 05-31-2013, 10:29 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by huntbenz View Post
The fuel rail had vary small fuel leak.Thank you for your help!
Really?? That was the cause of the bad idling??? 99% it's intake vacuum leak, it gets unmetered air therefore engine runs lean but O2 sensors make it run rich to compensate.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 8 Series - E31 (1989 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms