check engine light- increased emissions - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2013, 07:08 AM
bmwrulez bmwrulez is offline
d'oh!!
Location: Hickory,NC
 
Join Date: Nov 2008
Posts: 12
Mein Auto: 08 550i, 04 Z4
Thanks for the info on testing the thermostat. Found out i replaced a good thermostat. Oh well. But, does the same process apply for testing ohms on water pump? I'm getting a 1 when testing.

Sent from my SCH-I535 using Bimmer App
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2013, 09:51 AM
bmwrulez bmwrulez is offline
d'oh!!
Location: Hickory,NC
 
Join Date: Nov 2008
Posts: 12
Mein Auto: 08 550i, 04 Z4
Update: Replaced the thermostat again with an OEM part, due to recommendation of indy mechanic. Fixed my problem!!!!! Driven over 500 miles & no MIL.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.