Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-28-2013, 07:45 PM
ozabani ozabani is offline
Registered User
Location: Ohio
 
Join Date: Dec 2013
Posts: 7
Mein Auto: 2007 525i
2007 525i ENGINE OVERHEAT, NO HOT AIR, FAN TURNS 1 QUARTER ONLY

Hey there everyone, I am new to this forum and I always know I can rely on this website therefore I joined.

I have a 2007 525i with almost 90K miles, about 2 weeks ago I noticed that sometimes when I would turn my car off the "angel eyes" would not turn off and the air would keep blowing inside of the car and radio would be on, even though nothing would alert me (like the beeping sound if you leave your lights on and they were on auto so they should turn off by themselves) Id just open the car again and turn they ignition on and off and it would go away like everything would turn off as it is supposed to when I turn my car off, that happened about three times in a months time.

Yesterday (12/27/2013, after about 20 minutes driving my car, an alert came on saying "Engine is too hot, drive moderately to allow engine to cool down". About 1 minute later, another warning popped up saying, "Engine overheated, stop and park the vehicle immediately and allow engine to cool down, contact your BMW dealer", I also noticed later that when I turned the heater on inside of the car, the left side (drivers side) would not turn hot, it would blow air but no hot air was coming from it, the right side (passenger's side) seemed to be warm, but drivers side, both outlets were cold.

So ok, I checked coolant, and it was almost at low level so I unplugged the bottom part by the hose with that sensor and let it drain out and refilled all the way to max, that didnt do the trick. I stopped car, opened hood and checked to see fan, the front fan I believe main fan would try to start turning, like with a certain struggle, it would like, kick on slow turn about 1/4 to 2/4's of the way and stop, that would happen about 8 times until car would get hot and then I would hear the fan working insanely, like at a desperation mode so it seemed. Usually I never hear the fan in my beemer, its pretty quiet, but once the engine overheated, then it would come on full blast like it was a storm under my hood and loud as ****. It didn't seem to want to shut off either, I find it weird because it wouldn't turn on at first, it would want to turn but seemed like it was weak like didn't have the strength to turn, then when it came on full blast and angry sounding it didnt seem to cool engine down.

What could be wrong with this car? Recap, engine overheating, drivers side of the heater not blowing hot air, now seems like passengers side is not working as well, not sure. Fan wants to start turning normally but it wont, it seems weak, not wanting to turn, turns 1/4 to 2/4s of the way then stops then when engine overheats, fan comes on insanely and angry sounding, like a storm under the hood, also fan will not cool engine down and seems like it wont shut off.

SORRY for long thread, please help?
Reply With Quote
Advertisement
  #2  
Old 12-28-2013, 08:08 PM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,628
Mein Auto: '06 530i, '07 C280, ML320
Recharge the battery.
Buy new water pump and thermostat and replace both.
Reply With Quote
  #3  
Old 12-29-2013, 01:50 AM
kskane's Avatar
kskane kskane is online now
From DownUnder
Location: Australia
 
Join Date: Oct 2009
Posts: 722
Mein Auto: '04 525i M54 with 6HP19Z
Re: 2007 525i ENGINE OVERHEAT, NO HOT AIR, FAN TURNS 1 QUARTER ONLY

Quote:
Originally Posted by pcy View Post
Recharge the battery.
Buy new water pump and thermostat and replace both.
+1. And also some silicon based grease as lubricant for gasket and O-ring.

Sent from my Droid bug
Reply With Quote
  #4  
Old 12-29-2013, 06:33 AM
banglenot banglenot is offline
Officially Welcomed to the 'Fest
Location: Ft. Lauderdale and Connecticut
 
Join Date: Feb 2004
Posts: 1,854
Mein Auto: 2007 530
As pcy says, 100% that your electronic water pump is failing, or more likely has failed.

But just want to add: Stop driving it and fix it. Don't drive it again until it's fixed. Unlike the E46, this engine doesn't warp the head almost immediately when the pump fails, but you're taking a huge risk every time you run it.

Read the "So you just bought" sticky at the top of the page for more details and other useful items on the car.
__________________

2007 530I
2003 325XI (gone)
2004 530I (gone)
2001 530I (gone)

BMW CCA Member 10+ Years
Reply With Quote
  #5  
Old 12-29-2013, 01:17 PM
ozabani ozabani is offline
Registered User
Location: Ohio
 
Join Date: Dec 2013
Posts: 7
Mein Auto: 2007 525i
thanks, I am going to buy a new water pump, quick question tho, how can I be absolutely sure that it is the water pump? what about my heater not coming on? the fan spinning slow lie struggling and then all of a sudden coming on full blast? like mad man.

Last edited by ozabani; 12-29-2013 at 01:20 PM.
Reply With Quote
  #6  
Old 12-29-2013, 04:22 PM
banglenot banglenot is offline
Officially Welcomed to the 'Fest
Location: Ft. Lauderdale and Connecticut
 
Join Date: Feb 2004
Posts: 1,854
Mein Auto: 2007 530
Quote:
Originally Posted by ozabani View Post
thanks, I am going to buy a new water pump, quick question tho, how can I be absolutely sure that it is the water pump? what about my heater not coming on? the fan spinning slow lie struggling and then all of a sudden coming on full blast? like mad man.
Don't know. Do the pump. It's broken. There's nothing else that causes the indicator and main fan cycling symptoms you have.

Do what you know is wrong. Then move to the next thing.

After that, check the battery (like pcy said), and likely replace it if it's the original. But the pump is shot. New one and thermostat, since you're under there.

The "so you just bought" has a couple of vid references to get you started.
__________________

2007 530I
2003 325XI (gone)
2004 530I (gone)
2001 530I (gone)

BMW CCA Member 10+ Years

Last edited by banglenot; 12-29-2013 at 04:30 PM.
Reply With Quote
  #7  
Old 12-29-2013, 10:27 PM
ozabani ozabani is offline
Registered User
Location: Ohio
 
Join Date: Dec 2013
Posts: 7
Mein Auto: 2007 525i
awesome, I will do that, anyone knows where to get a pump and thermostat cheap?
Reply With Quote
  #8  
Old 12-30-2013, 08:34 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,628
Mein Auto: '06 530i, '07 C280, ML320
Check on amazon.
Buy NEW Pierburg pump only. Don't buy remanufactured unit or any other brand.
Reply With Quote
Reply

Bookmarks

Tags
2007 525i, 525i 2007, fan noise, fan operation, no heat from vents, over heating, overheat, warning lights


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms