Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-19-2013, 07:58 PM
Wildbill 528i Wildbill 528i is offline
Registered User
Location: Georgia
 
Join Date: Mar 2013
Posts: 2
Mein Auto: 1998 BMW 528i
1998 528i E39150,00 miles ABS, ASC light shift issues

My ABS and ASC light both came on at the same time after driving 11 miles.. The asc light would not turn off when depressed. Car operated fine the remaining 6 miles to work. When I started home the lights were not on at first. Before leaving the parking lot both lights came on again. This time when I started to leave the transmission would not shift from first gear. I came to a full stop and tried again, same results. I then shifted in 1 and accelerated slowly then shifted to 2, transmission shifted fine, then shifted to 3 and shift was good. I had to do this each time from a full stop. After I reach some speed placed in D and transmission shifted into the overdrive.I can start the car sitting in garage and no abs and asc light. After running for a few minutes both will came on. This is without the car moving. Also speedometer and tach work fine and no transmission limp indicator illuminated. Sorry for the lengthy description.
Reply With Quote
Advertisement
  #2  
Old 03-19-2013, 08:41 PM
2000bmwe39 2000bmwe39 is offline
Registered User
Location: florida
 
Join Date: Mar 2013
Posts: 4
Mein Auto: 2000 bmw 528i
i will start with scanning to make sure but the problem you have is one of the 4 or more than one of the abs sensor are bad this is the front side(2) number 7 on the picture http://www.realoem.com/bmw/showparts...19&hg=33&fg=30 this is the rear side(2) number 24 on the picture
Reply With Quote
  #3  
Old 03-20-2013, 10:08 AM
L0F L0F is offline
Registered User
Location: chicago
 
Join Date: Nov 2011
Posts: 90
Mein Auto: 3/98 528i
I had a similar issue a year ago, it was my front right wheel speed sensor. Don't cheap out on sensors either, cheap Chinese ones will not be built to the proper tolerances.
Reply With Quote
  #4  
Old 03-20-2013, 05:25 PM
Wildbill 528i Wildbill 528i is offline
Registered User
Location: Georgia
 
Join Date: Mar 2013
Posts: 2
Mein Auto: 1998 BMW 528i
Smile

Thanks to all. Here is a new one. I crawled under vehicle to look at the location of the sensor. Mud was caked up on the passenger side front. I took a hose and washed off the best that I could. Drove to car to work today no lights or shift issues. She will get a wheels off cleaning a.d inspection this weekend.
Again thank to all.
Reply With Quote
  #5  
Old 03-20-2013, 05:34 PM
L0F L0F is offline
Registered User
Location: chicago
 
Join Date: Nov 2011
Posts: 90
Mein Auto: 3/98 528i
The insulation on your sensor is probably frayed and the wiring is shorting out if it gets wet. If it rains before you get a chance to clean and inspect the assembly take your car for a drive and see what happens.

Last edited by L0F; 03-20-2013 at 10:14 PM.
Reply With Quote
  #6  
Old 03-20-2013, 06:23 PM
2000bmwe39 2000bmwe39 is offline
Registered User
Location: florida
 
Join Date: Mar 2013
Posts: 4
Mein Auto: 2000 bmw 528i
Hey wildbill528i but what L0F told you about "Don't cheap out on sensors either" he is right find the good ones because you will waste your time
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms