Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-19-2013, 10:14 PM
benzbenz benzbenz is offline
Registered User
Location: LA
 
Join Date: Jun 2009
Posts: 3
Mein Auto: 2005 X5 3.0i
2005 x5 3.0 check engine light on with r5/FCC fault code table19 5e

I checked the error code table 19 ,5e secondary air system,air mass.
What does it mean, I replaced Maf but the error code came back after I reset it.
Reply With Quote
Ads by Google
  #2  
Old 03-20-2013, 09:43 AM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 498
Mein Auto: BMW, Lotus, Porsche
It's part of the AIR PUMP F VACUUM CONTROL system. Here an illustration of the system.

Reply With Quote
  #3  
Old 03-20-2013, 06:23 PM
benzbenz benzbenz is offline
Registered User
Location: LA
 
Join Date: Jun 2009
Posts: 3
Mein Auto: 2005 X5 3.0i
thanks for your reply.
but what does falt code: table 19, code 5e mean?
it's said : secondary air system: air mass. what does it mean? which part is wrong?
The car runs ok, I don't feel any difference. well, it's my wife's car, I don't drive it daily, maybe there is something wrong but I couldn't feel it.
thanks in advanced.

Last edited by benzbenz; 03-20-2013 at 06:25 PM.
Reply With Quote
  #4  
Old 03-21-2013, 05:54 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 839
Mein Auto: 2001 X5 3.0L
Check everything in the SA system. Start with the vacuum hoses which are the most likely to fail and cheapest to replace. The system only works on cold starts for a few minutes and uses a pump that will squeal like a Shopvac when the pump is the problem. (Item #1)
The image above is from RealOEM.com Work your way through the parts. I know a $7 length of vacuum hose from Autozone cured my SA problem. You may also want to do a Search on xoutpost.com as the SA system is covered there in many posts.
GL.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms