self leveling suspension inactive - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2013, 04:45 AM
lachapellerj lachapellerj is offline
Registered User
Location: RI
 
Join Date: Nov 2012
Posts: 1
Mein Auto: 2005 x5 4.4i
self leveling suspension inactive

2005 4.4 X5 - got the error msg, car sitting on axle - battery went dead a day later. Replaced battery, no change....drove 150 miles and during the course of the trip the error msg went out and vehicle at proper height. The vehicle sat overnight and the next day the error msg came back but now the vehicle is perched up like a hawk looking for dinner.....the compressor obviously works, the air bags are fine...level sensors or module????
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-25-2013, 04:03 AM
jarden jarden is offline
Registered User
Location: ireland
 
Join Date: Mar 2013
Posts: 1
Mein Auto: 01 x5
Hi..i hav same problem with my 01x5..i replaced the 2 self leveling sensors and light went out on dash..but jeep is sitting up high on back now..very hard to drive on roads..maybe its air pump relay..if any one cud tell me wher this is located on jeep...

Sent from my GT-I9100 using Bimmer App
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.