Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-23-2013, 08:06 PM
RoxyBMW RoxyBMW is offline
Bimmer Lady
Location: California
 
Join Date: Nov 2012
Posts: 27
Mein Auto: 525i
Rear window defrost not working

Hello, i have tried getting my rear window defrosted early in the morning but its not working. I press the button to turn it on but the light next to the button doesnt come on nor does it defrost window
Reply With Quote
Ads by Google
  #2  
Old 03-23-2013, 08:42 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Check fuse #28. It may be blown. If so, replace it.

There is also a rear defogger relay in the rear power distribution box located under the rear seat cushion. You don't tell us what year your car is. This is important because the relay location in the 89 and 90 models are a little different than the 91 and later models.

If you have the Bentley manual, take a look at page 610-2 for details.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #3  
Old 03-24-2013, 10:24 AM
RoxyBMW RoxyBMW is offline
Bimmer Lady
Location: California
 
Join Date: Nov 2012
Posts: 27
Mein Auto: 525i
My car is a 1995 525i.
Reply With Quote
  #4  
Old 03-24-2013, 10:26 AM
RoxyBMW RoxyBMW is offline
Bimmer Lady
Location: California
 
Join Date: Nov 2012
Posts: 27
Mein Auto: 525i
Thank you so much. I will take a look at that page. Im very ignorant on finding my way around this book. Roxy
Reply With Quote
  #5  
Old 03-24-2013, 10:31 AM
Alnlesley Alnlesley is offline
Registered User
Location: Prince Rupert
 
Join Date: Feb 2013
Posts: 25
Mein Auto: 91'bmw ac schnitzer
Its probably fuse under the back seat. You might have to remove a few screws to take the plastic cover off covering the fuse panel. I had the same issue an it was the fuse on my 91 e34.
Reply With Quote
  #6  
Old 03-24-2013, 11:00 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Quote:
Originally Posted by RoxyBMW View Post
Thank you so much. I will take a look at that page. Im very ignorant on finding my way around this book. Roxy
Page 610-2 shows where the relay location is, but not the fuse location. The fuse location is on page 610-1. The fuse is located in the front power distribution box which is on the driver's side behind the strut tower.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #7  
Old 03-24-2013, 11:44 AM
manuelwindows manuelwindows is offline
Officially Welcomed to the 'Fest
Location: Eugene, Oregon
 
Join Date: Oct 2012
Posts: 134
Mein Auto: 1994 530i, 1977 320i
is this also happening in conjunction with the AC not working? check to make sure. if the AC is also not working as well or that light there by the AC or the Recirc button are blinking or lighting up orange instead of green, then most likely not the fuses and instead it is the IHKR, which is your climate control module and which is the "brain" that controls the rear defrost, AC and recirc buttons and it can get a little corroded and sometimes just needs to be cleaned.

I had this problem a little while ago. It was the IHKR.

(I have a '94 530i which might have a different climate control module than your car. You might have the "sword" as a climate control module which looks more like this one on eBay here that came from a '94:

http://www.ebay.com/itm/E34-525i-530...item2579ed66eb

There seems to be significant variation within models on this. whether it is called an "IHKR" or "climate control module", or the "sword" can be different between years and the ease of pulling it out from behind the controls in the dash can also vary widely I learned when I had this problem. But it turned out I didn't need a new one but that I just needed to clean the corrosion on my existing one with a toothbrush. Bentley's will tell you which you have and how to remove it. I found some replacements for about $75 for the particular IHKR my car has but I didn't need to purchase one.


Could also be the #28 fuse in the front box or the relay by the fusebox under the back seat, as previously mentioned but that would just be too easy

Last edited by manuelwindows; 03-24-2013 at 11:56 AM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms