Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-26-2013, 10:17 AM
Markjo92 Markjo92 is offline
Registered User
Location: Essex
 
Join Date: Feb 2013
Posts: 2
Mein Auto: BMW x5
X5 shuddering when under power!!!!

Hi
I'm hoping somebody has the answer? I have an 2000 x5 4.4 which has started to shudder/wobble once warm from about 30/40 mph when under power, when you take foot off the accelerator it's smooth ride...... I have had new tyres, and balanced all round- still did not solved the problem. Have been to two independent mechanics, both have test drove it, had it on the ramps etc and cannot find why the car wobbles!

I would be grateful for any advise!

Thank you
Reply With Quote
Ads by Google
  #2  
Old 03-13-2013, 09:43 AM
trfraser trfraser is offline
Registered User
Location: knoxville tn
 
Join Date: Mar 2013
Posts: 9
Mein Auto: 2001 x5 4.4i
Something called the GUIBO . Mine was doing the same thing. I had it replaced now it is smooth.
Reply With Quote
  #3  
Old 03-15-2013, 05:00 AM
Markjo92 Markjo92 is offline
Registered User
Location: Essex
 
Join Date: Feb 2013
Posts: 2
Mein Auto: BMW x5
Thank you, I will look into that....was it expensive to fix!
Reply With Quote
  #4  
Old 03-15-2013, 07:07 AM
trfraser trfraser is offline
Registered User
Location: knoxville tn
 
Join Date: Mar 2013
Posts: 9
Mein Auto: 2001 x5 4.4i
No , seems like it was around 280.00 with labor with an indi mechanic .
Reply With Quote
  #5  
Old 03-18-2013, 12:51 AM
flyace20 flyace20 is offline
Yippikayaaaay
Location: Australia
 
Join Date: Mar 2013
Posts: 54
Mein Auto: 2002 X5 4.4
Could you post your thoughts when you get it fixed?
I have exactly the same problem with mine as well. A couple of mechanics I've asked don't have a clue what it is and the parts guy at BMW service centre had no idea either.
Reply With Quote
  #6  
Old 03-18-2013, 12:53 AM
flyace20 flyace20 is offline
Yippikayaaaay
Location: Australia
 
Join Date: Mar 2013
Posts: 54
Mein Auto: 2002 X5 4.4
Quote:
Originally Posted by trfraser View Post
Something called the GUIBO . Mine was doing the same thing. I had it replaced now it is smooth.
What is this GUIBO thing. I have the X5 service manual and never came across this acronym...
Reply With Quote
  #7  
Old 03-18-2013, 07:04 AM
trfraser trfraser is offline
Registered User
Location: knoxville tn
 
Join Date: Mar 2013
Posts: 9
Mein Auto: 2001 x5 4.4i
Have you tryed to google it ? Its also called a flex disc.. Pull up google and type in guibo replacement e53.. or something like that...
Reply With Quote
  #8  
Old 03-24-2013, 11:38 PM
flyace20 flyace20 is offline
Yippikayaaaay
Location: Australia
 
Join Date: Mar 2013
Posts: 54
Mein Auto: 2002 X5 4.4
cheers I found it. so you had the same problem and when you changed the guibo, it never happened again?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms