Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-15-2014, 12:47 PM
Tyler199 Tyler199 is offline
Registered User
Location: SC
 
Join Date: Feb 2014
Posts: 2
Mein Auto: 2001 X5
BMW X5 Brake Noise. HELP

I recently acquired a 2001 X5 and the rotors were so terrible that when braking the car felt like you were riding a paint agitator. It was ridiculously violent. The day I got the car, I replaced the front rotors and reinstalled the existing pads with the brand new rotors. I didn't apply lube to the pads(not sure about doing this really) but I did lube the slide pins. The rotors are Wearever rotors from Advance auto parts. After installing the new rotors, all seemed well. However it began making this squeaking noise while driving and NOT under braking. It is a very rhythmic sound, it's tempo increases directly proportional to the wheel speed. Also there is a slight grinding when braking lightly. It sounds like the pads are made of some very abrasive material such as concrete. Also a slight popping/craking sound happens sometimes when braking like a bushing or something is bad. The grinding stops under heavy braking as well as no braking. The sqwuaking squeaky sound is dormant for about sixty seconds after the pads and rotors have cooled all night. Before I even get to the main road(takes slightly more than 1 minute) the sound has begun for the day and will not cease again until the next morning(again for only one minute). Other issues with the car include the "trifecta" or whatever will the instrument cluster looking like a christmas tree. My ABS, BRAKE(yellow), Traction control, (some light I'm not sure the name of but has to do with ABS braking speedo stuff). Speedo doesn't work. I have since replaced the new rotor with another new rotor and nothing changed... This is on the front passenger side. Please help me. I'm thinking it could be a bad caliper maybe?
Reply With Quote
Advertisement
  #2  
Old 02-15-2014, 03:39 PM
dpbayly dpbayly is offline
Registered User
Location: UK, Cambs
 
Join Date: Dec 2008
Posts: 27
Mein Auto: 2001 E53 4.4
You should never have refitted the old pads that had worn to the old rotors to you brand new rotors thats probably the root of your noise problem,

I'd suggest getting a brand new set of pads.

Last edited by dpbayly; 02-15-2014 at 04:49 PM.
Reply With Quote
  #3  
Old 02-15-2014, 05:43 PM
Tyler199 Tyler199 is offline
Registered User
Location: SC
 
Join Date: Feb 2014
Posts: 2
Mein Auto: 2001 X5
Quote:
Originally Posted by dpbayly View Post
You should never have refitted the old pads that had worn to the old rotors to you brand new rotors thats probably the root of your noise problem,

I'd suggest getting a brand new set of pads.
Thanks man
Reply With Quote
  #4  
Old 02-15-2014, 06:43 PM
lahermano lahermano is offline
Registered User
Location: california
 
Join Date: Jul 2011
Posts: 38
Mein Auto: x5
Quote:
Originally Posted by dpbayly View Post
You should never have refitted the old pads that had worn to the old rotors to you brand new rotors thats probably the root of your noise problem,

I'd suggest getting a brand new set of pads.
I second that... Its an absolute mistake to reuse pads.. on new rotors.

The pads might be semi metallic, which are typically stock on x5, that's the worst problem right there with new rotors and old warped semi metallic pads..

I recommend.. ceramic pads. I had used Akebono pads.. and its been great for over 2 yrs and am happy with them.
Reply With Quote
Reply

Bookmarks

Tags
brake, grind, noise, rotor, squeak, x5


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms